Compile OpenWrt on RaspberryPI, too slow?

Has anyone ever tried to use a RaspberryPI 4B with 2(or 4)Gb of RAM to compile a build? It will takes 4/5 hours or more?

Because I want to use it as a build environment. But I’m scared that is too slow also only to try.


Have not tried but it will take ages would be my guess. RPi4 is basically a cell phone. What is your use case? The whole point of cross compiling is to build binaries/images for less-powered hardware on more powerful hardware :smiley:

1 Like

Because at the moment I don’t have any other Linux machines, I have a MacBook but with few space on the SSD (and it’s complicated to build the environment on macOS), and I have a spare Raspberry PI 4…
But as you saying, it will take at least 4/5 hours I think.

Never mind, I’ll buy something more powerful, like a mini pc for Linux.

never managed to sign up for the free public cloud host ?

Ahah not yet, do you have another option/VPS on the free plan that has a decent speed? (In addition to Oracle)


I think only Oracle have free for life, the others - Amazon, MS, Google, are (generously, 1y ?)
limited, but I haven't tried any of them.

Oracle also offers ARM, with 4 cores, but I don't know if Openwrt would cross compile on those.

1 Like

I have been using the free Ampere 4 core/24GB from Oracle to roll out CI builds of OpenWrt and it works great


Thanks for letting us know, do you know the compile time?

The OpenWrt build environment on Debian takes ~10GB once built.

Use UTM to get a VM running, then follow the build guide.

Alternatively, clone the OpenWrt GitHub repo, and use GitHub Actions to set your build up. ubuntu-latest image, then in a few steps, you can install all the build tools you need, clone the repo, and run the build steps. @robimarko's repo has the basic steps outlined (just make sure you change the target from ipq807x to whatever you need):


Nearly 1h on the oracle 4 ampere cores

On Pi4: ~4-5h


Compilation is inevitably a disk-bound activity: assuming you're using microSD storage, that's going to be your bottleneck right there. Also, a crazy amount of wear: microSDs aren't really made for hours and billions of tiny writes, which is what compiling an entire embedded system amounts to. The CPU on the other hand, while no powerhouse, is remarkably decent and well up to the task. Get a USB3-attached SSD and it's a much more reasonable proposition.

The RPi4 will be working a lot harder once this bottleneck is removed, and will need a heatsink and/or (preferably and) some moving air over it. Just plopping it behind a desktop's PSU fan outflow works for this purpose.

(I had a spare 180GB Intel 80mm m.2 left over after a laptop upgrade so I got a USB enclosure for it. It's very handy for this sort of thing.)

1 Like

I don't know what I'm doing doing wrong but the Oracle website is terrible, I'm unable to login or use it. And is not my fault, I also added my credit card etc... but I can't use the website with 3 browser, I'm trying to login with the default link and the login doesn't work, when I ask for a password reset I don't receive email.

I don't know what's the issue, I can't "operate" on Oracle website, maybe I'm stupid but that is... I'm going crazy!


it's not the most logical site on earth (haven't tried the other cloud vendors, might be just as messy),
but wait until you are setting up internet access for your hosts :slight_smile:

I've saved this link for logging in (not email address)

Yes but is the same, is the link I was following, I got always an error and if I try to ask for a password reset, nothing is arriving to my inbox/spam/whatever. Oracle website is driving me crazy, I quit with it.

I'm trying with UTM, I have also two VPS on DigitalOcean but they are the defaul ones,
/ 1 GB Memory / 25 GB Disk / FRA1 - Ubuntu analytics 2022-10-21

I think it will takes more or less the same (infinite) time as the Raspberry PI.

Be glad that you only have to deal with them as a hobby and are not punished professionally with their unnecessarily complex products.

I also had problems with the password for Oracle Cloud. The problem with me was: There is a cloud account name and an email address as login - these are not the same!
The procedure for me to log in therefore runs like this:

  1. I am asked for the username - I have to enter my cloud account name (not the e-mail adress!)
  2. then I am asked again for username and password. But here I have to fill in the e-mail address - the cloud account name does not work here!
  3. enter the password.

Maybe it helps


Damn! Finally, this is very stupid, now I entered inside this stupid console interface, thanks.

What a silly thing, you have to register to one site, then login, then login again to the cloud service, and I was doing it with the just filled username, but with another username (your email), and there isn't specified somewhere that now your username is your email. Bah... that's absurd!

Anyway thanks for the help :smiley:

There is no rational explanation for such bullshit.
Therefore, there must be another reason for it. I guess it is some kind of test if you are able to solve even absurd problems by yourself. If so, and you make it through the application process, they can be sure that you won't bug them about trivial questions...

1 Like

or you're smart enough to be offered a job with them :wink:

1 Like

Anyway is working, and looks fast, thanks for the support with the Oracle "bullshite" :slight_smile:


Done, less than 1h if someone is interested! Thanks also to @frollic for the suggestion of the Oracle Cloud Service, now I have only to monitor that I don't go outside the free plan because I inserted my credi card details :sweat_smile: