Compile 'kmod-mt7610e' for MT7610EN


I have an Archer C2 with an MT7610EN. To get the wifi 5G successfully working I had to install a version of OpenWRT with 'kmod-mt7610e' that I found on internet "Designated Driver 50147 (kernel: 4.4.14)".

Currently I have installed "OpenWRT SNAPSHOT r8448-81d7f82 (kernel 4.14.79)" but wifi 5G is not working anymore. I tried to run "$opkg install kmod-mt7610" but the output is "Unknown package 'kmod-mt7610'.

Is it possible to compile [] by myself? I have never compiled anything related to OpenWRT. Can I extract a binary 'kmod-mt7610e' from another release and use it in a different one? will my mt7610e work in my current release or in future releases?

Thanks in advance,


1 Like

I believe this driver is already available for be added to any target which has this chip.
There is a pull request ( waiting for an specific router (DIR810L) but I believe it can work the same for any other which has the same chip, only wanting for someone to send pull requests.

1 Like

@barrenaedu I have an Archer C20 with MT7610E too, the Presisco mtk drivers and Noissac mtk drivers doesn't work now for recent releases of openwrt and lede builds.

As @musashino correctly pointed, the mt76 kmod module that now supports the MT7610E wifi chip is kmod-mt76x0e. For now, you need to install manually on a trunk build image or compile manually from trunk and enable the kmod-mt76x0e in menuconfig. The MT7610E support in the mt76 driver is very recent, and still have performace issues, but the mt76 gets updated very frecuently, so i hope that the MT610E get good support soon

1 Like

Hello @Mynzer
Thanks for the report.

Apart from the performance issues have you observed any instability issues ?
Also were you able to test multiple SSIDs to see if has problems as it currently happens on MT7628 ?

1 Like

It works!! Thank you!

@musashino, @ffredy, @Mynzer Thanks for comment :slight_smile:

It is working fine, no instability issues so far 1 2

I also tried kmod-mt76x0e on a TL-WR902AC V3. I had to install it manually on the device.

The driver seems to work and I can transfer traffic, but after a couple of minutes the WLAN just disappears. Restarting the the WLAN with the wifi command brings it back for some minutes until it vanishes again.

There is nothing logged to syslog or dmesg. It just stops responding.

Update 21.11.2018: I tried with the last fixes in trunk and it now seems to work.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.