Clients on same wlan can't see each other

Device Info -

Devices on my 5Ghz WLAN (wlan0) can't see each other but they can see all the rest of the devices on the network. Devices on my 2.5Ghz WLAN (wlan1) don't have this issue.

I went through this topic and found that for some reason ap_isolate is set to 1 in /var/run/hostapd-phy0.conf even though in LUCI it is unchecked.

Anyone know how I can begin to diagnose what is going wrong here?

SSH in to the router and run cat /etc/config/wireless.

Redact the passwords in the "option key" sections.

Post the results in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

1 Like
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'US'
        option cell_density '0'
        option rts '500'
        option channel 'auto'
        option distance '40'
        option htmode 'VHT160'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid '<redacted>-5G'
        option encryption 'psk2'
        option key '<redacted>'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT40'
        option channel 'auto'
        option country 'US'
        option cell_density '0'
        option rts '500'
        option distance '40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid '<redacted>'
        option encryption 'psk2'
        option key '<redacted>'
        option network 'lan'

Values <100 (less than one-hundred) do not work.

I assume you removed that?

If so, you need to run /etc/init.d/network reload after you saved the wireless config file.

I didn't. It is set for both of them and 2.5Ghz is working, so obviously it isn't as simple as setting ap_isolate to 0, there seems to be other dependent settings.

Here are the hostapd conf files:

/var/run/hostapd-phy0.conf (5Ghz)

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=US
ieee80211d=1
ieee80211h=1
hw_mode=a
beacon_int=100
dtim_period=2
channel=acs_survey


tx_queue_data2_burst=2.0
ieee80211n=1
ht_coex=0
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40]
ieee80211ac=1
vht_oper_chwidth=2
vht_oper_centr_freq_seg0_idx=acs_survey
vht_capab=[RXLDPC][SHORT-GI-80][SHORT-GI-160][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][VHT160-80PLUS80][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7]

radio_config_id=778556808b4b83b3176e579e8bee07fd
interface=wlan0
ctrl_interface=/var/run/hostapd
ap_isolate=1
bss_load_update_period=60
chan_util_avg_period=600
disassoc_low_ack=1
skip_inactivity_poll=0
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
utf8_ssid=1
multi_ap=0
wpa_passphrase=<redacted>
wpa_psk_file=/var/run/hostapd-wlan0.psk
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=<redacted>-5G
bridge=br-lan
wpa_disable_eapol_key_retries=0
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
dynamic_vlan=0
vlan_naming=1
vlan_file=/var/run/hostapd-wlan0.vlan
config_id=f7d80dc3f4510153537e64c67845d4cb
bssid=3c:37:86:1f:2f:20

/var/run/hostapd-phy1.conf (2.5Ghz)

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=US
ieee80211d=1
hw_mode=g
supported_rates=60 90 120 180 240 360 480 540
basic_rates=60 120 240
beacon_int=100
dtim_period=2
channel=acs_survey



ieee80211n=1
ht_coex=0
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40]

radio_config_id=0b8937ab1a57bf1127ae1ec2dd15f422
interface=wlan1
ctrl_interface=/var/run/hostapd
ap_isolate=1
bss_load_update_period=60
chan_util_avg_period=600
disassoc_low_ack=1
skip_inactivity_poll=0
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
utf8_ssid=1
multi_ap=0
wpa_passphrase=<redacted>
wpa_psk_file=/var/run/hostapd-wlan1.psk
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=<redacted>
bridge=br-lan
wpa_disable_eapol_key_retries=0
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
dynamic_vlan=0
vlan_naming=1
vlan_file=/var/run/hostapd-wlan1.vlan
config_id=d56e074e90535880d066cb43f18e76ed
bssid=3c:37:86:1f:2f:21

If two devices A and B are connected to same wifi via access point C, and if A pings B. will those packets be directly picked up by B or will they be captured by C and then retransmitted such that B can capture them?

Actually, it works for my devices.

I have 5 Ghz set at 30 meters, and 2.4 Ghz set at 90.

I assume the access point handles traffic between devices. The only way they would not use the access point if they were a mesh device network. I don't have any mesh devices.

Am I missing something and you're trying to direct me in the correct direction?

Is there anything outside of the distance setting that looks wrong? It's annoying I have to swap my phone from the 5.0GHz wifi to my 2.5GHz wifi to access my sonos speaker that is on my 5GHz wifi.

I would take the channel selection off of "auto" for both 2.4 GHz and 5.

For 5 GHz, select a channel between 36-48 or 149-161.

Channel 36 is usually crowded, since it's the default for many consumer routers.

I would also change the channel width to 80, or 40.

For 2.4 GHz, select either channel 1, 6, or 11.

I suggest using 20 for the channel width.

Is there a specific reason this is set at 500?

Read what it tell you on the command line.

Enlighten me.

I actually get better SNR on both bands, and no drops.

Does the channel affect devices being able to communicate with each other? I thought that only changes the broadcast wavelength. I am not having any issues with devices connecting to the wifi.

I set it to 500 because that is what was recommended for the Netgear R7800 in a forum thread I read somewhere.

I'm taking a broad view of your wireless configuration.

Since the router is selecting the channel for you, you could wind up in a situation where adjacent channel interference can cause issues.

I've seen "auto" select a DFS (radar) channel.

Usually, CTS is set to 2346 and RTS is set to 2347.

As long as all devices are on the same subnet, (i.e 192.168.1.1/24 and 192.168.1.254/24), and wireless is configured correctly, devices should be able to communicate with each other.

However, if you've set up a Double NAT (two routers each with their own WiFi network), that could cause the issue.

Personally, for network security reasons, I configured my wireless devices to not communicate with each other, or the main network.

I've configured mine to be on separate subnets for 2.4 GHz (192.168.2.1) and 5 GHz (192.168.3.1), and the ones that are on the same subnet (i.e. 2.4 GHz) are isolated from each other.

It changes to "under 400" at least in versions 17 and 18 (I am not able to change the setting on an OpenWrt AP for about 2 days, so I cannot get a copy/paste).

???

That seems unrelated but...OK...the "antenna gods" must been good to you. Cool!

It started working. Not sure what the issue was. The only thing I changed was moving the distance to 100.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.