Clients in same WLAN can't reach each other

Ethernet switch + 2.4G Wifi + 5G Wifi is bridged into one interface and firewall zone (lan).
I updated to LEDE 17.01.0 (stable) and got following problem:
Clients connected to the same Wifi SSID can not communicate with each other (same interface/firewall zone)
PING OPO.lan (192.168.0.17) 56(84) bytes of data. From MJ.lan (192.168.0.58) icmp_seq=1 Destination Host Unreachable ...
I can still reach it from Ethernet or from the other WLAN (5G -> 2.4G and vice versa) but not when both are connected to the same... It works fine if i create 2 different SSIDs on an adapter and put a client in each one.
Multiple clients connected through ethernet can also reach all others.

There is an option at /etc/config/wireless to isolate clients from each other, that works exactly as you describe; make sure that you did not activate that option by mistake.

Yes, that is excatly what i experience. But there is no option isolate in my wireless config, also no difference if i add and set it to '0'.

Also make sure that your device firewall (PC, lappy, phone's firewall) isn't blocking ICMP echo request (ping).

Try add option wds 1 or install full wpad and hostapd-utils then.

I used ping only for demonstration, FTP etc. does also not work. I am sure that ICMP is not blocked because it goes through when i move one client to a other SSID or Ethernet ...

Tried that, but does not change anything.

Did this work before the upgrade? What where you running before? On which device?

It is an Archer C5 v1, first with Openwrt, installed LEDE at the end of 2016 (dont know exactly what rev) and at release 17.01 (r3205). Yes, it did work before, i did not particulary test this right after the upgrade, but i haven't really changed the config in the meantime, so i think that caused it.

In that case, I would open a bug report.

Can you tried LEDE 17.01-rc1 ? Sometimes it's better than current release :grin:

Did a factory reset (to make sure it's not my config) and tried rc1, same problem again... I make a bug report now.

If you are using Windows have you made sure that Network Discovery is enabled?

I am not using Windows. Tested with Arch Linux and Android Clients.

Also probably a stupid question but your devices get an IP in the same address range?

Yes, as you can read from the ping i was trying from 192.168.0.58 to 192.168.0.17.

I have the exact same problem:
I set up a bridge (layer 3) with lan/wlan interfaces.
Clients within wlan cannot reach each other, clients within LAN cannot reach each other. LAN Clients can reach WLAN clients and vice versa. Of course all can reach the router itself.
I used the latest firmware (lede-17.01.0-r3205-59508e3-brcm47xx-mips74k-netgear-wnr3500l-v1-other-regions-squashfs.chk) on a Netgear WNR3500l and upgraded from a DD-WRT image - so the config startet from scratch. I also had no "isolated"-option around in configs.
I had to downgrade back to DD-WRT.

HTH!

I had the same problem, but only while I had set up a second network ('v-test', as a guest network) on the same device (radio0). The first network was connected to 'lan' all the time, unlike 'v-test', which should only provide Internet access to connected clients (no access to other computers on the 'lan'). While 'v-test' was enabled, the overview page would not show clients connected to my master network on radio0 - only those connected via cable, or on radio1 (5 GHz). I had not expected this behaviour, and I don't know if it can be considered a bug, or if I did something wrong. I'm using LEDE 17.01.0.

1 Like

Any clues on this problem?

I found your bug and added supplemental information in a comment. Are you using version 17.01 or version 17.01.1? I believe 17.01 didn't suffer from this problem. Please update bug report accordingly. Thank!