Cant install kmod-usb-storage - help please!


Not being very experienced can someone enlighten me what is wrong here please?
As far as I can see it has a dependency on the kernel version that is currently running, so why is it whinging ???
Thanks very much

root@OpenWrt:~# opkg install kmod-usb-storage
Installing kmod-usb-storage (4.14.167-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
 * 	kernel (= 4.14.167-1-342af9e4f67b3447c53216ab8e3b12a1)
 * opkg_install_cmd: Cannot install package kmod-usb-storage.
root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.167 #0 Wed Jan 29 16:05:35 2020 mips GNU/Linux
1 Like

If it's a self built kernel the hash won't match. Rebuild including the kmods you need. Or use a release build from the start.

Also 19.07.2 is the latest release.


You could try (at your own risk) to install it with "--force-depends", which "Install/remove despite failed dependencies".

Thanks, I went back and rebuilt the image with the kmod-usb-storage, I guess its a bit more picky about kernel mode drivers that application layer packages!!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.