Can't get internet connection

I installed openwrt (snapshot) on my TP-link MR6400 (4G LTE) V5 router a couple of days ago, before installing openwrt the router was working fine, but now I don't have internet access. I tried a suggested solution I found by changing the LAN IP address to a different range, it didn't work either. My networking background is not very strong, could anyone here help me find the problem?
This is a screenshot of the /etc/config/network file:

I tried Ethernet&WIFI connection both of them did't have internet connection, I can ping other hosts in my network.

Instead of screen shots, please post your results in pre-formatted text using the icon highlighted in red...

OpenWRT Posting Icons

Additionally, run cat /etc/config/dhcp and post.

What is upstream of your openwrt router (i.e. what is between it and the internet)?

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

That does not appear to be the complete file. Maybe try again.

fixed it, thanks

i'm not sure if i understood you correctly but i'm using a 4G LTE router (SIM inserted in router) and my computer is connected to the router using Ethernet cable.

Did you configure the LTE modem?

Currently it looks like the device is expecting the WAN on the ethernet ports.

No i didn't. Mine is version 5

I don't personally know how to get your LTE modem up and running (I haven't use that device), but I think fundamentally the system isn't firing that up -- it doesn't know it is available as a WAN connection.

You might take a look at the User Guide...

This might be useful: