Can't connect wifi printer to Archer C7 [Solved]

Hi everybody.
I'm still quite new to OpenWrt, so tell me if you need extra information or details please!

I upgraded my Archer C7 AC1750 v2 from stock to OpenWRT a month ago or so. I'm currently on the latest 19.07.2 firmware. I didn't change much in the configuration, I only setup the wifi network to match the old one I had, and everything is working great!

There is one device that I can't get to connect to the wifi: an old Epson printer (BX305FW). Every other device (phones, laptops, ...) is working fine, lan or wifi.

I did some tests:
if I set the printer in DHCP mode, it doesn't get an IP address.
if I set a static IP, I can't ping the device; I tried from my PC (same network) AND from the router itself.

To reduce the variables, I put the wifi network in legacy mode, with no password.
The device shows up in the Associated Stations list with the MAC address, but the HOST field shows a ?

I tried, leaving the printer in DHCP mode, to capture network traffic. What I see is a bunch of DHCP discovery from the printer, but no DHCP offer.
My next step was enabling the "Log queries" option in the DHCP page in LuCI. The System Logs shows that the router received the DHCP discovery, and sent a DHCP Offer.

My conclusion, if I haven't neglected something, it's that the Router responds to the device, but the message is never transmitted.

Does anyone have any suggestions to solve this?
Thanks

Please post here the output of the following commands, copy and paste the whole block:

uci export network; uci export wireless; \
uci export dhcp; uci export firewall;

lease use "Preformatted text </>" for logs, scripts, configs and general console output.
grafik

uci export network;


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdaf:7ecf:3776::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        list dns '208.67.222.222'
        list dns '208.67.220.220'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option password 'timadsl'
        option ipv6 'auto'
        option username 'timadsl'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

uci export wireless;

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option beacon_int '250'
        option txpower '19'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key ''
        option ssid 'MatWiFi_2.4GHz'
        option encryption 'psk2+ccmp'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option beacon_int '250'
        option country 'IT'
        option txpower '17'
        option channel '1'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key ''
        option ssid 'MatWiFi_2.4GHz'
        option encryption 'none'

I removed my password from the option key fields

uci export dhcp;

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option logqueries '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option limit '100'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option mac 'xx:xx:xx:xx:xx:xx'
        option name 'Switch_MikroTik'
        option dns '1'
        option ip '192.168.2.5'

I did remove some static leases, they are all the same

uci export firewall;

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

Thak you!

Remove these from lan interface. If you need to advertise specific DNS to your dhcp clients you need to add 6,208.67.222.222,208.67.220.220 in dhcp options of lan interface. Or you can add them in wan interface.

There is a key but no encryption?

        option key ''
        option ssid 'MatWiFi_2.4GHz'
        option encryption 'none'

Also remove the beacon interval to use the default value.

I will try removing the dns and beacon interval, and update the post.

There is a Key, I assume because I first setup the network with one, then removed it. I am using the web interface, so I think that's the way it behave.

EDIT: Typos

So, I removed the 2 list dns lines, and also the beacon interval, and rebooted both router and printer. Nothing changed.

From what I see it doesn't even support wpa2. Your best bet would be to enable legacy rates on the radio.

So... I'm quite embarassed. Somehow I did not try the legacy mode in combination with open network.
This way works. I thought enabling "Allow legacy 802.11b rates" would allow me to use N mode when the printer is disconnected, but fall back to legacy when required.
I am wrong, am I?

Also... THANK YOU very much for the support! You are amazing!

1 Like

I am not sure about that. You can try to run a speed test with both options and see for yourself.
If the problem is solved, feel free to mark the topic accordingly.

For future reference, i did revert to N mode with legacy rates on, and it works. For some reason the printer needs legacy mode enabled to make the connection the first time, then it is no longer required, even after rebooting the printer and the router.
Thank you to trendy for the help!

1 Like

I hope you've also been able to re-enable WPA2/ CCMP encryption of your network, as that's really the minimum to keep your WLAN secure. If that isn't supported by your printer, I'd suggest to find a way to use a wired connection instead (and to disable its WLAN support completely).

Wired connection is not an option, the printer is wifi only. I've created a second wireless network, with wpa and mac filtering only for the printer. The main wifi network is now WPA2 again. I know this isn't optimal, but it will work for now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.