Can't accessing the modem through the router

i can't access my modem (Mikrotik SXTsq Lite 5) through winbox (ip or mac)

Router's IP address: 192.168.1.1/24
Modem's IP address: 192.168.3.1/24

I did create the interface with static IP on wan, like that: Accessing the modem through the router

i can easily connected via ethernet port to my PC

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdba:0795:cbdb::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'wifi'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config interface 'modem'
	option proto 'static'
	option netmask '255.255.255.0'
	option device 'wan'
	option ipaddr '192.168.3.254'

what's problem?

thank you

Disable the 'modem' interface. You already have access to network 192.168.3.0/24 (using DHCP) through the wan interface.

4 Likes

ok. i delete the 'modem' interface but winbox can't login with IP (192.168.3.1) or mac

Can you ping the device?

1 Like

yes. everything is okay

PING 192.168.3.1 (192.168.3.1): 56 data bytes
64 bytes from 192.168.3.1: seq=0 ttl=64 time=0.735 ms
64 bytes from 192.168.3.1: seq=1 ttl=64 time=0.704 ms
64 bytes from 192.168.3.1: seq=2 ttl=64 time=0.645 ms
64 bytes from 192.168.3.1: seq=3 ttl=64 time=0.554 ms
64 bytes from 192.168.3.1: seq=4 ttl=64 time=0.554 ms

--- 192.168.3.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0.554/0.638/0.735 ms

and traceroute in windows:

You mean that when you connect your PC directly to some of the Mikrotik ports you get winbox access?

1 Like

yes, exactly

By default, port 22 also should be open. Try to access the device from Windows using PuTTY.

1 Like

PuTTY Say Access denied but I'm sure user & pass absolutely true

when connected PC directly to some of the Mikrotik ports i can get winbox access and ssh with same user & pass!

all services in "ip>services" mikrotik is open

can you ssh from the openwrt router to the "modem" (which is clearly a router too)

2 Likes

Seems like another device in the network with the same IP address but different credentials. Please ssh into the OpenWrt router, type arp and check if the mac address, corresponding to 192.168.3.1 belongs to the Mikrotik.

1 Like

i don't understand

you mean i can ssh to router? yes i can

No, I mean what I said

can you ssh from the openwrt router (192.168.1.1) to the microtik router (192.168.3.1) (what you call the modem)

i.e. ... once you've ssh'd into 192.168.1.1 ... can you

ssh user@192.168.3.1

where user is whatever the user name on the microtik router is

1 Like

i sure type correct user & password but:

yet, if you connect a PC directly to the microtik router - that exact process works, i.e.

ssh admin@192.168.3.1

with the password you tried above

Yes. if connect a PC directly to the microtik router can ssh with same user&pass

all services in "ip>services" on mikrotik router active

Odd thing is, you've linked to an Access Point, not a modem/router

Only this ip and mac is related to mikrotik router

what should I do?

you say you have a modem ... which seems to work like a router ... but the link you've provided is to an access point

so .. confusion sets in