Cant access router page after upgrade

Hi all,

This is my first upgrade to openwrt, with xiaomi 4a gigabit edition. wired connection seem to work and internet is up and running but no wifi. when I try to login to I get a connection refused error even with a wired connection. What am I missing?

Tried to run luci, getting these messages

opkg update
opkg install luci-ssl
/etc/init.d/uhttpd restart
root@OpenWrt:/etc# /etc/init.d/uhttpd restart
4+0 records in
4+0 records out
Error relocating /usr/lib/ __time64: symbol not found
Error relocating /usr/lib/ __select_time64: symbol not found
Error relocating /usr/lib/ __time64: symbol not found
Error relocating /usr/lib/ __stat_time64: symbol not found
Error relocating /usr/lib/ __gmtime64_r: symbol not found
Error relocating /usr/lib/ __gettimeofday_time64: symbol not found
Error relocating /usr/sbin/px5g: __gmtime64: symbol not found
Error relocating /usr/sbin/px5g: __time64: symbol not found
mv: can't rename '/etc/': No such file or directory
mv: can't rename '/etc/': No such file or directory

Version info

root@OpenWrt:/etc# cat openwrt_version


root@OpenWrt:/etc# cat openwrt_release






DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r13499-7b4877c204'


Quick clarification: when you state "my first upgrade to OpenWRT", did you mean it was your first time "installing" OpenWRT on this router.... or did you already have OpenWRT on this router and you were "upgrading" the OpenWRT version?

If it was a first-time install of OpenWRT, I had accidentally installed a SnapShot version, which does not include LuCI. I was able to get to LuCI by installing the Full Version. See this post here.

1 Like

first install. I followed all the luci guides and got me to these error messages

1 Like


install luci:

or make your snapshot with luci:

1 Like

Ahh... noting your Distrib_Description of "snapshot" it sure looks like you landed where I did... Installing the Snapshot (without LuCI) rather than the Full Install (with LuCI).

I got lost in the weeds on trying to get LuCI installed separately. So with the kind help of the members in the prior post I linked, I was able to simply install a Full Version.


This snapshot is over three years old, it is not compatible with current repository packages anymore.


Would @sedoxa be able to install a new/current Full Install in the same/similar method outlined in my post?

Normal sysupgrade -n to 23.05.2 should solve the problem.


Can I also get a link to a guide with normal snapshot/distro?

tried to do that, got these errors. Maybe my client type is wrong?

root@OpenWrt:/tmp# sysupgrade -n open_wrt.bin 
Device xiaomi,mir3g-v2 not supported by this image
Supported devices: xiaomi,mi-router-4a-gigabit - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA
Image check failed.

Perhaps so. It seems you're trying to use an image for the 4a Gigabit Edition, when you actually have the Mi Router 3G v2.

This is a link to version 23.05.2:

Look this: Trying to override openwrt version - #4 by remittor

Yes, I'm now aware of your duplicate posting. Thanks for the clarification.

this is the second time this happens to me. So annoying that sysupgrade doesnt work properly, everytime i upgrade i have to factory reset the router and config all over again