Cannot save open configuration / changes

I have successfully installed openwrt-18.06.8-ar71xx-tiny-tl-wr841-v8-squashfs-factory.bin on my router.
Then I started to configure a Wi-Fi bridge following this documenation.

The interface protocol "Relay bridge" was not available and I installed the relevant packages:
opkg install relayd luci-proto-relay

Here the first error was reported: no space left.

But I was able to start the service
/etc/init.d/relayd start
but I could not enable it
/etc/init.d/relayd enable

Nevertheless the required interface protocol "Relay bridge" was available and I continued the configuration.

Now I'm facing the issue that this configuration is not saved. This means the following changes are still open:

So, my idea was to enter the configuration manually by executing the commands in CLI.
However this had no impact.

root@net3-tlwr841:~# uci commit
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error
uci: I/O error

Then I tried to modify the configuration file /etc/config/network directly, but the file is read only.

I think the root cause of the issue is that there's no free space on the device:

BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 18.06.8, r7989-82fbd85747
root@net3-tlwr841:~# df -hT
Filesystem           Type            Size      Used Available Use% Mounted on
/dev/root            squashfs        2.3M      2.3M         0 100% /rom
tmpfs                tmpfs          13.6M     80.0K     13.5M   1% /tmp
/dev/mtdblock3       jffs2         320.0K    256.0K     64.0K  80% /overlay
overlayfs:/overlay   overlay       320.0K    256.0K     64.0K  80% /
tmpfs                tmpfs         512.0K         0    512.0K   0% /dev

Can you please advise how to fix this issue?


You don't have enough free space left, that isn't fixable other than either reducing your space requirements (no runtime installed packages, less configurations) or changing the hardware.

See for details.


I understand that my router TP-Link WR841N ver. 8.2 is undersized for OpenWRT with 4MB Flash / 32 MB RAM (and consequently not recommended).

However I don't need many router functions but just Wi-Fi bridge.

Therefore my question:
Would it be possible to install the required packages and save the configuration with another cheap device, e.g. TL-WR841N ver. 13 with 8MB Flash / 64MB RAM?


Depending upon the amount of required additional packages you do not need another device: In case you are willing to dig into the details of building your own image.
As there are a lot of options to reduce RAM requirements. First of all, to get rid of LuCI.
And to remove other options, like IPv6 or pppoe or ppp or ...

So, trade your learning curve/time against investment in new hardware :slight_smile:

If you are going to spend money I would recommend to go for a device with minium 16MB Flash/128MB RAM.

If you already have this unit I would go for it instead of investing time in making my own builds in order to strip things. Otherwise if you already have the knowledge in making your own builds you could go this route easy.


many thanks for all replies.

I will continue with my "old" device TP-Link WR841N ver. 8.2 and build my own image w/o any web interface or GUI.

However I have this question:
Which release should I checkout?

The latest (tiny) release provided by OpenWRT is: 18.06.8

Can I build my image on a newer release, too?


You could but you probably have to strip out more. The kernel is newer and it size has grown also.

There are community builds with 19.07. also. Maybe you can use this as a template:

Vanilla 18.06.x is smaller, thus simpler to shrink down. When you have success with it, give 19.07.x a try, applying your aquired knowledge.

Thanks for your great support.

I've decided to go with the custom image as propsed by pwned.
And this really worked well for my requirements.

Therefore this ticket can be closed.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Actually I wanted to mark it as solved, but there's no pencil after the thread topic.

Please advise.

It comes up if you hover the topic with the mouse trying to edit.

Well, I wish I could edit the initial posting, but I can't.
Maybe this is prevented as I have already edited by initial posting before.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.