Cannot Install Luci on R6700v2

I'm very new to OpenWrt and just found out that my router (Netgear R6700v2) was supported in a non-stable build. I downloaded "openwrt-ramips-mt7621-netgear_r6700-v2-squashfs-factory.img" (which came out only around a month or so ago) and uploaded it to the router. The install seemed successful, however I cannot access the router through, I can however reach the router through PuTTy and get the root welcome screen. I tried installing Luci but was greeted with the following error:

Master ('snapshot') builds do not have a web interface unlike stable releases. You are probably running a build that by now has been replaced by a newer one.

The easiest way to go about this is to use the image builder to generate an image with the web interface included.

Do keep in mind though MT7615 support (your wireless radios) is pretty young so it's not fully stable yet AFAIK.

1 Like

I imagine that you meant you can't access the router's Web interface but you can access it via SSH. So, yes, you need to install LuCI.

Get the sysupgrade image for your router, install it using sysupgrade comnand then immediately iayely install LuCI the same way you were doing.

1 Like

I just did this and now the router is on a boot loop and I can’t connect to it. Was this not the same build mt7621 as the other build I posted?

1 Like

I am sorry that this happened. I don't know why it happened.

Factory images (like the one you posted) are for installing OpenWrt on devices that are running OEM firmware. Sysupgrade images are for upgrading OpenWrt. The target and the hardware revision look the dame to me, so I don't know why it was bricked.

The device page mentions nmrpflash recovery method I have no further info about it though other than what's written there.

1 Like

Coincidentally after messing with it all day I finally figured out how to fix it using a similar method! Like 15 minutes ago, good timing. Oddly enough after doing several resets and using the factory firmware my settings are exactly the same as they were before doing anything with OpenWRT. Although I definitely still want to make this router custom so back to work!

The culprit is the current development build, I can now say after attempting to install the latest image that the device always becomes bricked even with the img file. I have the previous build that actually works, but I don’t currently have a Linux install on hand to compile LuCI into it. Any way to get around compiling a GUI version in strictly Linux?

1 Like

You can use the Windows subsystem for Linux if you're on Windows 10?

@About7Deaths so what firmware did you use that didn't cause the r6700v2 to brick?

I'm not sure if you can still download that version or not, but it was hash #: 17811B38583A8CC3DAAE75C290760C0643D6624E

In general the snapshots for this router are found here:

so you mean that all of the these will almost guarantee a bricked router?
Sorry if i sound stupid, I've basically worked to teach myself everything I know about routers and networking through just messing around with them. But yeah I've just figured that if I can unlock its true potential then why not then.

1 Like

What I understood @About7Deaths is that the r6700v2 has 5 different clones, so with that said would be possible to find if they have a DD-WRT and would that work?

DD-WRT is not available for the R6700v2 in any capacity. OpenWRT has only had it for a few months with snapshot builds only. Also no, not every snapshot build is guaranteed to brick the router, but the builds are compiled daily, which means that whenever the code is changed it has the potential to not work with each build given that snapshots are completely experimental. Since they are compiled without the GUI front-end Luci, you must install the interface within the same 24 hour interval that the snapshot build was compiled. Otherwise you will receive the error I received in the initial post. Now knowing this, I'll wait a week to download a new image snapshot and attempt to install both the firmware image and the Luci front-end on the same day. Hopefully, by that time the build will not have the kink that lead to bricking. However, I am not worried about bricking because I now know how to restore the router. I can help you do the same if you fall into a similar circumstance.


I have the amazon r6700v2 and just tried to upgrade using "openwrt-ramips-mt7621-netgear_r6700-v2-squashfs-factory.img".

After about 3mins the webgui just returned to the stock netgear gui. It appears the upgrade failed and returned to the stock webgui.

how's the snapshot build working for you? stable? I can't wait to get rid of the stock firmware.

@About7Deaths can you post or send me the trick you used to unbrick? I used that latest snapshot build and have bricked my r6700v2. i have tried to flash using nmrpflash on many different versions of the stock firmware but each time after reboot router is still solid red light. i tried using nmrpflash using openwrt snapshot firmware and upgrade bin.

c:\temp>nmrpflash.exe -i net4 -v -f R6700v2-V1.2.0.36_1.0.1.img
net4: \Device\NPF_{C6CCF0FD-3462-428B-9E08-DB65D16CD6A2}
Adding to interface net4.
Advertising NMRP server on net4 ... -
Received configuration request from b0:39:56:0c:0e:cc.
Sending configuration:
Received upload request without filename.
Using remote filename 'R6700v2-V1.2.0.36_1.0.1.img'.
Uploading R6700v2-V1.2.0.36_1.0.1.img ... OK
Waiting for remote to respond.
Received keep-alive request (478).
Remote finished. Closing connection.
Reboot your device now.

This is actually a severe oversight on the database. I'm not sure about "5 clones" but Netgear changed out Broadcom chip for a MediaTek one in version 2, a chip that no open firmware will support, I believe looking closely at "Details" on the database page, they have information from D-Link DIR-509, an entirely different router!! Netgear changed again in Version 3, R6700v3, I'm not certain if it was back to Broadcam, but it's flashable with OpenWRT. I'd forgive those devs who may have heard of successes with the original version and version 3, but I'm wondering if foul play isn't involved here. It seems suspicious that details from another router were placed in the version 2 entry, when that specifically bricks version 2, all of them as far as I'm aware. If Netgear did put back Broadcom on certain "clones", that would certainly add to the confusion. Also v2 has pentalobe screws, so again it's difficult to verify. Chipset. I'd don't think I'm ever going to buy Netgear again!

I've replied to About7Deaths, he's right about DD-WRT not being available in any capacity, but he's mistaken about technical aspects of the snapshots, with or without Luci. Netgear deceptively put out v2 with Mediatek rather than Broadcom chips. There was instability at the Broadcom company and they made plans to withdraw from wireless tech altogether, although they were bought out by another company. Why Netgear didn't change the model name or number is a mystery- perhaps just a bad business decision. Anyways R6700 v2 is basically an entirely different router. OpenWRT database does not reflect this presently. Yes every snapshot will brick these routers, and likely always will. Version 3 apparently works. They may have basically the same characteristics of version 1, IDK

A post was split to a new topic: Unbricking R6700 v2

nmrpflash can only be use with stock firmware. It worked multiple times for me after a few (unsuccessful) attempts with the openwrt snapshot.

It eventually did take, but it was some really wild behavior where I did the power cycle and then it proceeded to finallt self reboot and go on as expected to "start over" from stock.

As to the original issue of the post, I've found out that @Hegabo mentioned the sysupgrade procedure and this has been the method to prevent a brick and must be done before trying to install anything including Luci/the GUI after originally flashing the snapshot image. Unfortunately so far, anything else creates a brick either in fast or very slightly slower form, and I've reproduced it many times now before figuring this out. I believe this is post #3 here where it describes sysupgrade, and the command help page is very useful.

1 Like