Builds for NETGEAR WNR1000V2, WNR1000V2-VC, WNR612v2, WPN824N, WNR2000v3, EX2700

Sorry, missed the notification.
19.07.7 build you can find here:
There is no need to change the bootloader or make a special image for 64 MB RAM suppport. All you need is to prepare SPI Flash - an ART partition need to be placed to a new address, 0x7F0000 instead of 0x3F0000, you need a programmer for that.


I can't for the life of me succeed flashing this on my WNR1000V2. I'm using Tftpd64 using Win 10 and every time it errors out after a minute or two with the error "timeout while waiting ack block xxx" Replace the xxx'es with 147 or 155 or another number thereabouts. Any advice?

Or maybe just tell me exactly how to flash it on linux. I can install ubuntu, but don't know how to flash from it (which software works, should I configure ip addresses?) Thanks.

I've been using a router with new firmware for about two weeks and everything is working stable for me. The load was average; a bit of surfing the Internet, watching videos and downloading via torrent.
Thanks for the build!

There are a couple of questions:

  1. Is it possible to enable the L2TP protocol to connect to the Internet or will there not be enough memory?

  2. When is it planned (and is it planned at all) to make build based on OpenWRT 21.02?

  1. Will work L2TP? Why not? But don't overload the device: OpenWrt on 4/32 devices

  2. No, not planed. But you can try to build it yourself.

I know about the small memory size, so I asked if there was enough space to add an L2TP packet?

In general, I asked the author of the topic (@jlpapple) about this.
I asked this question already in post #145, but I didn't get an answer then.
But thanks for your answer)

It looks like I was wrong, it turns out the question was in post #83 and the answer is in the next one :slightly_smiling_face:.

I've made a build of 21.02.1 version for 612v2 with L2TP support. With Luci and IPv6 excluded it is 4,35 MB size. To make it work normally you need to exclude something that occupies as much as 600 kbytes. I have no idea what it could be, because in this case you have only kernel and basic stuff.
If you want newer versions on THIS device, you should consider hardware upgrade (replace SPI flash to 64 or 128 Mbit size)

Were optimizations from these posts (post #9 and post #12) used when creating the build, or was the default configuration used?

No optimization, default config.

Maybe if you apply them, then at least the PPP package will fit into the memory size?
By the way, I have no personal experience of building OpenWRT.

I'm working on builds for 21.02 right now, stay tuned. I'm very doubtful I'll be able to continue to include PPP support due to size limitations. This also likely means that L2TP support is also not possible.

I'm trying to retain IPV6 and LuCi support in the 21.02 builds.

By the way, this webpage lists all of the space-saving optimizations and configuration settings that I use to create these builds:

The settings are also viewable in the "config.buildinfo" file included in each firmware folder.

1 Like

It can be tricky. Are you flashing from the original NETGEAR firmware - or a current version of OpenWrt?

If you are flashing from the original Netgear firmware, try downgrading it to an older Netgear firmware version - perhaps the initial release - and then try flashing. I've had difficulty flashing when the device has a newer Netgear firmware version installed.

Additionally, double-check all of your TFTP and IP settings on the computer you are using to flash. Also, ensure you follow the proper boot sequence on the router so it is clearly in failsafe mode. (Step #4 above).

Thanks for getting back - that sounds like good advice. I am trying to flash from the newest version of the original firmware, yes. I can find v1.0.1.1 on the Netgear website. I'll give that a go. Or do you have the initial release you could share with me? Thanks.

For anyone experiencing the same thing as me, here's what worked: I tried flashing back to an old official firmware, but still experienced very slow flashing of Openwrt and erroring out every time after a couple of minutes. After reading a suggestion elsewhere about disabling the firewall, I switched computer (the one I was using didn't allow me to change firewall settings as it's a corporate pc), and disabled the firewall. Tried again, and everything worked as expected. Uploading of firmware was near instantaneous, and now I'm off to try and have this thing setup as an extender. Thanks for making the firmware available to us.

1 Like

I've built images of 21.02.1 for WNR1000v2, WNR2000v3, and WNR612v2 for testing. These images do not include PPP, SSL, OPKG or Relayd like the 19.07.X series. They include LuCi, IPv6.

I have not been able to test these images as I no longer access to these routers - use and flash at your own risk.

(21.02.1 Link Removed)

Backup your configuration via webserver, but flash new upgrades using SSH! Flashing via LuCi webserver most likely doesn't have enough memory to handle file upload.

Please report back with your comments in this thread and tell us if these images flash successfully and your device runs reliably.

(The WNR1000v2-vc and WPN82N are not available as their device profiles have not been submitted to the Openwrt codebase for the ath79 platform. Please submit these device profiles if you know how. Thanks to user Ashus and this thread for his helpful information in configuring size optimization options for 21.02. He has also successfully created his own 21.02 images for WNR1000v2, WNR2000v3, and WNR612v2 that you can try.)

1 Like

Can you give a tip how to flash the router via ssh?
Since my devices are currently in operation, as soon as I find a replacement for them, I will definitely check your builds on them.

Oh, it looks like I found the instructions in the topic you specified:)

1 Like

I dont know if this is the right place to ask but after messing arund with my WNR2000v3 a bit, it now always spits out this error message when trying to boot any (even the official) image:

Hit any key to stop autoboot:  0 
   Verifying Checksum ... OK
## Booting image at 9f050000 ...
   Image Name:   MIPS OpenWrt Linux-4.14.241
   Created:      2021-07-29  19:50:28 UTC
   Image Type:   MIPS Linux Unknown Image (uncompressed)
   Data Size:    1299456 Bytes =  1.2 MB
   Load Address: bf070000
   Entry Point:  bf070000
   Verifying Checksum ... OK
Wrong Image Type for bootm command

After that it goes back into TFTP recovery

I did this a while ago so i dont know anymore what exactly i did to mess it up this badly

Hi. Wnr612v2. After sysupgrade.bin flashing Luci doesn't work.

Can you replace wpad-mini package to at least wpad-basic for 802.11r fast roaming. Thank you

It won't fit, sorry. You can build your own custom firmware if you wish - but you'll have to strip out LuCi and/or IPv6 to make it fit.

Any chance of a 19.07.9 version now that's it's been released? Or are the changes less than trivial to fit into the available space? Thanks.

1 Like

I will build a 19.07.9 version, but it won't be ready for a few weeks.