Builds for Linksys WHW03 V2 + V1


My ISP has now provided me with a newer Wi-Fi 6 Linksys model.

I've still got the previous WHW03 v2 router and would like to try flashing it with OpenWRT.

When I navigate to 'Connectivity' there is no option to manually upload a firmware.

I've also tried connecting to via SSH, but I'm receiving 'Connection Refused'.

Am I missing something? Do some ISP/OEM models lack the option to manually upload firmware?

Using CT drivers (10.4b-ct-4019-fW-13-5ae337bb1) and wpad-wolfssl, I'm getting the following on a test mesh setup. Mind you that the APs are on separate floors with concrete in between.


root@ae-ap04:~# iperf3 -c -R
Connecting to host, port 5201
Reverse mode, remote host is sending
[  5] local port 39688 connected to port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  17.1 MBytes   144 Mbits/sec
[  5]   1.00-2.00   sec  17.7 MBytes   148 Mbits/sec
[  5]   2.00-3.00   sec  17.9 MBytes   150 Mbits/sec
[  5]   3.00-4.00   sec  17.8 MBytes   149 Mbits/sec
[  5]   4.00-5.00   sec  17.7 MBytes   148 Mbits/sec
[  5]   5.00-6.00   sec  17.9 MBytes   151 Mbits/sec
[  5]   6.00-7.00   sec  15.4 MBytes   129 Mbits/sec
[  5]   7.00-8.00   sec  18.0 MBytes   151 Mbits/sec
[  5]   8.00-9.00   sec  14.7 MBytes   124 Mbits/sec
[  5]   9.00-10.00  sec  17.7 MBytes   148 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.03  sec   176 MBytes   147 Mbits/sec    0             sender
[  5]   0.00-10.00  sec   172 MBytes   144 Mbits/sec                  receiver

http:///fwupdate.html or click on the 'ca' link at the bottom of the page.

1 Like

I took them from the OEM UI. The radio were refusing to start when I tried to use other frequencies.

Thank you. So it looks like it is also limited to the same bandwidth as in my case, right?
These are my mesh status:


Thanks for the tip. I found a GitHub guide for flashing my router.

For (my) future reference, the correct URL is:

Seeing the same issue on atheros-wds

Can you be more explicit? You are saying this could be an issue of the whole ath10k package?

I've seen it on the Netgear orbi pro srr60 and srs60.

Maybe I should test a build with your freq patch and non-CT drivers, as I see a lot of people complaining about this ath10k ct firmware...

I've somewhat scanned the thread but do we use SNAPSHOT (as per or one of the built FWs offered in this thread?

I'll be using it as an AP rather than mesh node (I only have one).

Let me know, I'm using stock at present across three nodes while I work out what's causing the throughput issues

what sort of throughput are you getting on stock?

Use snapshot or compile yourself until next version release.
Index of /snapshots/targets/ipq40xx/generic/ (

1 Like

Hi @vtremblay, any update on zigbee? I believe you've got bluetooth working, any guidance on how to use it would also be much appreciated!

I tested mine in stock before flashing to OpenWRT and got 400/460 Mbps via iperf between nodes


500/500 down and up on iperf


The manual upload of OpenWrt firmware even on Community Fibre branded routers isn't removed but hidden. Open Developer Mode (F12) and "unhide" the manual firmware upload section.

1 Like

Any idea if and when a download would be available for WHW03-V1?


I've flashed my router and I'm using it as a WAP with Guest WiFi segregated on a separate VLAN.