Building for the Mikrotik mAP lite RBmAPL-2nD rev2

I have tried most versions for the map lite in the ar71xx tree and none of them have working wifi on the revision 2 of the device. The image boots but wifi does not work or seem to be recognized. I was able to build an image for the ath79 target, but the wifi did not work for it either. Is there anyone willing to help m build or to make suggestions? I am an experienced user, but have only limited abilities to add new devices to the tree.

Hi,

we bought twenty Mikrotik mAP lite last week and we would like to use it with OpenWRT instead of RouterOS.

So I tried installing OpenWRT 19.07.2 today, but without WiFi these tiny devices are just useless.

So far I only tested openwrt-19.07.2-ar71xx-mikrotik-rb-nor-flash-16M-initramfs-kernel.bin. I do not find any error messages within the kernel log. The only one I spotted is:

daemon.notice procd: /etc/rc.d/S96led: Skipping trigger 'phy0tpt' for led 'WLAN' due to missing kernel module

So my first impression was, that there are no drivers for the Wifi-part of Qualcomm Atheros QCA9533.

But "lsmod | grep -i ath" gives the following output:

ath                    18240  3 ath9k,ath9k_common,ath9k_hw
ath9k                  94064  0
ath9k_common           11232  1 ath9k
ath9k_hw              343456  2 ath9k,ath9k_common
cfg80211              221744  4 ath9k,ath9k_common,ath,mac80211
compat                  5888  4 ath9k,ath9k_common,mac80211,cfg80211
mac80211              442720  1 ath9k

So the kernel has ath9k-support but the ath9k-modules do not detect the Atheros A9533 wifi.

I looked at https://wireless.wiki.kernel.org/en/users/drivers/ath9k and AR9533 is not listed as a supported chipset.

But have a look at https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=4c6fe32468bc60cc25a8c298498c0be3c73e7378
Seems like David Bauer mail@david-bauer.net did some changes in November 2019 that impove the detection of QCA953x chipsets. So there is support for QCA9533 chipsets.

Kind regards

Peter

Thanks for this work. I am unfortuantely away from home and can't do much now. But there is hope that the eko builds might work. Read this: https://eko.one.pl/forum/viewtopic.php?id=18083 and try the image as linked (https://dl.eko.one.pl/luci/openwrt-18.06/ar71xx/mikrotik/) Please let me know if it works.

Also, here is a thread about the datasheet:


I think the problem is with the new revision of the 9533 chip, because the commits seem to indicate the earlier version of the mAP lite was working.

I just tried:

Does not detect Wifi

Peter

okay. I think that it has to do with the second revision of the chip then. Although I know how to build, I am really unable to fix this. I think that there must be some necessary changes in the source code for the QCA9533-BL3A revision of the chip. Someone has to find these changes and test building with them. Unfortunately, I am unable to find the source code.

A student from the computer-science department of the university of Düsseldorf is working with us and he will try to fix this problem. I have no idea how long this will last.

Peter

@pk1234
Okay, thanks for letting me know. Please mention it on this thread if he solves the problem. I would be happy to test builds if he needs it.

@pk1234

Any chance you could post the dmesg from the mAP Lite?

I think this is the most important:

[    7.884964] ath9k 18100000.wmac: Direct firmware load for ath9k-eeprom-ahb-18100000.wmac.bin failed with error -2
[    7.895611] ath9k 18100000.wmac: Falling back to syfs fallback for: ath9k-eeprom-ahb-18100000.wmac.bin
[    7.948449] urngd: v1.0.2 started.
[    8.191976] firmware ath9k-eeprom-ahb-18100000.wmac.bin: firmware_loading_store: map pages failed
[    8.201983] ath: phy0: Unable to load EEPROM file ath9k-eeprom-ahb-18100000.wmac.bin
[    8.210046] ath9k 18100000.wmac: failed to initialize device
[    8.215968] ath9k: probe of 18100000.wmac failed with error -22

I am not sure whether that was my own build on ath79 or ar71xx, but the problem is probably the same (either changes in the 2nd revision of the chip or changes in the mikrotik config partition)

If you need the whole thing let me know

@pk1234 Any updates?

@pk1234 @hecatae
Building from trunk now generates an image which has working wifi!!

I think that it was this commit that did it:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=1c6990fe6d198718850b6a37998416cac69f6f53

Thank you - this is good news. I will try trunk this weekend, but must setup a build environment first

you can just build an image from the trunk ar71xx tree, hopefully we can get it setup for the ath79 soon, but for now ar71xx works from trunk

@pk1234 @hecatae
As it turns out the latest release build in ar71xx is working:
https://downloads.openwrt.org/releases/19.07.3/targets/ar71xx/mikrotik/

It would be good going forward to get the map lite in the ath79 tree, but having a working release build is probably enough for most people

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

thanks, done!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.