Build LEDE without IPv6


I am trying to use image-generator to build a light weight lede for W841ND (4MB flash).

make image PROFILE=tl-wr841-v9 PACKAGES="-odhcpd -odhcp6c -ip6tables"

Does anyone have a list of all the packages that I can exclude to completely remove ipv6? What else can be safely removed?

I want to create a build with openvpn client support.

You're only partially stripping IPv6 support, e.g. luci-proto-ipv6 should be stripped as well. A more comprehensive list can be found here - no idea if it's exhaustive though.

@Borromini Where on the page you linked did you find a more comprehensive list of packages that can be removed to save space? I couldn't find any on the whole page, and once more the question comes up in another thread Can I strip the IPv6 out with the imagebuilder?, what can be removed, with IPv6 support being one of the proposals. I'm now trying to collect bits and pieces of information, in order to update

@tmomas I checked the previous revision, that doesn't contain it either. I might have linked to the wrong page... If I find it I'll give you a heads up.




make image PROFILE=XXXXXXXX PACKAGES="-ip6tables -kmod-ip6tables -kmod-ipv6 -kmod-nf-conntrack6 -kmod-nf-ipt6 -libip6tc -luci-proto-ipv6 -odhcp6c -odhcpd"

Im getting this error when trying to compile while removing the IPv6 modules. Any ideas?
make image PROFILE=tl841 PACKAGES="-ip6tables -kmod-ip6tables -kmod-ipv6 -kmod-nf-conntrack6 -kmod-nf-ipt6 -libip6tc -luci-proto-ipv6 -odhcp6c -odhcpd"
make[1]: Entering directory /home/user/source' make[1]: *** No rule to make targetimage'. Stop.
make[1]: Leaving directory `/home/user/source'
make: *** [image] Error 2

That means that something else is turning it on, hit '?' to see what other
modules turn it on via the dependency resolution. Then go and turn them all off
(there may be multiple layers of dependencies here)

This does not exist.

My bad, I thought I had to put the name of the config I created. Sorry.
edit getting this now

Ran it both as user and sudo.

For the record I did 'make defconfig', then 'make menuconfig', opened the config I had saved, saved it again then:
make image PROFILE=tplink841v9 PACKAGES="-ip6tables -kmod-ip6tables -kmod-ipv6 -kmod-nf-conntrack6 -kmod-nf-ipt6 -libip6tc -luci-proto-ipv6 -odhcp6c -odhcpd".

This is a main problem due owners conflicts in temp and stamp files. Better is to start from scratch as regular user.

Cool thanks

When you are using complete build and not the imagebuilder like in the thread Build for TP-Link TL-WR841N(D) [all versions] you need to call make menuconfig and remove IPV6 by hand.

You cand find this option in menuconfig at /Global build settings/Enable IPv6 support in packages.

Check if you removed all IPv6 packages too, like /LuCI/protocols/luci-proto-ipv6.