Build for Linksys EA9500

So an update on this. I tried again this morning, but instead from latest Linksys FW 1.1.7.180968. This time after first reboot of the router and cycling through the blue LEDs once, the Linksys logo started flashing. I thought I had bricked the router, but left it alone and eventually it came solid. Opened browser to 192.168.1.1 and was presented with openwrt.

Only other thing different this time was I was plugged into ethernet port 8. Yesterday was plugged into port 4.

I like the basic inclusions like PPPoE and Luci to get the WAN back online nice and quick.

1 Like

Make sure you flash both the partitions with openwrt from ssh:

mtd write /tmp/EA9500_Factory.trx firmware
mtd write /tmp/EA9500_Factory.trx failsafe

btw, port selection shouldn't have any effect on the flashing.

1 Like

I didn't think the ethernet port would make a difference, but thought I would try it as port 8 for CFE was mentioned on an old blog page I noticed you had posted on a few years back.

From the top of this page it says only need to flash openwrt to one partition? Is that no longer recommended?

Some of the instructions were written when I was still learning about the router. Connecting it to port 8 doesn't alter the outcome of the flash.

Technically, you will never need second partition. Unless of course if the first goes bad. The bleeding edge build now has the partitions defined, in future I would like to add support for booting from second partition.

1 Like

After a few days of testing i can report some good news regarding Non-US builds. After I've read the post by our Aussie friend, I've tried the same thing, and this time it worked like a charm! Since then I've flashed it at least 6 times from factory and it boots straight into OpenWrt. So i can confirm for the Non-US models, GUI-flashing from the most recent factory firmware (1.1.7.xxx) works flawlessly. (Bold for the people with the same issue who are searching the forum.)

Now the reason I've flashed it so many times is because it obviously reverts to factory after reboot. :slightly_smiling_face: Can you provide a quick guide for flashing both partitions for non-US builds, for those of us who are relatively new to OpenWrt?

You mentioned flashing 'factory.trx' file, do you rename 'openwrt-20200102.trx' to 'factory.trx', put the renamed file in putty's folder and flash it through putty, or..?

2 Likes

Thanks for your helpful feedback.

Here is a detailed (for people who might not be used to *nix) instructions to flash both partitions.

To flash both partitions (once you are in openwrt), all you have to do is

  • ssh into your router. I use Putty to ssh into the router @ 192.168.1.1
  • Copy openwrt-yyyymmdd.trx onto a flash drive and plug it into the router
  • Mount the usb drive using
mount /dev/sda1 /mnt/
  • Locate the file name using
ls /mnt/
  • Assuming openwrt-20200102.trx is the file name, flash using below commands.
mtd write /mnt/openwrt-20200102.trx firmware
mtd write /mnt/openwrt-20200102.trx failsafe

Reboot to make sure you have openwrt.

1 Like

I don't know what to say, if only the other devs were as helpful as you are... Compared to the ddwrt community :crazy_face: what a difference.. Much appreciated!
I'll flash it and try the stable build for a few days then i'll report back after i test the 'bleeding edge' for a few days.. Thanks again!

2 Likes

Good to hear you have made the openwrt firmware take from the Linksys GUI as well! Interesting to hear that after reboot it reverts back to Linksys firmware as I have rebooted a number of times straight back into openwrt.

Might do the double flash as suggested by npcomplete just to make sure.

I am currently using the swconfig build as using all 8 ethernet ports. Does the bleeding edge build resolve the cross ports comms issue?

Yes, thanks to your findings i decided to try flashing it from the v.1.17 and to my surprise it worked without a single hiccup. I don't know about rebooting maybe we have different versions of routers (v.1.0 vs v.1.1) but i think flashing the both partitions is a good practice anyways. As for the bleeding edge question i wouldn't know as I'm still testing the 20200102 build, npcomplete or jallen2281 are probably the right people to answer it.

Hi, i can install openwrt on this router with serial cable, but i can’t revert back to factory, i have tried and tried. its driving me crazy. if anybody out there can help with information how to do this for dummies pls help help. by the way it non-usa model
will be highly appreciated. thank u

I'm currently trying out the Hurrian swconfig builds and liking the addition of configurable vlans. I have yet to try the latest builds from ncomplete. I'm really waiting for the DSA drivers to mature and fully support proper bridging and vlans as hurrian has also stated.

1 Like

Don't worry, npcomplete's builds are totally fine - it's just that UCI configuration for DSA bridging isn't there yet (for bcm53xx at least).

You can configure bridges manually with "ip bridge" and it'll work fine on npcomplete's builds :slight_smile:

1 Like

I've run a bunch of his builds and have loved them over stock firmware. I'm totally aware of the CLI bridging utility also, but it's extra work and I like Luci. I'm also cisco certified and still like their gui when i can use it. I also utilize more than 5 ports on mine. That said I am always trying out the new builds. I am curious as to the changes in the new kernel. Haven't looked at the change logs yet.

Try this from Serial cable:

flash -noheader 192.168.1.10:/EA9500_Factory.trx nflash0.trx
flash -noheader 192.168.1.10:/EA9500_Factory.trx nflash0.trx2

And

flash -noheader 192.168.1.10:/EA9500_Factory.trx nflash1.trx
flash -noheader 192.168.1.10:/EA9500_Factory.trx nflash1.trx2

Then

nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit

It has to boot into Factory

Hi thank you for the quick reply but I tried the instructions and nothing all i get is the reloop boot and nothing else.
I can revert to openwrt but no to factory firmware .
:thinking: :thinking: :thinking:

Are you downloading factory firmware from this page or somewhere else?

Hi I am downloading from this website. its the same as the one u posted at first post.
the router works fine with openwrt but I cannot revert it to factory.

Hello.

I have a Linksys EA9500 V 1.1 US Version. I have read the thread and I think that I want to install the OpenWRT software on my router.

Before to doing that, I want to ask if there is any drawback of installing OpenDWR software on my router instead using the Linksys stock firmware.

Thank you all :slight_smile:

https://openwrt.org/reasons_to_use_openwrt

2 Likes

Hello again :).

I followed the steps of the "Detailed tutorial". I have connected the 3 wires correctly, set my IP to 192.168.1.10/255.255.255.0 (Gateway 192.168.1.1), set the Putty settings as in the guide but when I open the Putty session and power on the router, nothing happens. I only see a black screen on the Putty console.

Should I open the Putty session prior to power up the router, right?
Should I wait some time until I see something on Putty console?

Here some screenshots about what I did:







Thank you.