Build for Linksys EA9500

Me too. It warned about openwrt firmware not being official or something like that and It loaded it just like the stock firmware, full progress bar and everything. But after the reboot it was stuck in a loop.

Oddly enough, first time it rebboted once it reached 8th line on the display and froze there for a few seconds, second time it rebooted around the 5th. After 3 consecutive reboots i interrupted it and reverted to stock. Do you think i should've waited longer?

It would help if you can paste the entire log for update and after update.

I'll do it. Is there an option to do it through gui or is it limited only to serial? As far as i can see ea9500's gui logs are limited to IP-related info, and router diag has only an option to 'share router info with Linksys'.

How do you see all 8 ports on the SWconfig version? I asked this question before I didn't quite get an answer. Or rather could you explain why the other ports don't show up in Luci at all?

These all show up as port LAN1 in the swconfig version. They aren't individually configurable because of network topology. They are attached to an external switch that is "plugged into" port LAN1 on the internal switch and only controllable via the DSA driver.

Hi @npcomplete !

Have you tried the current BCM4366C0 firmware (10.10.122.x) on the kernel 5.4 builds?

If 10.10.122 works, VHT160 should start working too, and that'd be pretty interesting to see.
Furthermore, I believe 5.4 should also support WPA2-PSK FT (instead of having to use WPA/WPA2 for FT like a user on here noted)

No I haven't, but if you can tell me if it performs better than the .69 version I'd be happy to include it in next build.

First off, thanks for the effort with creating a build for this router! I have been reading this thread for a little while now and decided to bite the bullet and convert the router to openwrt.

I am in Australia, so followed the non-US instructions including reverting to FW version 1.1.6 prior to flashing the non-US image. Unfortunately I haven't had much luck with the router still booting into stock Linksys firmware.

After uploading the non-US image and clicking on OK to reboot, the router tries to reboot 3 times, scrolling through the bars on its display a couple of times before each reboot, then eventually the Linksys logo lights up and on the GUI says update successful, but then Linksys firmware is still there.

I tried forcing the partial boots to boot from other partition, but still Linksys. So I gave uploading the non-US image another go, but with same result.

Is the non-US image not compatible with the Australian version? Is there something I am missing, or do I need to get myself a serial cable and flash via that method?

1 Like

I think, the only way to fix this properly is someone with Non-US version opens the router, connects the serial cable.

  1. Revert to factory
  2. Try updating with my non-US build.
  3. Provide me the logs.

Or I convert my router to a EU version and then try to do the same thing.

So an update on this. I tried again this morning, but instead from latest Linksys FW 1.1.7.180968. This time after first reboot of the router and cycling through the blue LEDs once, the Linksys logo started flashing. I thought I had bricked the router, but left it alone and eventually it came solid. Opened browser to 192.168.1.1 and was presented with openwrt.

Only other thing different this time was I was plugged into ethernet port 8. Yesterday was plugged into port 4.

I like the basic inclusions like PPPoE and Luci to get the WAN back online nice and quick.

1 Like

Make sure you flash both the partitions with openwrt from ssh:

mtd write /tmp/EA9500_Factory.trx firmware
mtd write /tmp/EA9500_Factory.trx failsafe

btw, port selection shouldn't have any effect on the flashing.

1 Like

I didn't think the ethernet port would make a difference, but thought I would try it as port 8 for CFE was mentioned on an old blog page I noticed you had posted on a few years back.

From the top of this page it says only need to flash openwrt to one partition? Is that no longer recommended?

Some of the instructions were written when I was still learning about the router. Connecting it to port 8 doesn't alter the outcome of the flash.

Technically, you will never need second partition. Unless of course if the first goes bad. The bleeding edge build now has the partitions defined, in future I would like to add support for booting from second partition.

1 Like

After a few days of testing i can report some good news regarding Non-US builds. After I've read the post by our Aussie friend, I've tried the same thing, and this time it worked like a charm! Since then I've flashed it at least 6 times from factory and it boots straight into OpenWrt. So i can confirm for the Non-US models, GUI-flashing from the most recent factory firmware (1.1.7.xxx) works flawlessly. (Bold for the people with the same issue who are searching the forum.)

Now the reason I've flashed it so many times is because it obviously reverts to factory after reboot. :slightly_smiling_face: Can you provide a quick guide for flashing both partitions for non-US builds, for those of us who are relatively new to OpenWrt?

You mentioned flashing 'factory.trx' file, do you rename 'openwrt-20200102.trx' to 'factory.trx', put the renamed file in putty's folder and flash it through putty, or..?

2 Likes

Thanks for your helpful feedback.

Here is a detailed (for people who might not be used to *nix) instructions to flash both partitions.

To flash both partitions (once you are in openwrt), all you have to do is

  • Download Full Build version (even for Non-US router) from first post above.
  • Copy openwrt-yyyymmdd.trx onto a flash drive and plug it into the router
  • ssh into your router. I use Putty to ssh into the router @ 192.168.1.1
  • Mount the usb drive using
mount /dev/sda1 /mnt/
  • Locate the file name using
ls /mnt/
  • Assuming openwrt-20200102.trx is the file name, flash using below commands.
mtd write /mnt/openwrt-20200102.trx firmware
mtd write /mnt/openwrt-20200102.trx failsafe
nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit

Reboot to make sure you have openwrt.

1 Like

I don't know what to say, if only the other devs were as helpful as you are... Compared to the ddwrt community :crazy_face: what a difference.. Much appreciated!
I'll flash it and try the stable build for a few days then i'll report back after i test the 'bleeding edge' for a few days.. Thanks again!

2 Likes

Good to hear you have made the openwrt firmware take from the Linksys GUI as well! Interesting to hear that after reboot it reverts back to Linksys firmware as I have rebooted a number of times straight back into openwrt.

Might do the double flash as suggested by npcomplete just to make sure.

I am currently using the swconfig build as using all 8 ethernet ports. Does the bleeding edge build resolve the cross ports comms issue?

Yes, thanks to your findings i decided to try flashing it from the v.1.17 and to my surprise it worked without a single hiccup. I don't know about rebooting maybe we have different versions of routers (v.1.0 vs v.1.1) but i think flashing the both partitions is a good practice anyways. As for the bleeding edge question i wouldn't know as I'm still testing the 20200102 build, npcomplete or jallen2281 are probably the right people to answer it.

Hi, i can install openwrt on this router with serial cable, but i can’t revert back to factory, i have tried and tried. its driving me crazy. if anybody out there can help with information how to do this for dummies pls help help. by the way it non-usa model
will be highly appreciated. thank u

I'm currently trying out the Hurrian swconfig builds and liking the addition of configurable vlans. I have yet to try the latest builds from ncomplete. I'm really waiting for the DSA drivers to mature and fully support proper bridging and vlans as hurrian has also stated.

1 Like