BT Modem (B-FOCus V-2FUb/r Rev.B) VG3503J - IP Connection - New Modem Firmware

Hi, connecting via serial to BT VG3503J as per wiki, I notice there is a newer firmware on it than referenced elsewhere. I suppose G.INP support maybe:


Anyway, would like to copy this file off before flashing, but I can't get it IP accessible via either LAN port.

Device is running OpenWRT 10.03.1-RC6 and has installed utilities including: ifconfig, brctl, switch_cli, switch_utility, swreset, ppacmd amongst others.

Device appears to run this to intialise the networks:

    else  # FOR_VG3503J_USE
            ### Set LAN and bridge interface for BT design.
            /usr/sbin/brctl addbr br0
            /usr/sbin/brctl setfd br0 1
            /usr/sbin/brctl addif br0 eth0
            /sbin/ifconfig br0 hw ether $BR_MAC_ADDR up
            /sbin/ifconfig eth0 up

However, using ifconfig eth0 netmask up (or against br0) doesn't result in anything being able to hit the device. Also the ifconfig eth0 Rx counter remains on zero even though it's connected to a network with some broadcast traffic.

I have enabled everything with iptables.

Any assistance getting this on the network so I can save the firmware file would be greatly appreciated.

Many thanks!

Well, having spent hours on this and not gotten anywhere.., suddenly the answer came. Found a script:

/usr/sbin/ 1

Rebooted and hey-presto listening on port 1 :slight_smile:

Sidenote: You might want to update to a more recent OpenWrt release like 17.01 or 18.06 (19.07 might fail due to 32MB RAM only).

Anyways, If your initial problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Thanks. Yes it run 19.07.03 just fine. It can be configured for PPPoE passthrough via tagged VLAN to enable in-band management access on via a single connection too.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.