BT Home Hub 5a behind a 4G router

I have a BT Hub 5 Type A router with Openwrt 19.07 sitting behind a Huawei 4G LTE router connected to each other via a LAN Cable. The BT Router is and is the DHCP while the 4G router acts as the gateway with address I have a number of other routers dotted around the premises acting as extenders, providing wifi access. All works fine at the moment.

What I want to do is, use the parental controls or firewall to limit some WIFI traffic, using Openwrt on the BT router. Because the WAN interface is not being used and ALL the routers are connected via LAN, any rule I setup does not work as they are ALL on the same zone.

How can I setup the WAN on the BT router so that it connects to the 4G router via ethernet and still gives me internet on the Openwrt BT router, which will create a new zone so that the parental controls can be used

Easiest, change the LAN subnet on the Huawei, and connect the devices LAN -> WAN (Hub)

If not doable, change the subnet on the LAN side of the Hub, and connect LAN -> WAN (Hub)
Obviously all other devices using the Hub as router, have to change their IPs too, assuming
their data is supposed to go via the Hub.

I can easily change the 4G router to and connect to the WAN of the Hub.
However, I am a little confused as to the settings I would use for the WAN interface.

DHCP client, or static IP in the 192.168.2 subnet
The latter requires more work, but gives more control, if you're not picky, use the DHCP client, it's easier.

Tried the DHCP client. I think that my WAN interface settings are not correct

are you sure dsl0 is the right interface for the WAN, considering openwrt says the interface isn't present ?

unplug and reinsert the ethernet cable into the WAN port, check in system log of the Hub which interface changes it's state, that would be the one you should use as WAN.

(or ssh to the Hub, and run dmesg)

Can't see any activity relating to WAN.
Would it be better to delete and recreate the WAN interface ?
If so, will it just require the DHCP client option only?

if it was there from day one, yes, it could be assuming it's used for ADSL, and DHCP client only.

read WAN port does not work with ISP (BT Home Hub 5.0)
from that thread, it should look something like this in dmesg.

-- plugging WAN cable.
[10050.988789] lantiq,xrx200-net 1e108000.eth eth0: port 5 got link
[10050.994233] br-lan: port 1(eth0.1) entered blocking state
[10050.998843] br-lan: port 1(eth0.1) entered forwarding state
[10076.189174] nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based firewall rule not found. Use the iptables CT target to attach helpers instead.

Seems it could be eth0.2
BT Hub 5a Fresh Install, no internet

I only get the line below, nothing else
[10050.988789] lantiq,xrx200-net 1e108000.eth eth0: port 5 got link

Looks like you have to create a vlan for the wan port??

1 Like

There is already a VLAN for the WAN, do I need to create another ?

start by recreating the WAN port, to start with.

the info in the wiki might be outdated.

I have created the WAN port and set it up as DHCP Client for Eth0.2, which now shows its active, but I can't get the internet when the 4G router is connected to the WAN port.

yeah, the clients now have the default gw set incorrectly.

it needs to get refreshed either by restarting the clients, or disconnecting them from the Hubs wifi.
quickly switching flight mode on and off will work too.

or reboot the hub, so all devices temp lose internet access :wink:

The LAN IP of the 4G router is The IP of the BT Openwrt router is and is the DHCP.. I have set the IPV4 GW as and DNS as the same, with additional DNS servers as,

I have rebooted the hub and 4G router. No connection to the internet

pretty sure the clients' GW should be the Hubs LAN IP.

Tried the static address, were the IPV4 Gateway gets picked automatically, however, it will not allow me to use the same address in the device IPV4 address

well no, your WAN IP can't ge the same as the IP of the Huawei (= the GW for the Hub).

Leave the DHCP client on for WAN, it should get the correct values by default, it's not where the problem is anyway.

Another option is to reset the Hub, and start from scratch, only thing you really should need to do then, is to readd the WAN, if it isn't there by default.

I changed my last post, reread it.

As you can see from the screenshot below, I am now getting more packets on the WAN interface.
I enabled the DHCP on the Huawei, as its using the 198.168.2 subnet, where as the Hub is using 192.168.1. Should there be a bridge on the WAN interface to the LAN ?