Bridging and accessing "dumb" ap web interface

I have REALLY tried to understand this but every post I read has totally different approaches. On top of that, most of them want to bridge a modem, I want to bridge my old modem that I now want to use as dumb AP for wifi.

I do NOT have wifi on my openwrt router.

I managed to set the dumb-ap with static ip (192.168.1.2) and on my wrt router (192.168.1.1) I have added static ip to the mac adress and I CAN SEE THE DUMB AP on the router (got lease) and it has the correct ip.
I can not ping it or access dumb ap web interface from my computer.

Now, the extended problem is that I disabled DHCP on the wifi-dumb-ap, so I can't even connect with a wifi unit and edit it on the web interface to remove the bridged mode and it doesn't seem to get ip from my router, just says "fail to obtain ip adress".
I REALLY don't want to factory reset it and loose all settings I have made, besides, I need to get this to work anyway.

By connecting cable only to the dumb-ap designated port (this router calles it dmz, witch is super dumb imho) I can see the dumb ap status lamp going from red to green, so it def gets connection through it.

I have probably read 25 posts about this problem, and it seems to be a routing thing. Some say I should add another interface, some say to just put some routing rules in the firewall, and some say a mix of the two or something completely different. What almost all of those posts assume is that the router also has a wifi, witch mine doesn't.

Request what info you need more and I'll screencap/post it immediately, don't want to create a wall of text immediately.

Your question about configuring a non-OpenWrt device is a bit out of scope here, so you may need to refer to the documentation and/or support channels for that device... but here's my guess as to what is happening (correct me if these are wrong):

  • you likely connected the OpenWrt LAN > Dumb AP WAN
  • and then you probably set the AP to use the same subnet on its LAN as on the WAN.

What you need to do is connect the OpenWrt LAN > dumb AP LAN. It sounds like you've already disabled the DHCP server on that device, but if you haven't, be sure to do that. Make sure that the LAN address (usually a static assignment on the device) is set to 192.168.1.2 (per your description above), and that wifi is enabled properly on your AP (most consumer all-in-one routers will bridge the wifi and wired LAN, so it should just work). Your wifi devices should work once you've fixed the physical connections and verified the address and wifi settings.

Thank you for responding.

This is what confuses the fk out of me:

What do you mean by this, and why? (you are correct in your assumption because I thought that was if you had 2 wifi routers)

I read a lot of post where they define 192.168.1.1 and 192.168.2.1 as different "subnets", while I interprit different subnets as the ACTUAL subnet is different. f.ex 255.255.255.0 and 255.255.0.0.
Witch one do you mean? :slight_smile:

Don't I need to do ANY changes on the openWRT router?
Since I set the ip adress static on the dumb-ap, should I still set it statically on the router or could that just complicate things?

For your purposes, you want the LAN-LAN connection and an address in the same subnet. This is how a dumb ap should operate.

However, if you were cascading two routers in routing mode, you need to make sure they are on different subnets. The simple way to imagine why is this: you have an item that you need to hand to someone in the room. If all of the people have the same name, you wouldn’t be able to complete your task. If the have different names, there is no ambiguity and you can pass the object to the right person. This is important, but not relevant to use case.

Subnets are a combination of the address (I.e 192.168.2.1) and the subnet mask (such as 255.255.255.0).

If you want to understand more about subnets, see this:

So in my case the this is correct?
Router ip: 192.168.1.1/24
Dumb ap: 192.168.1.2/24

Moving on, not sure how to explain or if I should even ask or just ignore and move on.

So this happened. I reset the router, someone got annoyed with me and wanted to watch tv that was on the wireless. xD
So quick reset and change back to correct SSID and pass, no huge biggie I guess.
When tv got assigned ip I figuered that lease works for 12 hrs, I can tinker a liiiiittle more and turned off the dhcp server on the dumb-ap.

Accessed the web interface of the ap to check that the dhcp was disabled and mac address of the tv box to see if I could add it and also check the ip if I could ping.
Ping to tv box=successfull (wtf?!?)

Logged into the wrt-router but the ip lease was not showing there. so fkn strange. oh well.
Checked with my phone if I could connect to the wifi (should not be able to) IT WORKED, but where is the ip lease on the ap-router?!? just not there. For other reasons I was going to check something on the wrt-router and... well, THE PHONE WAS THERE. WTF is going on?!?!

I.... I... I don't know what to say.

You set the ip manually (static ip assignment) on the ap’s lan interface. Therefore it is not requesting a dhcp lease and thus won’t show up in the dhcp lease table.

Meanwhile,

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Well, that depends, would be kinda nice to know whyyyyyy it works, should this really work?!?!

Maybe I should just move on with a win, it's not often something just suddenly works, its usually the other way around. xD

Really appreciate you taking your time though!

You changed the topography of your network - and your sundry devices needed to catch up to the changes ... whether a disconnect/reconnect updated dhcp gateway, dns, default routes and their underlying mac addrs ...

There's 2 ends to each device <---> router connection and both have to be in sync.