Bricked router Buffalo WZR-HP-G450H need HELP

i used on the router openwrt for some years, but when reflashed it with newer version it got bricked.
tried setting connection to router with Lan, setting pc ip to then retried to subnet and gateway then but it keeps sayin unidentified network..unpluged cable in cycle

can't ping or neither
tftp obviously didn't work since there's no lan connection

what can i do to recover it ? thanks

TFTP recovery should work

i am not sure i understand that guide... after setting tftp as server, will it require opening the router and special equipment that i don't have ? PS. i did set it a a server but i keeps saying unidentified i doin something wrong? the link says "Set up minicom" what is that ??

You're probably supposed to use a tftp client here, not the server, it (the server) is on the device itself.

do i have to buy a usb with pins and that sorta stuff to do that ?

no, unless you need to use the How to recover from a broken firmware method.

1 Like

so 1 means the server is already running on router. right ? i should skip that step?

where should i write sudo command from number 2 ?
i have windows 10. no osx or linux

made a copy and paste from the above guide....

  1. Start a TFTP server on your computer.
  • On Fedora, you can do it with:

$ sudo yum install tftpd-server $ sudo service xinetd start $ cd /var/lib/tftpboot

  1. Download the sysupgrade image

$ sudo wget

  1. Set up minicom:

$ sudo minicom -s

  • Set serial device to /dev/ttyUSDB0

you're reading the wrong paragraph - try TFTP Recovery.

as said in original post, i can't connect or ping the router, tftp was the first thing i tried, it does nothing !

can't ping or neither
tftp obviously didn't work since there's no lan connection

p.s what i did through tftpd64 was loading the firmware and trying to flash, progress barr hanged.
reading the recovery above it talks about arp and mac and from where i work with those from the tftpd64 ?

It tends to help a lot, to put an unmanaged switch between defective router and your PC.

The ARP entry needs to be set in parallel (before) your attempts with a tftp-client.

just because it doesn't answer ping, doesn't mean it's dead.

as slh (and me, previously) states, wrong application, use the client.

It won't (can't) answer pings, before you've set the ARP entry on your PC.

thanks for the replies. but i know nothin about the arp thing.
from where i do the arp part (whatever it is) ? name of an app to do arp from windows? and how to use it please

i tried on cmd after assigning static ip to pc, pc connected to router via ethernet, windows 10
arp -s my-ma-ca-dd-re-ss
but i get "the arp entry addition failed: access is denied"
i get same messages if the ethernet cable is disconnected.

what now ?

Did you try failsafe mode?

You might need elevated auths in win, for arp, and the mac should be of the router, not of your computer.

yep... the mac is of the bricked router and cmd was run as admin. as sadly expected "no ping ,no party" if theres no connection how can it take commands ??

"but it keeps sayin unidentified network..unpluged cable in cycle"

is failsafe the procedure where you keep hanged the reset button while pluggin the power cable for 10-15 sec ?

i am unable to go in failsafe, don't know if am doin it wrong or router is unrecoverable

any other ideas ?

i was able to to build a serial usb cable, solder it on router and get to openwrt command line. any one knows if i can flash the firmware from there with no lan ??