Bricked Archer C7 v5?

Hello all,

I have a weird problem that I cannot seem to solve despite countless hours of searching. I had attempted to flash my Archer c7 v5 via the tp-link web gui (which was most likely my first mistake) and while it seemed to work initially, after a reboot the router seems to be in a bricked state. I have tried to follow the tftp flashing guide in an attempt to fix it to no avail.
So, the following questions:

  1. The lights on the front flash as follows:
    Power light constantly on
    After 10 seconds or so, all the other lights flash at
    I'm hoping that this means it is just bricked and not unrecoverable?

  2. I'm using windows 10 and I have connected to my router via Ethernet to lan 1. I have set my up to and have downloaded the latest stock firmware and renamed it ArcherC7v5_tp_recovery.bin
    Hopefully good so far?

  3. I'm using SolarWinds tftp server and binding it to As well I have placed the bin file in the server room directory. I then power of fthe router and set it to tftp recovery mode using the two following methods:

    Powering on the router and holding wps button for 8 seconds. This results in nothing but the same light pattern described above and I don't see any indication from tftp that it tried to connect

    Hitting the reset button and powering on the router while holding reset for 7-10 seconds. This has the same result as with the other method.

Any help with this would be greatly appreciated.

Also forgive the formatting as I'm on mobile at the moment

As well, Is it worth it to get a serial adapter to try and see what's going on? I'm going to try and confirm that tftp is working on my end and is using the correct ip address but besides me maybe not getting my router into recovery mode, I'm not sure what else could be going on.

Did you fix it?

maybe flashing an openwrt factory image with hex edited header could help here. when the manufacturer/product id gets corrupted, the bootloader refuses tftp images with them set to correct values. I've recovered mine long ago by hexing 0xffffffff in , let it flash and then sysupgrade -f 'ed to the same openwrt image in original state again so future upgrades run under the correct manufacturer id again. (search my topic from the past)

See: Need Modified Image Archer C7 v2 Product ID Verify Fail Bricked/Bootloop

1 Like