Need Modified Image Archer C7 v2 Product ID Verify Fail Bricked/Bootloop

I know they are/were out there, but none of the links I found worked.


Thank You,


Can you post your serial bootlog from a failed tftp recovery if possible?

Normally your device does expect the values to be everything "ff" if you've erased this flash part and haven't written anything to it, but sometimes you will have other wrong values...

Never done it, so not sure if I can, this is all new to me. Also, I have not been able to stop the bootloop with tpl yet. I am working on that now and will get back to you.

Thank you for your reply.

I just started to attempt de-brick again. This thing is ridiculous. I cannot get anything to work. There is too much information and misinformation scattered everywhere. The level of frustration is not worth it, but I want to try to get it to work if it is all possible.


Have you tried using the TFTP Method?
One thing to remember that is not mentioned in that guide is that some routers will only ACCEPT a bin with the correct name on it. To find out if your router is still waiting for a TFTP Boot, when it starts up you can connect your bricked device to your PC and run wireshark on the PC. Wireshark should show you what exactly your router is asking for, IF it's asking for anything of course.

This has information on how to TFTP recover your device. Good luck.

TFTF does not work. It will flash and fail.

I tried two serial to TTL adapters, one, a PL2303, works sometimes randomly. Other times, it will read, but not send, or gibberish is displayed and then blue screens the win 10 laptop. The other a CH340 chipset only displays gibberish. All port settings have been checked multiple times. I have used both terminal and putty. Neither are consistent. One will work when the other will not.


You don't need serial flash, editing the firmware file cautiously with a hex editor will get it up again. I've found a post somewhere herein ago and followed to enter the "wrong" product id as hex code into the flash image and then I could flash it with tftpd32 . After this was successful, openwrt booted again and I could do a sysupgrade -f (force) flash to get the original fw image in, containing the right product id. After the two flashes I no more had problems with brick and I can normally upgrade openwrt through the web ui.

I think I found it here again : Can't get my archer c7 unbricked.. been trying all weekend

The serial console could only help in getting the product id from the uboot output that you know if ot expects a to-flash file to have 0x00000000 or 0xffffffff

The original post has the content to be put in by hexedit, Can't get my archer c7 unbricked.. been trying all weekend

But it's about restoring a more severe damaged router. If you just have a brick after flashing which occured to me to multiple devices when upgrading from 18.x to 19.x , then hex editing and uploading this via tftp works.

Which is why the subject is need modified image. I know someone has it. Bit banging is not my area of expertise.

Edited a 19.07.03 factory image with hwid (offset 0x40) and product id (offset 0x44) set to 0xffffffff.

Here you go:

You have to use the tftp recovery method:

I don't know what it is, or how to get it back to stock, but it's alive! I can;t even fathom how many hours I spent trying to get this thing back to life. I am so grateful for your help! If you have a suggestion on how to get it back to stock, I would appreciate it very much.

Thank You!


The same method also works for restoring back to the stock firmware.
But first you have to flash a sysupgrade image from a running OpenWrt with the forced option, eg. sysupgrade -F ..., to restore your device specific hwid and product id.
The forced option should also be available from luci web interface.
Probably it will also work without the forced option, I'm not absolutely sure...
Feel free to ask one more time if you aren't know how to do that.

I was going to flash Gargoyle, but I waited, in fear of bricking again. I should flash a sysupgrade image of what? From the openwrt gui? Yes I would like to restore the correct ID's.

Thank You again!

I've answered your question already... Follow the link and download this image!

From shell:
sysupgrade -F

Or luci web interface should also work. You probably need to force the flash as the check can fail due to wrong id's!

I figured out what you suggested, then bricked it again. I was able to recover it, flash stock, then flashed Gargoyle. The default password did not work, possibly due to my neglecting to uncheck the save settings for upgrade. It bootlooped/bricked in my attempts to re-flash. I then sorted it out and it is now functioning, running Gargoyle as it should. I have enough tools now to de-brick it if it ever happens again, with much thanks to you.

The downside of this router, is that the 2.4 GHz and 5.8 GHz radios use separate antennas. This is very misleading when you look at the unit on the surface as described. The RP-SMA's are for the 5.8 GHz radio only. They (TP-LINK) did not incorporate diplexers that would enable the use of dual band antenna(s). I use a dual band MIMO sector as a point to point link/bridge. So, I will have to see how it performs on 5.8 GHz only.

Not my way of doing things here, so I will try this router, but I just don't think it will be good enough for my application as a bridge. It may be useful as an AP though.

Thank you again for all of your help!

1 Like

I am happy to report, that this router works quite well on 5.8 GHz only, as a bridge.

Thanks to all for your help.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.