Bricked Archer C6 V2(Eu)

So Basically i tried out OpenWrt for the first time and i wasnt quite happy with it because it didnt reach the speeds the router was made for. So i tried rolling it back to the original fw via tftpd64 and it half bricked itself. It was in a somekind of not router but switch positon where it could connect to pc via lan and my Pc could reach the Internet and i had the full bandwith that was advertised. But because it was a router i wanted to use it as one with wifi. It did not bother me at first because this should be an acces point but later i basically needed it. So i tried flashing it again with 5 different versions of the original software via Tftpd and solarwind. I tried it with the 1.0.1 version i got from the Internet because it wasnt available on the tp-link site anymore. I tried using the newest and oldest one on tp-links own site. I tried one of two stripped versions. But no succes every time the router started up with me holding the reset button. Then catched the file from the Tftp server and the lights blinked on for a ms and at last only the Power led was on no blink or something just on straight. So i tried the Openwrt firmware again and it works flawlessly(the installation not the software itslelf). So i want to know now how i can revert it back with Tftp or with the Openwrt web gui. And why it didnt work in the first place. I have an assumption that it has something to do with the file size. Because every file was bigger than the openwrt file(6.4mb and every other one was above 7mb). I also used a program that could acces the memory of the router directly but i didnt go to deep with that because i am not experienced at all with modding routers so i am in big need for help. I hope somebody somewhere knows what my problem is. Because i have seen this exact problem a lot on some other threads on this forum aswell as on reddit or the tp-link forum. But i couldnt get any help from there.

is there web page recovery?
make a photo of the back of your router
where all the information about hardware

Do you still have acces for recovery web page or you sure tftp gets the firmware ?
if yes try these starting with oldest one
oh i see you have 8 Mb flash only
then this

And anyway why not OpenWrt? what speed did you get ?

** Warning The 5 GHz radio / Qualcomm Atheros QCA9886 support seems to be buggy in some cases.

Some users report much improved long-term stability with 5 GHz by using the closed-source ath10k firmware instead of the open-source ath10k-ct firmware. To do this remove the packages “kmod-ath10k-ct” and “ath10k-firmware-qca9888-ct” and instead install “kmod-ath10k” and “ath10k-firmware-qca9888”.**
did you try this?

I don’t have access to the site or or , and with Tftp I am sure that the file is transmitted because if I do the same with openwrt it works. I can’t Tftp the file right now. But I will try later and do you think the us version of the a6 will work with the eu version of c6? I will try tho and let you know

It has to do with lan speed. I only get 250mb stock and with software something something I get 450mb but before I changed the software to openwrt I had gigabit on all ports and also faster Wi-Fi so that’s the reason. And the update does not work for me it says it does not have enough storage to download the file

C6v2 uses a single core QCA9563 mips CPU. Using it as a router, LAN to LAN I managed about 500Mbps. Using it just as a wireless AP with VLANs it manages the same performance as stock, and with ath10k-ct-smallbuffers and with -ct firmware I haven't seen any issues (current uptime 48 days). If you need a gigabit router with OpenWRT, use at least a MT7621 based device with MT7615D wifi and enable hardware flow offloading.

For reverting to stock, can you try the guide?

1 Like

Whey should i buy a new router when the old one can do it? It did it before and i think you didn’t read my first post. C6v2 can reach 1 gigabit no problem with stock firmware. Openwrt does not

Also hardware offloading reduced the speed in comparison to using only software offloading but still no gigabit

And the lan performance is also the biggest factor in not using openwrt

Tried those out and the archer c6 v4 which is also the sam size file at least in europe and both dod not work so :frowning:

remove the packages “kmod-ath10k-ct” and “ath10k-firmware-qca9888-ct” and instead install “kmod-ath10k” and “ath10k-firmware-qca9888”.**
did you try this?
try it after installing OpenWrt via console or luci it can really improve speed
anyway OpenWrt is better i use OpenWrt since 2016 and recently i use only compatible with OpenWrt devices like Comfast or ZBTlink

I wanted to try out a feature that prioritises packages and routes them smarter but after not finding the feature. I wanted to revert back because it only had cons for me. It feels like an unfinished product so. I would rather like the original software from the router and I tried getting an answer here but it doesn’t seem like anybody knows anything about this issue even tho this is a wide problem I couldn’t find any solutions to this problem. And the router is quite common because of its advertised performance of 1 gigabit and because it is cheap. The thing with the software download is, if I delete/ remove something it still takes up the space of the memory. So looks like the software is just buggy and does not work

The feature is called SQM and can be installed using luci-app-sqm package, but note that this will lower your performance further - expect around 150-200Mbps from this CPU.

Yes, and I have provided you with a guide that should work but I haven't tested myself.

OpenWrt is flexible - you can make it what you want, it is not a complete product - this is why it has a package manager - unlike any other router firmware.

Stock firmware supports hardware-accelerated routing of packets and that enables it to have the throughput advertised even if it uses a cheap CPU. This hardware acceleration is incompatible with many OpenWrt features (features stock firmware doesn't have - such as the feature you originally tried to use - that feature requires the CPU to process all packets so it can route them smarter).

This is by design, and the only way the software can fit in such a small (8MB) flash. Look into compressed read only filesystems (squashfs) and overlays.

Anyway, the TFTP flash to restore the original firmware should work but no one can help you if they haven't done the same and it fails for them, especially if you don't provide more details.