Brick edgerouter x

I need help today I bought a more accurate ubiquiti platform, the er-x edgerouter, I wanted to try openwrt so I used this method:


to install openwrt apparently
to install openwrt apparently i tried the tar file but after upgrading the equipment it didn't work so i wanted to go back to stock firmware so i used tftp but apparently it doesn't work either, server connection was lost

I won't even answer you the way you expect, you must have done something wrong.

It works perfectly. I have extensively tested the procedure from all versions of EdgeOS. 1.x and 2.x.

It is just better, prior to install OpenWrt tar file I provide, to first upgrade EdgeOS to lastest version, to ensure you have the latest bootloader, the one from versions 2.x .

Because if not, you cannot TFTP EdgeOS back to the router to get rid of OpenWrt and reinstall back EdgeOS, you need to use sysupgrade command from OpenWrt with a special image containing EdgeOS in a form that OpenWrt can understand with sysupgrade. It takes a little longer to do, but it works too.

I can put this EdgeOS *.bin image compatible with sysupgrade command on my repository if you want it, still, there are the instructions to build it yourself on the page dedicated to EdgeRouter X on OpenWrt website.

1 Like

If no OS boots (I think that's what you're saying) and you have the old bootloader without button-activated TFTP recovery, you will need to use serial to recover.

Apparently I showed the tar with the default version that EdgeOS brings since I saw your post that said you could use the tar in any version and it broke, apparently I can't use openwrt by tftp because it has to be signed by ubiquiti and now I have no cable serial or anything, how do I fix it?

I don't have it, they don't sell it in my area, nor can it be bought online due to the pandemic

When you press the reset button for like one minute continuously, what do you see at the leds of the router, can you describe me how they are blinking ?

all LEDs blink


That is good; TFTP recovery should be possible.


Only the specially formatted and signed recovery images linked on that page will work.
Windows 10 now has a built in CLI based TFTP client but it must be enabled through "Turn Windows features on and off" in the control panel.
An Ethernet switch should be placed between the PC and the router.
Start the transfer shortly after the LEDs start blinking-- the LEDs will keep blinking forever but the TFTP server inside the router may stop.
1 Like

It worked, I was able to get my router back so my question is how to test openwrt. I already have edgeOS, the latest version.

hello, I ended up having the same problem as the creator of the topic, installed the tar file directly on the router and lost access, could someone help me how to recover, I already bought the ttl USB cable

use TFTP method

sorry for the bad english my mother tongue is latin spanish

no problems, i'm brazilian, i also have difficulty communicating with the people on the forum, my router doesn't go in tftp mode probably was out of date, i bought a ttl usb cable to do the process by serial, but i didn't find any detailed tutorial, if anyone can help me thank you immensely, I made the same mistake as you when loading .tar directly on edgeos

  1. Download https://dl.ui.com/firmwares/edgemax/v1.10.x/ER-e50.recovery.v1.10.10.5210345.190714.1127.16de5fdde.img an rename that file to "vme50" (without quotes ofc!).

  2. Download https://dl.ui.com/firmwares/edgemax/v1.10.11/ER-e50.v1.10.11.5274269.tar and keep it for later.

  3. Prepare a tftp server listening on 172.16.3.210 (PC has to have the proper IP) and verify if it is working correctly. Place the file "vme50" downloaded in step 1 within the root directory of your tftp server.

  4. Connect your PC LAN NIC to the device' "eth0" connector with a proper RJ45 cable.

  5. If all is prepared connect your USB-TTL adapter to the device itself and your PC. Open your choosen terminal program with proper settings: 57600/8/N/1/N.

For Putty:

  1. Power on your device while holding down the key "1" on your keyboard.

  2. You will see a boot screen with several options. Choose option "1" (1: Load system code to SDRAM via TFTP; It should be choosen already if you pressed "1" all time).

putty2

  1. If setup all correctly before just press three times enter to confirm the settings. After this the loading process should start. It is indicated this with chars: ################ ....

  2. The system will boot up (this will take a while).

  3. After process is ended you should see the command prompt.

  4. Access the device with your browser over IP 192.168.1.1 and enter name (ubnt) and password (ubnt).

  5. Head to the menu "System" - "Upgrade System Image" and choose the file downloaded in step 2.

  6. Wait for reboot.

Keep in mind this valid for serial recovery only!

1 Like

thank you very much friend, when i get the ttl usb cable i will try to do this process, just a doubt, the first downloaded file will be named vme50.img ?, i'm looking forward to the cable arrival because i haven't been able to use the router yet, thank you very much for your help

You can name the file whatever you want. Standard name for this device is "vme50". Without ".img". This is just for minimizing errors. If you want to use different name you just have to change the filename under step 8 which has to be loaded by the bootloader.
According to this you could setup your tftp server with different IP address also.

ok friend i really appreciate your help

friend, sorry to abuse the help, could you tell me what is the real function of putty? it only serves to reactivate tftp or can i also upload the new image for it? It will be my first experience with this software, sorry for the confused English, I am communicating through a translator.

Exactly for this step and the following, aside from being an ssh/ telnet clienty it can also be used as terminal adapter for the serial console,

2 Likes

hello friends after all this time the ttl usb cable finally arrived, but I still didn’t succeed, the router is listed as openwrt but I can’t access the router page, when trying to do the above tutorial it didn’t work as it appears in the image below

if possible i would like to continue with openwrt, but i can't access the page at all.