Brick edgerouter x

You are at an OpenWrt CLI which means you're almost done. If you can't load a web gui you can follow the process for upgrading from the CLI.

One thing to note is that under OpenWrt the port labeled eth0 is the WAN port and the other four are LAN, so you want to plug your PC into port eth1.

Do not plug any non-PoE device into port eth4 until you have turned off the PoE output. Hardware damage is likely to result.

1 Like

could you pass me step by step please? unfortunately i was already using the router on the eth4 port, i'm worried.

Which version is running now, and where do you want to end up? Do you want to install OpenWrt or Ubiquiti stock firmware?

1 Like

I would like to use openwrt, I loaded this image directly on the edgeos and after that I could no longer access the router's ip, I apologize for my ignorance and appreciate your help, I have the ttl usb cable if necessary but I am totally lay on the subject.

https://github.com/stman/OpenWRT-19.07.2-factory-tar-file-for-Ubiquiti-EdgeRouter-x/blob/master/openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar

That's a third party build. It's probably best to start by using the same process to tftp boot the 19.07.4 initramfs from the official releases.
https://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/openwrt-19.07.4-ramips-mt7621-ubnt-erx-initramfs-kernel.bin

Also get the official sysupgrade here and keep it on your PC for the next step:
https://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin
Note that though the name is .bin, it is actually a .tar file and should be compatible with sysupgrade.
Boot the initramfs from the bootloader then move the Ethernet cable to port eth1 and establish an Ethernet connection to OpenWrt. ping 192.168.1.1 should return results then try http://192.168.1.1. If the page throws an error or doesn't load completely, clear your browser cache.
On the web page select System--Backup/Flash Firmware and Flash Image at the bottom. Use the sysupgrade image you downloaded.

how do i load the firmware using the putty?

I connected the lan cable to eth1 and when pinging with the automatic ip it gave an error, when placing the gateway manually I managed to ping but still not access the router's page

You cannot use the official kernel images because they are to big in size and do not fit into kernel partition. You have to use the community built kernel images or make your own build.

made by @stman 19.07.2.
https://github.com/stman/OpenWRT-19.07.2-factory-tar-file-for-Ubiquiti-EdgeRouter-x/blob/master/openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar

made by myself 19.07.4:
https://mega.nz/file/5gwDwS5D#CofsuNnsGOBr960pTQcZ6EPCqOz9zK9hQvxfKbt49Wo

@fnk633

As you have an USB-TTL adapter now and your device was bricked before you should first re-install EdgeOS and upgrade your Bootloader to the most recent version to make TFTP recovery more convinient for future. You can follow this guide:

Use this firmware version:

https://dl.ui.com/firmwares/edgemax/v1.10.x/ER-e50.recovery.v1.10.10.5210345.190714.1127.16de5fdde.img

After this follow "Factory firmware installation" of the wiki:

the putty page appears different because my edgerouter is with openwrt

If you want to just finish OpenWrt installation:

Download:
http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin

After the device has rebooted connect your PC to eth1 of EdgeRouter (you should get a DHCP IP now) and upload the sysupgrade image to the device, access the device via SSH and install the firmware to finish installation process:

scp /path/to/your/kernel-image/openwrt-19.07.4-ramips-mt7621-ubnt-erx-sfp-squashfs-sysupgrade.bin ubnt@192.168.1.1:/tmp

ssh root@192.168.1.1

root@OpenWrt:/$ cd tmp

root@OpenWrt:/tmp$ sysupgrade -v -n -F openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin

The device will reboot automatically and is ready for operation after.

For scp you can use putty pscp.exe program:

I am completely lost, the commands are not working

Do not execute the command prompt "root@OpenWrt:/$" :smiley:

cd tmp

sysupgrade -v -n -F openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin

and replace scp from above with pscp.exe to upload the file

when I run the first command asks for the ubnt password, but I can't type anything in the field

argh ... that was my fault .. It has to be root@192.168.1.1:/tmp

now accepted friend, but in which directory should I put the image? I tried to put it in the putty directory

You have to adjust this path (/path/to/your/kernel-image/) to the downloaded file or execute scp from within the directory where the downloaded file is (ofc without path then; just the filename) actually.

You are uploading with scp the downloaded file to the router itself.

This file:

http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin

friend sorry for my stupidity, what am i doing wrong? I've been trying to recover the router for two hours and I'm totally frustrated

https://ibb.co/bvnSCZw

you are already on the router! you have to scp from your pc where you downloaded the file!
open an new cmd and enter the command for upload from there.