Blueendless Kimax BS-U35-WF


#1

HI,

I installed @RinaGute Firmware from this link yesterday. Flashing was successful however after reboot, I lost wifi access to the device and LAN connection does not connect either.

Connecting LAN results in "unidentified public" network with IP address starting with 169 series. I have tried to connect using 3 different computers running WIndows 10 and Windows 7 OS. Have also tried almost all troubleshooting steps I could find on the internet however no success. Can anyone help if they have faced similar issue with this Router/NAS or similar routers?

Thanks in advance.


#2

That firmware is from a person in the old forums named: RinaGute. You need to contact them.

In addition, your device is not listed in the Table of Hardware - therefore, it's not supported.

Also, the post with link to the firmware is over 2 years old, I wouldn't recommend that firmware for use today.


#3

Thanks you for your response, unfortunately, it is too late for me as I flashed it and then lost access to the device. I am not very strong on technical, specially Linux hence thought to seek help in case RinaGute is active here.

I remember I saw this device on OpenWrt.org support page however surprised that you are "not supported". I could find this model's entry on this link.

Can anyone offer assistance or refer me to some guide?


#4

This means that a development snapshot should be available for the WF model

From: https://openwrt.org/toh/hwdata/blueendless/blueendless_u35wf

Firmware OpenWrt snapshot Upgrade URL:

http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-kimax_u35wf-squashfs-sysupgrade.bin


#5

I see this link but the problem is to bring device's network back to life. How do I flash this or factory firmware back without getting a proper IP? I saw few post talking about unbricking using serial cable, can you guide me to such article?


#6

From the git commit referenced in the ToH

ramips: add support for Blueendless Kimax U35WF

Blueendless Kimax U35WF is a 3,5" HDD Enclosure with Wi-Fi and Ethernet

Patch rewritten from: https://forum.openwrt.org/viewtopic.php?id=66908
Based on: https://github.com/lede-project/source/pull/965

Specification:

  • SoC: MediaTek MT7620N
  • CPU/Speed: 580 MHz
  • Flash-Chip: KH25L12835F Spi Flash
  • Flash size: 16 MiB
  • RAM: 64 MiB
  • LAN: 1x 100 Mbps Ethernet
  • WiFi SoC-integrated: 802.11bgn
  • 1x USB 2.0
  • UART: for serial console

Installation:

  1. Download sysupgrade.bin
  2. Open vendor web interface
  3. Choose to upgrade firmware
  4. After reboot connect via ethernet at 192.168.1.1

#7

Thanks Jeff, i will read the thread tomorrow. I could find that RinaGute is some guy Orlando Leite, he has a github profile but could not find anything else to contact him.

Regarding installation, it would work only if I could access the interface. Tomorrow I will try connect it on router after changing router's default gateway to some other IP other than 192.168.1.1 and then try to connect it via my PC. I hope it works out as I am sure only Wifi network is dead, the device is booting up and working as expected.


#8

Had success connecting to the device via a router, apparently, router assigned IP 192.168.1.100 for some reasons.

Stuck again as I cannot login due to unknown username and password. All common username and password such as 'kimax', 'password', '12345678' 'admin' does not work.

I read here that password is blank however, even that's not working.

Any help?

Capture


#9

Try using ssh to connect to the router and setting a password


#10

How? Using PuTTY? Can you guide me a little bit with command lines?


#11

I don't use Windows myself, but https://openwrt.org/docs/guide-quick-start/sshadministration may help


#12

Already tried, no success. It won't accept blank password hence, access denied.

On this page, a person soldered some RS232 wires to hard reset. Do you know what this is and how do I achieve it?


#13

If the password is not blank, you might want to look at the sources and build system you are using to either determine the credentials, or modify them so that you know the credentials.


#14

I am really sorry Jeff, I know you are trying to help me and I am keeping coming back to you with more. I might need your help on that too.

I am not a techie and no clue how to do that. if you point me to the direction, i can try to find it.


#15

Unfortunately you're not using OpenWrt, as OpenWrt delivers it, and not on an officially supported device.

If it were "real" OpenWrt then the password would be empty and the usual methods for reset and reset-to-default would work.

Scanning the thread from the old forums you linked, @F5BJR looks like they, at least at one point

I have compiled for U25-AWF-H1

and they may have some insight into the device.


#16

Thanks Jeff. let me scan it further. I am sure I would find a solution soon, when I do, I will post it here.


#17

Update: I bought a UART USB Dongle to connect the board using COM port. Struggled to solder wires due to very small connections. Connection did not work as expected.

On Adapter/Dongle, only 2 lights turn on however all three are required.
U35WF%20Connection%20and%20Serial%20Port

Seeking help here.


#18

Issue still open, I managed to access console but command line does not turn on.


#19

Hi,

I´ve bought two "Blueendless Kimax U35WF" cases. Their web interface says "Router model: Kimax-H1" and I could see they have the Mediatek MT7620A inside. Well, I think we´re talking about the same device!

I´ve tried to use the file openwrt-18.06.1-ramips-mt7620-mt7620a-squashfs-sysupgrade.bin and now one of the cases is dead! Maybe this was the wrong file, maybe I´ve turned the case off too soon after/during the upgrade (I´m considering that)...

Could you please help me? Is there a way to recover the bricked case?

I´d like to update the second HD case. Can I use one of these files?

1 - releases/18.06.2/targets/ramips/mt7620/openwrt-18.06.2-ramips-mt7620-mt7620a-squashfs-sysupgrade.bin
2 - releases/18.06.2/targets/ramips/mt7620/openwrt-18.06.2-ramips-mt7620-mt7620a_mt7530-squashfs-sysupgrade.bin
3 - releases/18.06.2/targets/ramips/mt7620/openwrt-18.06.2-ramips-mt7620-mt7620a_mt7610e-squashfs-sysupgrade.bin
4 - releases/18.06.2/targets/ramips/mt7620/openwrt-18.06.2-ramips-mt7620-mt7620a_v22sg-squashfs-sysupgrade.bin

Thanks,
Eduardo

IMG_20190205_212040686


#20

You shouldn't turn off a device during upgrade. It should reboot itself.