Blank Putty session on serial port connection with CP2102

HI all,
i was only able to embed 1 pic. please refer links
I successfully installed OpenWRT on my Xiaomi MiWiFi 3C using BREED. And I tried to revert to factory firmware. but it failed and my router never turned on and was not detected using the ethernet port. so I purchased USB to TTL CP2102 Connector and tried to connect to the serial port with putty. But I am getting blank putty screen.

This is how i connected to putty.

after connecting to putty with plugged in powers suply

Below image is my cp2102 device when the router is not plugged to a power source.
both Red and Blue is glowing

after connecting power only red is glowing. and it makes a small keek noise for a second when plugged in power

Did you try reversing rx and tx?

Disclaimer: I'm not familiar with this particular router, but rx/ tx definitions are often mixed up.

1 Like

Yes, I tried reversing TX and RX. As soon as I connect power blie light is turning off. I think there is some hardware issue

and the 3.3V isn't connected .... ?

i tried with connecting 3.3v and it behaved the same way.

when 3.3v was plugged in only red was glowing. when 3.v was not plugged in to serial port blue and red was glowing.

3.3V shouldn't be connected.

and if you short RX and TX, can you see your own typing in the terminal window ?

You brick your bootloader
only solution is using spi programer for rewrite bootloader.
write in there.

yes, I think i bricked my bootloader. I unplugged power while installing firmware.

is there any way to rewrite the bootloader using serial connector CP2102. because I don't have a programmer. I already purchased CP2102 serial connector. and the programer costs more than the router it self. instead, I can buy new router.

i want to know if I can SPI dump using CP 2102

yes. if i short tx and rx on cp2102 i can see my own typing

MT7628 does not have ROM boot, it must have a flash chip with bootloader already present for the serial port to do anything. So you need to SPI write directly to the flash chip. Boards based on the CH341 chip are commonly used for this, they cost less than $10.


ok, i will buy a programmer then. thanks all for help. i will update after I flash the spi chip

1 Like

I purchased a CH341A Programmer and flashed SPI with BREED as I was not able to flash with MIWIFI Factory Firmware. then using BREED WEB Recovery i updated to open wrt.


Thanks for helping

1 Like

Now i have lot to learn in OpenWRT. haha

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.