Hi @quarky,
the old driver is much less picky when it comes to ECC errors. It will work just as well with the re-written factory partition.
Hi @quarky,
the old driver is much less picky when it comes to ECC errors. It will work just as well with the re-written factory partition.
That sounds bad, as it really means that the new spi-nand driver does not accept stuff originally written by the OEM to RT3200/E8450.
cc @981213
Thank you for reporting that @hlew . This confirms what I was guessing but could not empirically verify: It comes with ECC errors out of the factory. I re-wrote the flash completely several time during development and also the installer may re-write parts of the factory partition in case it is needed to restore offsets without BMT, so I wasn't sure if only things written with the old driver, also used in old versions of the installer, cause trouble for the new driver.
As you never run the UBI installer and still got the device with it's original bootchain, the fact that it broke for you too confirms that the problem of corrupted ECC data also applied when the device comes right out of factory....
btw: do you see read-errors when trying got read other /dev/mtdblock*
devices?
Unfortunately the only way out is to either give the new driver an option (?) to be more tolerant with pre-existing ECC errors or to re-rewrite at least the factory
partition using the new driver.
As having correct ECC data is nice to have if you plan to use this thing for a decade or so having that cheap-brand SPI-NAND chip, I'd recommend re-writing so you got ECC in future.
Doing so requires booting with initramfs image where you removed the read-only
attribute from MTD partitions in device-tree.
OOB area for user data are reordered in the old driver but ECC part shouldn't be affected, as those data are placed by hardware, not by our drivers.
The old driver just doesn't report any bitflips in _mtd_read return value (due to how the spi-nand driver was hacked) which makes everything appear fine.
We just need to fix mt76 to ignore -EUCLEAN and everything should work again without other steps.
edit: I'd still recommend a rewriting to clear those bitflips as there are already 3 bits flipped when -EUCLEAN is reported and mt7622-snand is only able to correct up to 4 bitflips.
FYI there's a mtd-rw module in packages feed which unlocks all read-only partitions:
Last week, I was able to flash the non ubi image through the Belkin web interface. I decided to go back to stock by installing Belkin firmware through luci. Now I want to go back to non ubi image but nothing happens when I flash it on Belkin's web interface.
What could be wrong?
I was having the same issue and assumed that the image was not flashing correctly hence the board was defaulting to the stock firmware. As I mentioned a few posts ago, I had to revert to an earlier commit/build to get everything working again.
Thanks! Doing that worked.
Most recent snapshots should also work again.
Been busy for the past couple of days so I wasn't able to reply you earlier. Here is the network config:
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdef::::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.X.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.X.254'
option broadcast '192.168.X.255'
list dns '192.168.X.254'
list dns '9.9.9.9'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
root@OpenWrt:~#
Also I have updated the Wireless config as per your suggestion:
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wmac'
option band '2g'
option channel 'auto'
option cell_density '0'
option country 'IN'
option noscan '1'
option htmode 'HT40'
option legacy_rates '1'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option key '*********'
option ssid '2.4G_Network'
option disassoc_low_ack '0'
option encryption 'psk-mixed'
config wifi-device 'radio1'
option type 'mac80211'
option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option band '5g'
option channel 'auto'
option htmode 'VHT80'
option cell_density '3'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option key '*********'
option ssid '5G_Network'
option encryption 'psk-mixed'
option disassoc_low_ack '0'
option short_preamble '0'
Still I am seeing the same issue with Wifi clients not able to communicate to each other. It seems like we are hitting a bug similar to this https://bugs.openwrt.org/index.php?do=details&task_id=714, https://forum.openwrt.org/t/clients-in-same-wlan-cant-reach-each-other/2501
Anyone else having issues similar to this? I only see ARP requests between the wireless networks but no ARP replies when pinging.
Any idea what the issue could be related to?
Daniel,
After updating to the Openwrt firmware to r17443-90e167abaa https://github.com/dangowrt/linksys-e8450-openwrt-installer/releases/tag/v0.5.3, I lost my 5Ghz network. The interface doesn't show up and I see below errors in the system log:
Wed Sep 1 18:35:48 2021 daemon.notice netifd: radio1 (2324): Phy not found
Wed Sep 1 18:35:48 2021 daemon.notice netifd: radio1 (2324): Could not find PHY for device 'radio1'
Wed Sep 1 18:35:48 2021 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network
Wed Sep 1 18:35:48 2021 daemon.notice netifd: radio1 (2361): WARNING: Variable 'data' does not exist or is not an array/object
Wed Sep 1 18:35:48 2021 daemon.notice netifd: radio1 (2361): Bug: PHY is undefined for device 'radio1'
I tried updating to the latest snapshot but no luck. 5GHz is still down. Do I need to go back to a previous release?
Thanks in advance.
I just used the sysupgrade installer, do I need to install the recovery first and then install the sysupgrade?
Yes.
(you need the actions from the recovery installer script)
Like Daniel says above:
Ok, so now can I install the recovery? Sorry I didn't know that was for the new firmware, I thought he was sharing the generic upgrade procedure.
Just wanted to confirm that I am doing this correct, I should first flash the recovery installer and then once openwrt boots into recovery I need to flash the sysupgrade firmware, correct?
By the by, I am seeing below message when I try to flash recovery:
Yes, you have to use the force (ie. override the check) to re-run the installer once OpenWrt is already running.
If you have already used the 0.2.4 installer with the stock firmware it is not necessary to do that and will also not solve any problems.
In that case (ie. problems despite you have already run the 0.2.4 installer when installing for the first time from stock) something else must be wrong. Please login to the device via SSH and send the output of the following commands to be (by PM if you prefer):
dmesg
hexdump -C /dev/mtd2
hexdump -C /dev/mtdblock2
Hi Daniel,
I am not coming from the stock, I was on a snapshot build which was released on 26th and then I upgraded that to 0.5.3 from Github without upgrading the recovery. After that 5GHz stopped working and then I tried upgrading that to the latest snapshot and I still don't have the 5GHz working. Do I need to flash this recovery and try again?
I will post the requested outputs shortly.
I'm having the same exact problem. New hardware, fresh install of 0.5.3 (ubi-recovery-installer then ubi-squashfs). Didn't get wifi 5GHz to work, upgraded to snapshot. Now stuck on snapshot (have tried force flashing all original 0.5.3 files).
Continuing the discussion from Belkin RT3200/Linksys E8450 WiFi AX discussion:
dmesg:
[ 0.000000] Booting Linux on physical CPU 0x0000000000 [0x410fd034]
[ 0.000000] Linux version 5.10.60 (builder@buildhost) (aarch64-openwrt-linux-musl-gcc (OpenWrt GCC 10.3.0 r17443-90e167abaa) 10.3.0, GNU ld (GNU Binutils) 2.36.1) #0 SMP Fri Aug 27 23:35:02 2021
[ 0.000000] Machine model: Linksys E8450 (UBI)
[ 0.000000] earlycon: uart8250 at MMIO32 0x0000000011002000 (options '')
[ 0.000000] printk: bootconsole [uart8250] enabled
[ 0.000000] Zone ranges:
[ 0.000000] DMA [mem 0x0000000040000000-0x000000005fffffff]
[ 0.000000] DMA32 empty
[ 0.000000] Normal empty
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000040000000-0x0000000042ffffff]
[ 0.000000] node 0: [mem 0x0000000043000000-0x000000004302ffff]
[ 0.000000] node 0: [mem 0x0000000043030000-0x000000005fffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000040000000-0x000000005fffffff]
[ 0.000000] On node 0 totalpages: 131072
[ 0.000000] DMA zone: 2048 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 131072 pages, LIFO batch:31
[ 0.000000] psci: probing for conduit method from DT.
[ 0.000000] psci: PSCIv1.1 detected in firmware.
[ 0.000000] psci: Using standard PSCI v0.2 function IDs
[ 0.000000] psci: MIGRATE_INFO_TYPE not supported.
[ 0.000000] psci: SMC Calling Convention v1.2
[ 0.000000] percpu: Embedded 20 pages/cpu s43672 r8192 d30056 u81920
[ 0.000000] pcpu-alloc: s43672 r8192 d30056 u81920 alloc=20*4096
[ 0.000000] pcpu-alloc: [0] 0 [0] 1
[ 0.000000] Detected VIPT I-cache on CPU0
[ 0.000000] CPU features: detected: ARM erratum 845719
[ 0.000000] CPU features: kernel page table isolation disabled by kernel configuration
[ 0.000000] CPU features: detected: ARM erratum 843419
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 129024
[ 0.000000] Kernel command line: earlycon=uart8250,mmio32,0x11002000 console=ttyS0,115200n1 swiotlb=512
[ 0.000000] Dentry cache hash table entries: 65536 (order: 7, 524288 bytes, linear)
[ 0.000000] Inode-cache hash table entries: 32768 (order: 6, 262144 bytes, linear)
[ 0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[ 0.000000] Memory: 488596K/524288K available (8126K kernel code, 874K rwdata, 2212K rodata, 448K init, 303K bss, 35692K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[ 0.000000] rcu: Hierarchical RCU implementation.
[ 0.000000] rcu: CONFIG_RCU_FANOUT set to non-default value of 32.
[ 0.000000] Tracing variant of Tasks RCU enabled.
[ 0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[ 0.000000] NR_IRQS: 64, nr_irqs: 64, preallocated irqs: 0
[ 0.000000] GIC: GICv2 detected, but range too small and irqchip.gicv2_force_probe not set
[ 0.000000] random: get_random_bytes called from start_kernel+0x344/0x488 with crng_init=0
[ 0.000000] arch_timer: cp15 timer(s) running at 12.50MHz (phys).
[ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x2e2049cda, max_idle_ns: 440795202628 ns
[ 0.000003] sched_clock: 56 bits at 12MHz, resolution 80ns, wraps every 4398046511080ns
[ 0.008491] Calibrating delay loop (skipped), value calculated using timer frequency.. 25.00 BogoMIPS (lpj=125000)
[ 0.019223] pid_max: default: 32768 minimum: 301
[ 0.024082] Mount-cache hash table entries: 1024 (order: 1, 8192 bytes, linear)
[ 0.031660] Mountpoint-cache hash table entries: 1024 (order: 1, 8192 bytes, linear)
[ 0.040656] rcu: Hierarchical SRCU implementation.
[ 0.045746] dyndbg: Ignore empty _ddebug table in a CONFIG_DYNAMIC_DEBUG_CORE build
[ 0.053959] smp: Bringing up secondary CPUs ...
[ 0.058972] Detected VIPT I-cache on CPU1
[ 0.058979] CPU features: SANITY CHECK: Unexpected variation in SYS_CNTFRQ_EL0. Boot CPU: 0x00000000bebc20, CPU1: 0x00000000000000
[ 0.058996] CPU features: Unsupported CPU feature variation detected.
[ 0.059027] CPU1: Booted secondary processor 0x0000000001 [0x410fd034]
[ 0.059094] smp: Brought up 1 node, 2 CPUs
[ 0.093078] SMP: Total of 2 processors activated.
[ 0.097946] CPU features: detected: 32-bit EL0 Support
[ 0.103267] CPU features: detected: CRC32 instructions
[ 0.108685] CPU: All CPU(s) started at EL2
[ 0.112930] alternatives: patching kernel code
[ 0.120959] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.131177] futex hash table entries: 512 (order: 3, 32768 bytes, linear)
[ 0.138287] pinctrl core: initialized pinctrl subsystem
[ 0.144785] NET: Registered protocol family 16
[ 0.149803] DMA: preallocated 128 KiB GFP_KERNEL pool for atomic allocations
[ 0.157153] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA pool for atomic allocations
[ 0.165191] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA32 pool for atomic allocations
[ 0.173743] thermal_sys: Registered thermal governor 'fair_share'
[ 0.173749] thermal_sys: Registered thermal governor 'bang_bang'
[ 0.180063] thermal_sys: Registered thermal governor 'step_wise'
[ 0.186313] thermal_sys: Registered thermal governor 'user_space'
[ 0.192815] ASID allocator initialised with 65536 entries
[ 0.205297] pstore: Registered ramoops as persistent store backend
[ 0.211730] ramoops: using 0x10000@0x42ff0000, ecc: 0
[ 0.248134] SCSI subsystem initialized
[ 0.252339] libata version 3.00 loaded.
[ 0.256493] usbcore: registered new interface driver usbfs
[ 0.262348] usbcore: registered new interface driver hub
[ 0.267887] usbcore: registered new device driver usb
[ 0.275124] clocksource: Switched to clocksource arch_sys_counter
[ 0.282124] NET: Registered protocol family 2
[ 0.286793] IP idents hash table entries: 8192 (order: 4, 65536 bytes, linear)
[ 0.294724] tcp_listen_portaddr_hash hash table entries: 256 (order: 0, 4096 bytes, linear)
[ 0.303413] TCP established hash table entries: 4096 (order: 3, 32768 bytes, linear)
[ 0.311468] TCP bind hash table entries: 4096 (order: 4, 65536 bytes, linear)
[ 0.318915] TCP: Hash tables configured (established 4096 bind 4096)
[ 0.325587] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[ 0.332358] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[ 0.339688] NET: Registered protocol family 1
[ 0.344212] PCI: CLS 0 bytes, default 64
[ 0.348500] Unpacking initramfs...
[ 1.534957] Freeing initrd memory: 4892K
[ 1.540144] workingset: timestamp_bits=46 max_order=17 bucket_order=0
[ 1.549443] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 1.555535] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 1.598581] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 250)
[ 1.606775] mtk-tphy 1a0c4000.usb-phy: failed to get ref_clk(id-1)
[ 1.618318] mt-pmic-pwrap 10001000.pwrap: unexpected interrupt int=0x1
[ 1.632756] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 1.641071] printk: console [ttyS0] disabled
[ 1.645625] 11002000.serial: ttyS0 at MMIO 0x11002000 (irq = 22, base_baud = 1562500) is a 16550A
[ 1.654852] printk: console [ttyS0] enabled
[ 1.663238] printk: bootconsole [uart8250] disabled
[ 1.673572] 11004000.serial: ttyS1 at MMIO 0x11004000 (irq = 23, base_baud = 1562500) is a 16550A
[ 1.683330] 1100c000.serial: ttyS2 at MMIO 0x1100c000 (irq = 27, base_baud = 17499995) is a MediaTek BTIF
[ 1.693051] serial serial0: tty port ttyS2 registered
[ 1.698819] mtk_rng 1020f000.rng: registered RNG driver
[ 1.698831] hwrng: no data available
[ 1.707690] cacheinfo: Unable to detect cache hierarchy for CPU 0
[ 1.716929] loop: module loaded
[ 1.720073] Loading iSCSI transport class v2.0-870.
[ 1.726722] mtk-snand 1100d000.snfi: chip is FM35Q1GA, size 128MB, page size 2048, oob size 64
[ 1.739521] 4 fixed-partitions partitions found on MTD device 1100d000.snfi
[ 1.746512] Creating 4 MTD partitions on "1100d000.snfi":
[ 1.751905] 0x000000000000-0x000000080000 : "bl2"
[ 1.757663] 0x000000080000-0x0000001c0000 : "fip"
[ 1.764123] 0x0000001c0000-0x0000002c0000 : "factory"
[ 1.770815] 0x000000300000-0x000008000000 : "ubi"
[ 1.804359] random: fast init done
[ 1.912593] libphy: Fixed MDIO Bus: probed
[ 1.940613] libphy: mdio: probed
[ 1.945180] mtk_soc_eth 1b100000.ethernet eth0: mediatek frame engine at 0xffffffc0113e0000, irq 35
[ 1.955915] i2c /dev entries driver
[ 1.960644] mtk-wdt 10212000.watchdog: Watchdog enabled (timeout=31 sec, nowayout=0)
[ 1.972040] NET: Registered protocol family 10
[ 1.977323] Segment Routing with IPv6
[ 1.981026] NET: Registered protocol family 17
[ 1.985522] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[ 1.998593] 8021q: 802.1Q VLAN Support v1.8
[ 2.003914] pstore: Using crash dump compression: deflate
[ 2.019010] mtk-pcie 1a143000.pcie: host bridge /pcie@1a143000 ranges:
[ 2.025594] mtk-pcie 1a143000.pcie: Parsing ranges property...
[ 2.031428] mtk-pcie 1a143000.pcie: MEM 0x0020000000..0x0027ffffff -> 0x0020000000
[ 2.055997] mtk-pcie 1a143000.pcie: PCI host bridge to bus 0000:00
[ 2.062182] pci_bus 0000:00: root bus resource [bus 00-ff]
[ 2.067679] pci_bus 0000:00: root bus resource [mem 0x20000000-0x27ffffff]
[ 2.074545] pci_bus 0000:00: scanning bus
[ 2.078603] pci 0000:00:00.0: [14c3:3258] type 01 class 0x060400
[ 2.084629] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x1ffffffff 64bit pref]
[ 2.093537] pci_bus 0000:00: fixups for bus
[ 2.097737] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 0
[ 2.104430] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[ 2.112441] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 1
[ 2.119275] pci_bus 0000:01: scanning bus
[ 2.123496] pci 0000:01:00.0: [14c3:7915] type 00 class 0x000280
[ 2.129687] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[ 2.137011] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[ 2.144330] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[ 2.152293] pci 0000:01:00.0: supports D1 D2
[ 2.156559] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 2.163187] pci 0000:01:00.0: PME# disabled
[ 2.167672] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[ 2.206448] pci_bus 0000:01: fixups for bus
[ 2.210634] pci_bus 0000:01: bus scan returning with max=01
[ 2.216219] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[ 2.222831] pci_bus 0000:00: bus scan returning with max=01
[ 2.228418] pci 0000:00:00.0: BAR 0: no space for [mem size 0x200000000 64bit pref]
[ 2.236069] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x200000000 64bit pref]
[ 2.244064] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x201fffff]
[ 2.250852] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit pref]
[ 2.258675] pci 0000:01:00.0: BAR 2: assigned [mem 0x20100000-0x20103fff 64bit pref]
[ 2.266499] pci 0000:01:00.0: BAR 4: assigned [mem 0x20104000-0x20104fff 64bit pref]
[ 2.274316] pci 0000:00:00.0: PCI bridge to [bus 01]
[ 2.279281] pci 0000:00:00.0: bridge window [mem 0x20000000-0x201fffff]
[ 2.286163] pcieport 0000:00:00.0: of_irq_parse_pci: failed with rc=-22
[ 2.292768] pcieport 0000:00:00.0: assign IRQ: got 0
[ 2.297739] pcieport 0000:00:00.0: enabling device (0000 -> 0002)
[ 2.303842] pcieport 0000:00:00.0: enabling bus mastering
[ 2.309768] mtk-pcie 1a145000.pcie: host bridge /pcie@1a145000 ranges:
[ 2.316316] mtk-pcie 1a145000.pcie: Parsing ranges property...
[ 2.322149] mtk-pcie 1a145000.pcie: MEM 0x0028000000..0x002fffffff -> 0x0028000000
[ 2.430338] mtk-pcie 1a145000.pcie: Port1 link down
[ 2.435354] mtk-pcie 1a145000.pcie: PCI host bridge to bus 0001:00
[ 2.441530] pci_bus 0001:00: root bus resource [bus 00-ff]
[ 2.447021] pci_bus 0001:00: root bus resource [mem 0x28000000-0x2fffffff]
[ 2.453888] pci_bus 0001:00: scanning bus
[ 2.459055] pci_bus 0001:00: fixups for bus
[ 2.463230] pci_bus 0001:00: bus scan returning with max=00
[ 2.469141] mtk_hsdma 1b007000.dma-controller: Using 3 as missing dma-requests property
[ 2.477417] mtk_hsdma 1b007000.dma-controller: MediaTek HSDMA driver registered
[ 2.539160] libphy: dsa slave smi: probed
[ 2.544087] mt7530 mdio-bus:00 lan1 (uninitialized): PHY [dsa-0.0:00] driver [Generic PHY] (irq=POLL)
[ 2.554752] mt7530 mdio-bus:00 lan2 (uninitialized): PHY [dsa-0.0:01] driver [Generic PHY] (irq=POLL)
[ 2.565478] mt7530 mdio-bus:00 lan3 (uninitialized): PHY [dsa-0.0:02] driver [Generic PHY] (irq=POLL)
[ 2.576111] mt7530 mdio-bus:00 lan4 (uninitialized): PHY [dsa-0.0:03] driver [Generic PHY] (irq=POLL)
[ 2.586930] mt7530 mdio-bus:00 wan (uninitialized): PHY [dsa-0.0:04] driver [Generic PHY] (irq=POLL)
[ 2.597303] mt7530 mdio-bus:00: configuring for fixed/2500base-x link mode
[ 2.604875] mt7530 mdio-bus:00: Link is Up - 2.5Gbps/Full - flow control rx/tx
[ 2.605533] DSA: tree 0 setup
[ 2.616021] xhci-mtk 1a0c0000.usb: xHCI Host Controller
[ 2.621267] xhci-mtk 1a0c0000.usb: new USB bus registered, assigned bus number 1
[ 2.630337] xhci-mtk 1a0c0000.usb: hcc params 0x01403198 hci version 0x96 quirks 0x0000000000210010
[ 2.639431] xhci-mtk 1a0c0000.usb: irq 31, io mem 0x1a0c0000
[ 2.645556] hub 1-0:1.0: USB hub found
[ 2.649328] hub 1-0:1.0: 2 ports detected
[ 2.653593] xhci-mtk 1a0c0000.usb: xHCI Host Controller
[ 2.658853] xhci-mtk 1a0c0000.usb: new USB bus registered, assigned bus number 2
[ 2.666262] xhci-mtk 1a0c0000.usb: Host supports USB 3.0 SuperSpeed
[ 2.672570] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[ 2.680975] hub 2-0:1.0: USB hub found
[ 2.684744] hub 2-0:1.0: 1 port detected
[ 2.689759] UBI: auto-attach mtd3
[ 2.693088] ubi0: attaching mtd3
[ 3.081034] ubi0: scanning is finished
[ 3.089098] ubi0: attached mtd3 (name "ubi", size 125 MiB)
[ 3.094586] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[ 3.101465] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[ 3.108249] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[ 3.115203] ubi0: good PEBs: 1000, bad PEBs: 0, corrupted PEBs: 0
[ 3.121287] ubi0: user volume: 6, internal volumes: 1, max. volumes count: 128
[ 3.128502] ubi0: max/mean erase counter: 8/3, WL threshold: 4096, image sequence number: 537560588
[ 3.137541] ubi0: available PEBs: 0, total reserved PEBs: 1000, PEBs reserved for bad PEB handling: 20
[ 3.146906] ubi0: background thread "ubi_bgt0d" started, PID 804
[ 3.153808] FIT: Default configuration: "config-1" (OpenWrt linksys_e8450-ubi)
[ 3.161058] FIT: kernel sub-image 0x00001000..0x0050b6b9 "kernel-1" (ARM64 OpenWrt Linux-5.10.60)
[ 3.170891] FIT: flat_dt sub-image 0x0050c000..0x00513328 "fdt-1" (ARM64 OpenWrt linksys_e8450-ubi device tree blob)
[ 3.182285] FIT: filesystem sub-image 0x00514000..0x00ab3fff "rootfs-1" (ARM64 OpenWrt linksys_e8450-ubi rootfs)
[ 3.193063] FIT: selecting configured loadable "rootfs-1" to be root filesystem
[ 3.200367] ubiblock0_4: p1(rootfs-1)
[ 3.200661] block ubiblock0_4: created from ubi0:4(fit)
[ 3.210549] Freeing unused kernel memory: 448K
[ 3.255138] Run /init as init process
[ 3.258792] with arguments:
[ 3.261749] /init
[ 3.264011] with environment:
[ 3.267152] HOME=/
[ 3.269501] TERM=linux
[ 3.430424] init: Console is alive
[ 3.433919] init: - watchdog -
[ 3.440409] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[ 3.450294] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 3.467681] init: - preinit -
[ 3.513386] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
[ 3.521994] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
[ 3.530945] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 3.537925] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
[ 3.545034] 8021q: adding VLAN 0 to HW filter on device lan1
[ 3.557794] random: procd: uninitialized urandom read (4 bytes read)
[ 4.608550] mt7530 mdio-bus:00 lan1: Link is Up - 100Mbps/Full - flow control rx/tx
[ 4.616285] IPv6: ADDRCONF(NETDEV_CHANGE): lan1: link becomes ready
[ 7.600054] mt7530 mdio-bus:00 lan1: Link is Down
[ 7.608865] procd: - early -
[ 7.611784] procd: - watchdog -
[ 8.135206] procd: - watchdog -
[ 8.138528] procd: - ubus -
[ 8.143786] random: ubusd: uninitialized urandom read (4 bytes read)
[ 8.191047] random: ubusd: uninitialized urandom read (4 bytes read)
[ 8.197573] random: ubusd: uninitialized urandom read (4 bytes read)
[ 8.204635] procd: - init -
[ 8.308739] urngd: v1.0.2 started.
[ 8.339857] random: crng init done
[ 8.343286] random: 6 urandom warning(s) missed due to ratelimiting
[ 8.351244] kmodloader: loading kernel modules from /etc/modules.d/*
[ 8.365022] Loading modules backported from Linux version v5.10.42-0-g65859eca4dff
[ 8.372629] Backport generated by backports.git v5.10.42-1-0-gbee5c545
[ 8.392099] xt_time: kernel timezone is -0000
[ 8.433223] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 8.452977] PPP generic driver version 2.4.2
[ 8.459673] NET: Registered protocol family 24
[ 8.465480] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
[ 8.465480]
[ 8.487205] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 8.498132] mt7622-wmac 18000000.wmac: N9 Firmware Version: 2.0, Build Time: 20200131180931
[ 13.758816] mtk_soc_eth 1b100000.ethernet eth0: Link is Down
[ 13.772610] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
[ 13.781080] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
[ 13.783538] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
[ 13.797892] 8021q: adding VLAN 0 to HW filter on device lan1
[ 13.805991] br-lan: port 1(lan1) entered blocking state
[ 13.811222] br-lan: port 1(lan1) entered disabled state
[ 13.818851] device lan1 entered promiscuous mode
[ 13.823490] device eth0 entered promiscuous mode
[ 13.835387] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 13.848887] mt7530 mdio-bus:00 lan2: configuring for phy/gmii link mode
[ 13.857754] 8021q: adding VLAN 0 to HW filter on device lan2
[ 13.866306] br-lan: port 2(lan2) entered blocking state
[ 13.871539] br-lan: port 2(lan2) entered disabled state
[ 13.879869] device lan2 entered promiscuous mode
[ 13.891545] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
[ 13.900531] 8021q: adding VLAN 0 to HW filter on device lan3
[ 13.909415] br-lan: port 3(lan3) entered blocking state
[ 13.914645] br-lan: port 3(lan3) entered disabled state
[ 13.921403] device lan3 entered promiscuous mode
[ 13.931881] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
[ 13.939395] 8021q: adding VLAN 0 to HW filter on device lan4
[ 13.948029] br-lan: port 4(lan4) entered blocking state
[ 13.953281] br-lan: port 4(lan4) entered disabled state
[ 13.960555] device lan4 entered promiscuous mode
[ 13.973088] mt7530 mdio-bus:00 wan: configuring for phy/gmii link mode
[ 13.980371] 8021q: adding VLAN 0 to HW filter on device wan
[ 13.992074] mt7530 mdio-bus:00 wan: Link is Up - 1Gbps/Full - flow control off
[ 13.999423] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
[ 17.968490] mt7530 mdio-bus:00 lan1: Link is Up - 100Mbps/Full - flow control rx/tx
[ 17.976194] br-lan: port 1(lan1) entered blocking state
[ 17.981413] br-lan: port 1(lan1) entered forwarding state
[ 17.987372] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
root@OpenWrt:~#
mtd2:
00000000 22 76 02 00 e8 9f 80 f0 6c 17 00 00 00 00 00 00 |"v......l.......|
00000010 81 55 53 00 00 00 00 00 00 00 00 00 00 00 00 00 |.US.............|
00000020 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00000030 00 00 00 00 44 00 00 20 00 00 00 00 10 00 20 00 |....D.. ...... .|
00000040 00 00 44 00 04 00 00 00 00 00 00 00 00 00 00 00 |..D.............|
00000050 20 00 00 bb 40 b8 c3 c3 26 c1 c0 c0 41 c4 26 c2 | ...@...&...A.&.|
00000060 c1 c1 41 c4 26 c2 c2 c2 c0 c5 26 c1 c0 c0 00 00 |..A.&.....&.....|
00000070 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
000000b0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 c6 c6 |................|
000000c0 c3 c3 c2 c1 00 c3 00 c3 00 83 83 83 85 c1 c1 82 |................|
000000d0 85 85 85 82 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000000e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000000f0 86 00 2e 00 9e 00 8b 88 88 00 00 00 00 00 00 00 |................|
00000100 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00000120 0b 00 00 09 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00000130 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00000150 00 00 00 00 00 00 00 00 00 00 00 00 00 00 77 07 |..............w.|
00000160 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00000400 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff |................|
*
00005000 15 79 00 00 e8 9f 80 f0 6c 18 00 0c 43 26 59 97 |.y......l...C&Y.|
00005010 15 79 c3 14 00 80 02 00 15 79 c3 14 ec a0 01 00 |.y.......y......|
00005020 16 79 c3 14 00 80 02 00 16 79 c3 14 00 00 01 00 |.y.......y......|
00005030 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005050 01 00 8e 00 00 00 00 00 00 00 00 80 55 53 00 00 |............US..|
00005060 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00005070 30 1c 00 00 00 00 07 af 87 00 00 00 00 00 00 00 |0...............|
00005080 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
000050a0 00 00 00 00 00 00 00 00 8c 3c da c3 00 77 5e 63 |.........<...w^c|
000050b0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005190 24 52 06 00 28 00 00 15 00 00 00 00 00 00 00 00 |$R..(...........|
000051a0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
000051d0 01 00 fe fd fd fd f8 f9 01 00 fe fd fd fd f8 f9 |................|
000051e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005230 00 00 00 00 00 00 00 00 00 00 e4 e4 ee ee fa fa |................|
00005240 06 06 16 16 df df e7 e7 f3 f3 fb fb 03 03 0b 0b |................|
00005250 25 25 c6 c6 c2 c2 c2 00 00 c2 00 c2 00 00 81 82 |%%..............|
00005260 85 85 c2 c2 00 81 81 82 85 85 00 c2 c2 00 00 81 |................|
00005270 82 85 85 87 87 c2 c2 00 81 81 82 85 85 87 87 c2 |................|
00005280 c2 00 00 81 82 85 85 87 87 c2 c2 00 00 81 82 85 |................|
00005290 85 87 87 c2 c2 00 00 81 82 85 85 87 87 c4 c2 c2 |................|
000052a0 c1 00 c3 00 c3 c3 c1 00 81 83 83 c3 c3 c3 c1 00 |................|
000052b0 81 83 83 00 c2 c2 c2 c0 81 82 84 84 00 00 00 c3 |................|
000052c0 c3 c3 c1 00 81 83 83 86 86 c3 c3 c3 c1 00 81 83 |................|
000052d0 83 86 86 c2 c2 c2 c0 81 82 84 84 86 86 c3 c3 c3 |................|
000052e0 c1 00 81 83 83 86 86 c3 c3 c3 c1 00 81 83 83 86 |................|
000052f0 86 c3 c3 c3 c1 00 81 83 83 86 86 02 28 00 02 28 |............(..(|
00005300 00 02 28 00 02 28 00 00 00 00 00 00 00 00 00 00 |..(..(..........|
00005310 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00005320 00 00 00 00 00 00 00 00 00 00 00 00 00 4c 58 65 |.............LXe|
00005330 71 7d 00 4d 59 65 72 7e 00 4c 58 64 70 7c 00 4c |q}.MYer~.LXdp|.L|
00005340 58 64 70 7c 88 88 88 88 03 03 03 26 26 26 26 26 |Xdp|.......&&&&&|
00005350 26 26 26 00 03 03 03 26 26 26 26 26 26 26 26 00 |&&&....&&&&&&&&.|
00005360 03 03 03 26 26 26 26 26 26 26 26 00 03 03 03 26 |...&&&&&&&&....&|
00005370 26 26 26 26 26 26 26 00 00 00 00 00 00 00 00 00 |&&&&&&&.........|
00005380 00 00 00 00 00 00 bb bb bb bb bb bb 00 00 00 00 |................|
00005390 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000053a0 00 00 00 00 00 00 00 00 00 00 aa aa aa aa aa aa |................|
000053b0 00 00 00 00 00 00 dd dd dd ee ee ee 00 00 00 00 |................|
000053c0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000053d0 00 00 00 00 00 00 00 00 00 00 aa aa aa aa aa aa |................|
000053e0 00 00 00 00 00 00 bb bb bb cc cc cc 00 00 00 00 |................|
000053f0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00005400 00 00 00 00 00 00 00 00 00 00 aa aa aa aa aa aa |................|
00005410 00 00 00 00 00 00 dd dd dd dd dd dd 00 00 00 00 |................|
00005420 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00005430 00 00 00 00 00 00 00 00 00 00 aa aa aa aa aa aa |................|
00005440 08 42 51 51 63 74 08 42 51 51 64 74 08 42 51 51 |.BQQct.BQQdt.BQQ|
00005450 64 74 08 42 51 51 64 74 08 42 51 51 64 74 08 42 |dt.BQQdt.BQQdt.B|
00005460 51 51 64 74 08 43 54 54 66 74 08 42 56 56 68 74 |QQdt.CTTft.BVVht|
00005470 08 42 51 51 63 72 08 42 51 51 63 74 08 42 50 50 |.BQQcr.BQQct.BPP|
00005480 63 74 08 42 51 51 63 75 08 42 51 51 63 74 08 42 |ct.BQQcu.BQQct.B|
00005490 51 51 63 74 08 42 53 53 65 76 08 42 55 55 66 79 |QQct.BSSev.BUUfy|
000054a0 08 42 51 51 64 74 08 42 51 51 64 75 08 42 51 51 |.BQQdt.BQQdu.BQQ|
000054b0 64 75 08 42 51 51 65 75 08 43 51 51 64 75 08 44 |du.BQQeu.CQQdu.D|
000054c0 52 52 65 76 08 44 54 54 67 78 08 43 56 56 68 7a |RRev.DTTgx.CVVhz|
000054d0 08 42 51 51 63 74 08 43 52 52 64 76 08 42 51 51 |.BQQct.CRRdv.BQQ|
000054e0 64 74 08 42 51 51 64 74 08 44 53 53 66 77 08 44 |dt.BQQdt.DSSfw.D|
000054f0 53 53 66 77 08 44 55 55 68 79 08 43 57 57 69 7b |SSfw.DUUhy.CWWi{|
00005500 88 88 88 88 88 88 88 88 88 88 88 88 88 88 88 88 |................|
*
00005520 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
000057b0 00 00 00 00 00 00 00 00 00 00 00 00 00 26 25 02 |.............&%.|
000057c0 00 00 00 00 00 00 00 00 00 00 00 00 00 90 00 88 |................|
000057d0 00 88 00 90 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000057e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005800 00 00 ec a8 65 43 21 00 97 00 ec b9 75 43 22 00 |....eC!.....uC".|
00005810 97 00 ed ca 86 54 32 00 97 00 ca 97 65 33 22 00 |.....T2.....e3".|
00005820 87 00 0b 0b 0b 0c 0d 0f 0c 0c 00 00 00 00 00 03 |................|
00005830 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
000058c0 85 83 85 84 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000058d0 00 e8 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000058e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005900 43 c0 c3 c0 43 c1 43 c1 c0 cd 40 cc 40 cb 42 ca |C...C.C...@.@.B.|
00005910 3e cc 3e cc 3d cc 40 ca be cb be ca 3e cb c0 ca |>.>.=.@.....>...|
00005920 3e cc 3e cc 3e cc be ca c0 cd c0 cb 40 cb 42 ca |>.>.>.......@.B.|
00005930 be cb 3e cb 3e cb 3e cc 40 ce c0 ca 40 ca c0 c9 |..>.>.>.@...@...|
00005940 40 c9 40 c9 40 c9 40 c9 00 00 00 00 00 00 00 00 |@.@.@.@.........|
00005950 41 cd 41 cd 41 cd 41 cd 00 00 00 00 00 00 00 00 |A.A.A.A.........|
00005960 c0 cf c0 cf c0 cf c0 cf c0 cf c0 cf c0 cf c0 cf |................|
00005970 c0 ce c0 ce c0 ce c0 ce c0 ce c0 ce c0 ce c0 ce |................|
00005980 c0 d3 c0 d1 40 d1 c0 d0 c0 d1 c0 d1 c0 d1 40 d3 |....@.........@.|
00005990 40 d4 40 d1 c0 d0 40 d0 c0 d0 c0 d0 c0 d0 40 d0 |@.@...@.......@.|
000059a0 02 af 00 00 00 01 c0 00 b8 83 00 00 00 00 00 00 |................|
000059b0 49 81 e5 7c 99 a6 ab 49 18 18 18 18 18 18 18 18 |I..|...I........|
000059c0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005a00 00 4c 58 64 70 7b 00 4c 58 64 71 7c 00 4b 58 63 |.LXdp{.LXdq|.KXc|
00005a10 70 7a 00 4b 58 63 70 7a 00 00 00 00 08 48 48 5a |pz.KXcpz.....HHZ|
00005a20 69 7a 08 48 48 5a 69 7a 08 48 48 5a 69 7a 08 48 |iz.HHZiz.HHZiz.H|
00005a30 48 5a 69 7a 08 48 48 5a 69 7a 08 48 48 5a 69 7a |HZiz.HHZiz.HHZiz|
00005a40 08 48 48 5a 69 7a 08 48 48 5a 69 7a 08 48 48 5a |.HHZiz.HHZiz.HHZ|
00005a50 6c 75 08 48 48 5a 6c 75 08 48 48 5a 6c 75 08 48 |lu.HHZlu.HHZlu.H|
00005a60 48 5a 6c 75 08 48 48 5a 6c 75 08 48 48 5a 6c 75 |HZlu.HHZlu.HHZlu|
00005a70 08 48 48 5a 6c 75 08 48 48 5a 6c 75 08 47 47 5a |.HHZlu.HHZlu.GGZ|
00005a80 69 7a 08 49 49 59 6c 79 08 48 48 59 6b 79 08 48 |iz.IIYly.HHYky.H|
00005a90 48 5a 6c 78 08 49 49 58 69 78 08 49 49 58 69 78 |HZlx.IIXix.IIXix|
00005aa0 08 48 48 58 6b 78 08 4a 4a 5b 6d 79 08 46 46 58 |.HHXkx.JJ[my.FFX|
00005ab0 69 79 08 48 48 59 6b 79 08 48 48 59 6b 78 08 48 |iy.HHYky.HHYkx.H|
00005ac0 48 59 6c 78 08 49 49 58 68 78 08 49 49 58 68 78 |HYlx.IIXhx.IIXhx|
00005ad0 08 49 49 57 6b 78 08 4a 4a 5b 6c 79 00 00 00 00 |.IIWkx.JJ[ly....|
00005ae0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00005af0 00 00 00 00 00 00 00 00 00 00 00 00 00 01 ff fe |................|
00005b00 fd fb 00 ff ff fe fd fa 00 ff ff fe fd fa 00 ff |................|
00005b10 ff fe fd fa 00 ff ff fe fd fa 00 00 fe fc fb fa |................|
00005b20 00 ff fe fc fc f9 00 ff fe fc fb f8 00 ff fe fc |................|
00005b30 fa fa 00 ff fe fc fa fa 00 01 ff fd fa fa 00 fe |................|
00005b40 00 fd fc fc 00 fe ff fd fb fb 00 fe 00 fd fc fb |................|
00005b50 00 fe 00 fd fb fc 00 02 ff ff ff fe 00 fd ff fe |................|
00005b60 00 fe 00 fd ff ff 00 fe 00 fd ff fe 00 fe 00 fe |................|
00005b70 ff ff 00 fe 13 00 f0 d6 c6 af a0 86 13 00 f0 d6 |................|
00005b80 c6 af a0 86 13 00 f0 d8 c6 af 9e 86 13 00 f0 d8 |................|
00005b90 c6 af 9e 86 13 00 f3 d8 c8 b1 a0 87 13 00 f3 d8 |................|
00005ba0 c8 b1 a0 87 10 00 ed d5 c5 ac 9b 84 10 00 ed d5 |................|
00005bb0 c5 ac 9b 84 10 00 f0 d5 c5 ad 9e 86 10 00 f0 d5 |................|
00005bc0 c5 ad 9e 86 10 00 f0 d8 c5 af 9e 88 10 00 f0 d8 |................|
00005bd0 c5 af 9e 88 0e 00 ee d6 c3 ad 9d 83 0e 00 ee d6 |................|
00005be0 c3 ad 9d 83 10 00 f0 da c7 ac 9e 84 10 00 f0 da |................|
00005bf0 c7 ac 9e 84 0f 00 ef d5 c6 ae 9f 86 0f 00 ef d5 |................|
00005c00 c6 ae 9f 86 10 00 ef da c7 ae 9d 85 10 00 ef da |................|
00005c10 c7 ae 9d 85 0f 00 ef d5 c7 af 9f 86 0f 00 ef d5 |................|
00005c20 c7 af 9f 86 10 00 f0 d8 c6 ae 9d 87 10 00 f0 d8 |................|
00005c30 c6 ae 9d 87 12 00 ef d7 c8 af 9f 89 12 00 ef d7 |................|
00005c40 c8 af 9f 89 10 00 ef d7 c7 ae a0 88 10 00 ef d7 |................|
00005c50 c7 ae a0 88 10 00 f1 d9 ca b0 a1 89 10 00 f1 d9 |................|
00005c60 ca b0 a1 89 10 00 ee d8 c9 b0 a0 86 10 00 ee d8 |................|
00005c70 c9 b0 a0 86 ff 00 fe 00 04 06 02 01 ff 00 fe 00 |................|
00005c80 04 06 02 01 03 00 fc fa fa fb f5 f6 03 00 fc fa |................|
00005c90 fa fb f5 f6 02 00 fc f9 f9 fa f3 f3 02 00 fc f9 |................|
00005ca0 f9 fa f3 f3 01 00 fc f9 f8 f9 f2 f2 01 00 fc f9 |................|
00005cb0 f8 f9 f2 f2 00 00 fd fa fa fa f5 f4 00 00 fd fa |................|
00005cc0 fa fa f5 f4 00 00 fe fc fd fd f8 fa 00 00 fe fc |................|
00005cd0 fd fd f8 fa ff 00 fe fc fd fe f7 f9 ff 00 fe fc |................|
00005ce0 fd fe f7 f9 fe 00 fe fc ff fe f9 f7 fe 00 fe fc |................|
00005cf0 ff fe f9 f7 ff 00 ff 00 05 07 03 04 ff 00 ff 00 |................|
00005d00 05 07 03 04 01 00 fc fa fa fb f5 f6 01 00 fc fa |................|
00005d10 fa fb f5 f6 01 00 fd fb fb fc f7 f7 01 00 fd fb |................|
00005d20 fb fc f7 f7 00 00 fd fb fc fd f8 f9 00 00 fd fb |................|
00005d30 fc fd f8 f9 ff 00 fc fc fc fe f7 fa ff 00 fc fc |................|
00005d40 fc fe f7 fa 00 00 fd fd fe 00 fd fe 00 00 fd fd |................|
00005d50 fe 00 fd fe ff 00 fd fd fe 01 fc fb ff 00 fd fd |................|
00005d60 fe 01 fc fb ff 00 fd fe 00 01 fe 04 ff 00 fd fe |................|
00005d70 00 01 fe 04 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00005d80 de e8 f4 00 0c d9 e1 ed f5 01 09 11 00 00 00 00 |................|
00005d90 01 00 fc f9 f9 f8 f2 f3 01 00 fc f9 f9 f8 f2 f3 |................|
00005da0 02 00 fd fa fa f8 f2 f3 02 00 fd fa fa f8 f2 f3 |................|
00005db0 00 00 fd fc fc fc f7 f5 00 00 fd fc fc fc f7 f5 |................|
00005dc0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00005e00 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff |................|
*
0007fff0 ff ff ff ff e8 9f 80 f0 6c 16 e8 9f 80 f0 6c 15 |........l.....l.|
00080000 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff |................|
*
00100000```