Belkin RT3200/Linksys E8450 WiFi AX discussion

Pending this fix, should we be running any particular settings to help protect our devices?

1 Like

It may be best to start being satisfied with whatever release is running on our devices and stop flashing sysupgrades pending a fix like this. Most of us have a tendency to do that far more than necessary to keep up with critical bug fixes and security updates anyway,


Slightly off topic but do they even still sell this outside the US? I can't find a single retailer in the UK stocking either. Just chancers on Ebay looking to flog them for $150.

Just to follow up. I opened the second Belkin RT3200 that I had. It exhibited the same issue as the other one "failed to load BL2" in serial console. And the jtag recovery worked.

One thing that I didn't mention before. I used putty and a Prolific USB to serial TTL level interface. If I use COM3 115200 xon/xoff flow control, then the BL2 message comes up. And since it hasn't showed the "System halt!" message, the jtag recovery doesn't work as the first "halt" command shows it is in Aarch64 mode instead of Thumb mode.

If I change the putty connection to COM3 115200 none (for flow control) and power cycle the router after running openocd, then it comes up to the "System halt!" message in the serial console. Then jtag recovery works as expected.

Hope it helps anyone else trying this.


I have a friend who is stuck with the broken bootloader after trying to run updates. He gets no led and recovery button does nothing. Wiring up serial console gets:

F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 02D5 [000F]
Jump to BL
NOTICE:  BL2: v2.9(release):OpenWrt v2023-07-24-00ac6db3-2 (mt7622-snand-1ddr)
NOTICE:  BL2: Built : 21:45:35, Oct  9 2023
NOTICE:  WDT: Cold boot
NOTICE:  WDT: disabled
ERROR:   BL2: Failed to load image id 5 (-2)

We are going to try wavejumper00's walk though on the jtag recovery. Just letting everyone know this may be a widespread issue for Belkin. It would be nice to have the recovery button functional, or some protection against overwriting the bootloader. It would be nice to see if the bootloader failed to boot from the nand if it tried from usb.

They did, especially in the UK (amazon) - but it's probably slowly being phased out.

Again, Belkin specifically? I'm curious if Linksys somehow avoids this (or if those people just haven't spoken up yet). So far we have two mentioned as definitely Belkin. It's supposed to be the same hardware, but they're a little different.

If you or anyone else wants to post more details of the JTAG recovery process and what steps are tricky, it would be very appreciated. Wavejumper's guide is probably sufficient, but it still summarizes enough details that I feel somewhat apprehensive.

As for the recovery, sorry if this is silly, but I've never had a router with enough space/support for a recovery before and I had to ask: when merely upgrading OpenWRT, does normal sysupgrade from the running OS work or am I supposed to boot into the recovery and do a sysupgrade from there?

The Linksys E8450 is still sold on Amazon USA. They ship to international locations.

The seller Connected Home Store is Linksys USA Inc., directly from the vendor.

You only need a matching power supply. I would like to enter the needed information into the E8450 OpenWrt wiki article but my application for a wiki account is ignored.

I have three of the Belkin RT3200 devices, all converted to the OpenWRT UBI layout. I've run mine for an extended time with everything from low voltage, to standard supplies, and even via PoE extractors and not had a single failure of this nature or even any abnormal operation from the units at all for any reason other than my b0rking a configuration from time to time (and recovery did work then). Granted, we're still dealing with a small sample size, so a lot of this seems to still be guesswork.

Therefore, as far as guesses go, is it at all possible we may be dealing with a flash failure/improper write caused by performing a flash operation while the memory is running under voltage and/or CPU running at extremely low speed? Could this combined with the varying tolerances between chips present the possible cause of it all?


Actually, COMPAT_VERSION doesn't have to be bumped unless you also want to move caldata into UBI. The mtd layout isn't changed, and moving FIP into UBI shouldn't affect the compatibility of firmwares.

After checking it seems like they had it for £40 last year... ugh. Don't know why it's not being stocked anymore seems like a good little device.

Do you think the Netgear WAX206 would be a good alternative? I can get that for £75. It actually seems to have slightly better wlan hardware than the RT3200 but same CPU.

I just got a Linksys E8450 and planning to install OpenWRT on it. The recent reports of boot problems and cpu frequencies had me worried. Have I understood correctly that for now it is safest to install version 23.05.0 instead of the 23.05.2?

Where do you read that older 23.05 releases should be more safe or more stable than 23.05.2? Please quote the source.

I have and had multiple 23.05 snapshots, release candidates and all releases to date installed. All of them are stable on my E8450. This reply is sent via OpenWrt 23.05.2.


Sorry, I messed up with the version numbers. I saw the posts about not getting past boot appearing near when 23.05.2 was released and draw the inaccurate conclusion that that specific version would have caused it. But upon reading the posts again, the boot issue seems to happen even on older versions. Sources for the posts that talk about the boot issue: 3940, 3945, 3976, 3977, 3985, 3986, 3992, 3999, 4000, 4011.

To rephrase my original question: To avoid the booting issue, is it best to install latest stable release 23.05.2 and ensure that minimum frequency is set to 600 Mhz? (Currently my Linksys E8450 runs the stock firmware.)


I don’t see a relation of the reboot or boot issue with the current releases. The minimum frequency is set to 437.5 MHz as default on current OpenWrt code for our target. I raised the min_freq to 600 MHz in hope this may increase reboot stability since there is a past report of failing boot below and successful boot with 600 MHz clock speed set.

But: I don’t see a clear root cause of the reported boot or reboot problems. And no final solution either.


I have too little knowledge to make conclusions like this...yet, I have decided to keep two of my E8450s on 22.03 train. I may be completely unreasonable, but they have been working on this version for 1.5 years flawlessly. My rationale - this boot issues seem to have something to do with the CPU clock, CPU clock and governor were the things explicitly changed between 22.03 and 23.05 and there is suggestion here that MT7622 is not supposed to work below 1350 MHz. It also seems that all these boot problems came from 23.05.x devices, although this could come from the fact that possibly majority have already upgraded.

If 22.03 works for you and you don’t have Apple WiFi clients in your network you could stay for about half a year on 22.03 until it will be end of life with no security updates. I still don’t think that 22.03 is more stable than 23.05 in this issue. Reports of boot problems in this thread are older than the 23.05 branch.

Again, Belkin specifically?

I have 2 Linksys and flashed to the same version at the same time. The one friend that had 2 Belkins and no issue, and another has 3 Belkins (who this happened to), only one of them ended up broke. He did the same thing on all 3. Who really knows what happened.

I am looking at buying to share. Not that I think it will need to be used often. Also the routers are only $40 so if I didn't have the rest of the stuff this really wouldn't be worth it. I designed a 3d print that I am going to try for the jtag first before ordering that as $24 seems silly. But between my family and my friends we have about 10 of these routers and it probably is a good idea to have a way to fix them if they get borked on an upgrade.

1 Like

Is running the device always on performance governor the best approach to prevent dead boot issues?

that’s not yet known. I only know of one report that booting on 600 MHz is fine but on 437.5 MHz and below failed.