Belkin RT3200/Linksys E8450 WiFi AX discussion

800 Mbit/s with iperf3 on 80 MHz AX, iPhone as wifi station, WED disabled.

Try 80 MHz channel first when issues come up, this is what is officially supported. 160 MHz channel support is experimental on MT7915, it's out of specification for this wifi controller. If 160 MHz channels work: fine. If 160 MHz channels produce problems: this is expected, try 80 MHz channels again, if the problem persists.

1 Like

If you don't mind me asking - how are you using iperf3 on your iPhone. Id like to do the same.


Or try the HE network tools app with integrated iperf3 client.


Aside from the issue above, any other experiences on how 23.05.0 compares with 22.03.5? The latter has been working very well for me for some time, and so I'm a bit reluctant to switch over. Has anyone managed to upgrade and retain same config from 22.03.5 to 23.05.0 without complete reinstall? If so, what did you do and do you see any issues?

Roger, I'll try with 80Mhz and report back.

I just tried an attended sysupgrade from 22.03.5 to 23.05.0, which resulted in 5GHz wifi not working. I guess its due to a driver not being installed. I'm still searching what I need to install.


Fixed it. Installed opgk update ; opkg kmod-mt7915-firmware and replaced the "path" setting in /etc/config/wireless by phy wl0 and phy wl1.

I obviously have not much experience since I installed 23.05.0 just a couple of minutes ago, but at first glance the box is running at leasts as much as I need it for being able to fiddle around with it.


Upgraded RT3200 from 22.03.5 to 23.05.0 using Luci upgrade through browser and everything worked with existing config. My network setup includes 2 AX networks (AP mode, 80MHz, ch36, 20dBm - 100mW, disabled IPv6, SAE-mixed, 2 fixed MAC addresses, beamforming, and BSS coloring). Software and hardware offload as well as packet steering are on.

I maintain a minimal setup to ensure stability. After the upgrade, I re-flashed 23.05.0, and it worked as expected. Tested with Android devices, iPad, and another OpenWRT router.

Just had exactly same situation - after using auc to upgrade from 22.03.05 to 23.05.0 over web - I had no 5GHz WiFi. Had to install kmod-mt7915-firmware and reboot. After reboot, all seem as it was previously.

Thanks. I managed to upgrade from 22.03.5 to 23.05 0 using LuCi attended sysupgrade based on the posts here and this helpful post here:

I keep getting: "No upgrade available

The device runs the latest firmware version 22.03.5 - r20134-5f15225c1e"

When using LuCi Attended Sysupgrade with the server.

Have you done something special for the upgrade to become available?

Edit: it appears I had to enable advanced mode!

1 Like

I would not advice using attended sysupgrade for a major version upgrades. As in your case, some packages were missing. You also don't know, what other important packages might be missing.
Better upgrade the normal way with sysupgrade, check keep data and then just install the packages you need to get your functionality back. All their configs are kept.

I have been running 23.05.0-rc4 for a while and just upgraded to 23.05.0. No WED, no 160 MHz channel, here


@patrakov after the upgrade, compared to the manifest, I now have:


Why are these not in:

which lists:

kmod-mt76-connac - 5.15.134+2023-08-14-b14c2351-1
kmod-mt76-core - 5.15.134+2023-08-14-b14c2351-1
kmod-mt7615-common - 5.15.134+2023-08-14-b14c2351-1
kmod-mt7615e - 5.15.134+2023-08-14-b14c2351-1
kmod-mt7622-firmware - 5.15.134+2023-08-14-b14c2351-1

I'm a bit confused by this. Is another package in the manifest providing the firmware otherwise provided by:


On my E8450, I only have these two firmwares:

kmod-mt7622-firmware - 5.15.134+2023-08-14-b14c2351-1
kmod-mt7915-firmware - 5.15.134+2023-08-14-b14c2351-1

Therefore, kmod-mt7615-firmware is redundant, while kmod-mt7915-firmware is not.


Understood. But why isn't kmod-mt7915-firmware in the manifest file?

Because kmod-mt7915-firmware is needed specifically for Linksys E8450, not for all devices covered by the mt7622 subtarget.


I did almost the same, but used firmware selector and added my additional packages there (ddns, speedtestpp, nano, and others), then I updated using sysupgrade.

Everything's working fine on 23.05.0.

I do have a question that's probably answered somewhere: is there a way to edit the model name to reflect Belkin RT3200 instead of E8450? I know it's cosmetic, but at least it should appear as Linksys E8450/Belkin RT3200 (UBI) in the overview page.


Hack the value in /tmp/sysinfo/model? It will be overwritten on reboot, but it should change what you see on the luci status page.


Could be made permanent via local startup commands.


Is there a different firmware selector? This one doesn't allow adding custom packages:

Of course you can:


1 Like