Belkin RT3200/Linksys E8450 WiFi AX discussion

This worked great!

I added:

echo "Belkin RT3200 (UBI)" > /tmp/sysinfo/model

in my Local Startup (/etc/rc.local) file!

By the way, On 22.03.x I didn't need to change the governor, but now, I had to set schedutil also on my /etc/rc.local file because on reboot, sometimes the router won't boot up. Any thoughts???


This would be a bug. I have read for at least about seven E8450/RT3200 working fine with OpenWrt 23.05. Mine included. Booting should also not depend on the CPU scaling governor.

What is your boot problem about?

Don't know, I just rebooted the router from the System menu and the router won't come up, I had to power it off and turn it on again using the switch on the back.

As soon as I changed the governor, it rebooted properly. The same happened to me on 22.03 when I got this router and followed the Wiki by manually putting ondemand as the governor. When changed to schedutil, it rebooted fine. Eventually I removed the governor line and still worked fine. But now on 23.05 the problem appeared again.

Depending on your location: did you wait for the DFS radar scanning time to complete? This needs about one minute until the 5 GHz SSIDs are activated.

If you have found a bug please provide debug information from logs what is failing. I don’t see a relation from the CPU scaling governor to boot problems for now.


My RT3200 is running fine on 23.05.0


No, my 5GHz radio is on Channel 36. And the point is that is not that wifi takes long to appear. It's that when I reboot the router manually (via reboot on the System > Reboot or a scheduled task) even the power on led doesn't turn on. Heck, I might think that the router actually freezes before rebooting because all I have to do is to use the power switch to turn it off, and turn it on again.

It's like the reboot command, turns off the device somehow.

Using shedutil as the governor, makes the issue disappear on my RT3200.

I read somewhere that setting a min CPU frequency also helped, but I didn't use that at all.

How can I find a log that explains that behavior???


Yeah, rock solid. zero problems running as a dumb AP with multiple SSIDs, VLANs, and lots of clients.

Firmware Version OpenWrt 23.05-SNAPSHOT r23282+1-57e7188e63 / LuCI openwrt-23.05 branch git-23.189.73029-ac423e9
Kernel Version 5.15.120
Local Time 2023-10-17 09:28:45
**Uptime 91d 22h 25m 32s**
Load Average 0.12, 0.05, 0.01

hi everybody i can't flash the rt3200 a message appair

"the password has ASCII"...

i has put admin to password

what is the message ? thanks

Never heard about that message in OpenWrt.

Are you already running OpenWrt in the router?
Or are you still with the OEM firmware?

If you are installing from the OEM, note that you need the special UBI installer that modifies the bootloader.

1 Like

Yes this message in Belkin OEM

I has also flashed thé router but me toi

First message,

I will retest today with other Pc or mac

Thanks for help

That's incredibly curious. I have a very wide selection of devices connected to my WiFi (in total about 120-130 devices), none of them had any issues with WPA2/3 mixed mode. And they're a wide range, going from almost "retro" devices (Nintendo Wii U, 3DS), a few generations of smartphones and tablets (perks of being a mobile engineer), a bunch of smarthome devices, the list goes on.

My only problem so far has been that I'm using 3 of these bad boys as APs in relative proximity, and some Apple devices do not like roaming, even when forced. I often end up using the office AP on the balcony, because my iPhone won't reconnect to the much closer and clearer signal living room AP. But even that seems to be fixed now.


Good to hear WPA2/WPA3 mixed mode has been stable for you - what OpenWrt version(s) is it working well for you with?

Stability experience aside, WPA2/WPA3 mixed mode defeats much of WPA3's advantage by allowing a client attacker to force a WPA2 downgrade and exploit WPA2 brute force attack vulnerabilities anyway.

Beyond the danger its availability may promote a false sense of security with less complex passwords, I don't see anything particularly wrong with it, but it doesn't seem to offer much for home APs. I suppose if I were running a public open SSID on my home AP (yikes!) or didn't enable "isolate clients" on a WPA2 (Force AES) secured SSID it might offer some inter-client snooping protection to clients choosing WPA3?

hello, can somebody tell me if i can connect with mesh a Belkin RT3200 with a Xiaomi AX6S (RB03) ?

belkin is running openwrt 23.05 stable
Xiami is running lastest stock firmware.

or, i want to kkow is i can flash Belkin RT3200 with the xiaomi ax6s firmware.


The RT3200 supports EasyMesh with the vendor stock Firmware. IDK if the Xiaomi supports it.

EasyMesh is an open standard supported by many vendors, for example, TP-Link supports it now.

On the other hand, now that you have the RT3200 with OpenWRT, you can flash the Xiaomi AX6S with OpenWRT, too. It's officially supported and then you can use mesh as per the wiki:


Thanks, i dont want flash xiaomi with openwrt cuz i use the xiaomi app for many things when i am out of home. So, i will like to keep xiaomi on stock, and maybe do a mesh with the belkin running openwrt with a plugin or something like this, or i dont know if i can flash xiomi firmware on belkin, i saw that are practically "the same hardware".

I speak spanish, if we can talk in private. Many thanks for your answer.

Xiaomi has not EasyMesh.

I have had stable mixed mode use since snapshots in Jan-Feb 2022, then 22.03 and now 23.05. No iPhones in the mix, but android, windows, MacOS, rpi, various linux laptops all seem solid. Couldn't get a 12-year-old HP printer to work wirelessly with it, but I suspect bigger issues than mixed mode for that ancient thing (we just pulled a cable rather than spend time figuring out what was wrong).

1 Like

I've been on SNAPSHOT since the RT3200 has been supported, so that :smiley: and mainly 23.05's snapshot, with weekly/biweekly updates.

You're out of luck, then.

There's no way a device with OpenWRT would communicate with a proprietary technology Xiaomi has. You need to flash the Xiaomi router with OpenWRT to make it work. You can remotely control a router with OpenWRT with DDNS or a VPN and do many things like with the Xiaomi app.

EasyMesh is an open standard and even OpenWRT doesn't support it yet. I hope it's eventually supported.

Technically, you could build a custom OpenWrt binary with the prplMesh feed added, as well as adding the appropriate packages - however it is a reference implementation and there's no guarantee that it is compatible with whatever modifications Xiaomi might've made in their variant of EasyMesh.

Yeah, I've read about it but I don't think that's ready for use yet. Even if I manage to add the packages to my build environment, I don't think there are UCI or Luci apps to manage the mesh system.

It would be amazing if more progress is made because it looks promising.

I was surprised when I set up an RT3200 with vendor FW and then I saw a tp-link repeater with also EasyMesh support. So the insustry effort is there. Now OpenWRT needs to catch up.


EDIT: I don't think Xiaomi supports EasyMesh at all. Maybe their own proprietary solution.