Belkin RT3200/Linksys E8450 WiFi AX discussion

I tried but it gives the same problem :smiling_face_with_tear:

On 5 GHz try using 80 MHz wide or less, and select ac, not ax. If you are using 160 MHz width, that could be a problem. If you are using ax that could be a problem. My RT3200 5GHz is pretty stable at distance on 802.11ac 80 MHz width. You might also try staying off the DFS channels (so use 36 or 149 for 80MHz wide 802.11ac 5GHz).

2.4 GHz would not be my go to band for a stable low latency WiFi connection....


I would love to see those files! I am currently having a crash when using vlan filtering and I've been searching high and low to find out why.

1 Like

Ah dash - only hours before you posted I deleted them in WSL 2 in Windows 11. If you know a way to recover those deleted files, I will try that.

The way I was able to put the router into this crash was to set up a VLAN based on wan port with ID 2 wan.2 and then make wan.2 a member of br-lan. And then enable bridge filtering in LuCi and set VLAN ID to 2 and set all then lan ports to untagged and wan.2 to tagged, and not set any primary VLAN ID. Like this, but also with the VLAN member lan.2 with ID 2:

If I am remembering correctly, I think then on 'service network restart' the router crashed and those files got generated.


Actually I think it might have backed them up to my OneDrive. I just identified these:

@daniel I rebuild 1 time per month a new image for e8450 and i noticed since 4.1.2023 this change in the .config. Was it intended?


In "menuconfig" the item "kernel" is empty

This should be realted:

The latest mt76 commit seems to have fixed the sudden drop in TX speeds on AX mode! :+1:

Many thanks to all the contributors who have been working on improving this devices :smiley:

On the recent BW160 and BW80+80 capabilities removal in mt7915:

  • Is it a key contributor to the performance improvement?
  • Is it a temporary solution, or is it likely to become permanent?

Is the drop in speed due to the number of barriers between the transmitter and the receiver or is this something else?

In my case it seems to be due to the numbers of barriers. M1 Mac client, 7m from the router and a single wall in between. When the RSSI gets roughly below -65dBm, TX HE-MCS suddenly drops to 0. RX seems to be largely unaffected.

1 Like

I can say that the bug is still present on my Redmi RX6000 (not RT3200), building the latest from master:

Behind multiple barriers gives me iperf3 speeds >300 Mbit/sec in upload mode.
Channel = 100
Width = 160 MHz

If I switch to channel =149 with 80 MHz width, the identical test from the same location runs 10-12 Mbit/sec.

Very nice it seems to be fixed. Tested at the same spot as earlier where I got <20 Mbits ( 802.11ax worse than 802.11ac with mt76 driver? - #223 by Anteus )


[ ID] Interval           Transfer     Bitrate         Retr  Cwnd          RTT
[  7]   0.00-1.00   sec  74.1 MBytes   621 Mbits/sec  2972744   2.20 MBytes   12ms
[  7]   1.00-2.00   sec  69.8 MBytes   585 Mbits/sec  2054712   1.64 MBytes   22ms
[  7]   2.00-3.01   sec  69.4 MBytes   580 Mbits/sec    0   1.71 MBytes   21ms
[  7]   3.01-4.00   sec  68.2 MBytes   574 Mbits/sec  1505920   1.77 MBytes   20ms
[  7]   4.00-5.00   sec  65.3 MBytes   548 Mbits/sec  1624656   1.82 MBytes   14ms
[  7]   5.00-6.00   sec  55.9 MBytes   469 Mbits/sec  1637688   1.94 MBytes   46ms
[  7]   6.00-7.00   sec  59.8 MBytes   502 Mbits/sec    0   1.98 MBytes   33ms
[  7]   7.00-8.00   sec  68.6 MBytes   575 Mbits/sec    0   2.03 MBytes   31ms
[  7]   8.00-9.00   sec  70.0 MBytes   587 Mbits/sec    0   2.08 MBytes   27ms
[  7]   9.00-10.00  sec  63.4 MBytes   531 Mbits/sec    0   2.12 MBytes   37ms
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  7]   0.00-10.00  sec   664 MBytes   557 Mbits/sec  9795720             sender
[  7]   0.00-10.02  sec   662 MBytes   555 Mbits/sec                  receiver

My results on channel 36, htmode = HE80, across two walls. Before, upload speed was ~ 10Mb/s.

Wifi status

RX: 432.3 MBit/s, HE-MCS 4, 80MHz, HE-NSS 2, HE-GI 0, HE-DCM 0
TX: 816.7 MBit/s, HE-MCS 8, 80MHz, HE-NSS 2, HE-GI 1, HE-DCM 0


[ ID] Interval           Transfer     Bitrate
[  7]   0.00-5.00   sec   224 MBytes   376 Mbits/sec                  sender
[  7]   0.00-5.01   sec   223 MBytes   373 Mbits/sec                  receiver


[ ID] Interval           Transfer     Bitrate         Retr
[  7]   0.00-5.01   sec   391 MBytes   655 Mbits/sec    0             sender
[  7]   0.00-5.00   sec   387 MBytes   650 Mbits/sec                  receiver

Hi there! Are there any instructions on how to perform this update to the mt76 driver? I'm a bit lost here.


Download and install the latest OpenWRT snapshot

It seems that the "channel analysis" shows "no data" on the latest master snapshot - r21968-acd8e94d20. Is it an issue only on my router or you have that as well?

Same here. You can go to Wireless overview and disable your wireless networks then it should work.

Your crash is a little different than the one I'm having, but I am starting to see a common theme here.

I have four RT3200's, configured with VLAN's, and they crash about once or twice a day in direct correlation with how many users hook to them simultaneously.

I have four other RT3200's, configured almost identically but without VLAN's, and they have been pretty stable running for over a month now.

It seems that using VLANs with the Belkin RT3200 is causing kernel dumps, and it happens when interfaces enter and leave promiscuous mode. I have used them by myself on weekends, roaming between them, without any crashes. So it is possible this could be a threading race condition and requires simultaneous connections/roaming to reproduce the crash.

Here's the dump I just had:

2023-02-03 10:46:45|Kernel.Info|WIFI-Dev kernel: [ 1095.244841] br-vlan11: port 2(wlan1.4105) entered disabled state
2023-02-03 10:46:45|Daemon.Error|WIFI-Dev hostapd: VLAN: br_delif: Failure determining interface index for 'wlan1.4105'
2023-02-03 10:46:45|Kernel.Info|WIFI-Dev kernel: [ 1095.335406] device br-lan.11 left promiscuous mode
2023-02-03 10:46:45|Kernel.Info|WIFI-Dev kernel: [ 1095.335542] br-vlan11: port 1(br-lan.11) entered disabled state
2023-02-03 10:46:46|Daemon.Notice|WIFI-Dev netifd: bridge 'br-vlan11' link is down
2023-02-03 10:46:46|Daemon.Notice|WIFI-Dev netifd: VLAN 'br-lan.11' link is down
2023-02-03 10:46:46|Feb 3 10:46:46 WIFI-Dev kernel: [ 1095.389694] Unable to handle kernel paging request at virtual address 00689e8e03f8ea2f

I wonder what would happen if I set a configuration in /etc/config/network for all .1q devices to be in promiscuous mode...? Would it stop them from changing to and from promiscuous mode, potentially solving the crash?


This is not my area of expertise so I hope one of the others can comment. In my case, I gave up on VLANs because I managed to lock myself out of my own outdoor router in playing with them and interfaces, etc, maddeningly requiring climbing a ladder because OpenWrt does not yet have a buttonless failsafe trigger. I don't strictly need VLANs so I gave up.

Well I am using VLANS with no problem at all.

I am not using them too extensively, just for isolating guess lan and iot devices, not using them too much as there are not many devices, but in my test it worked perfectly.

I use 3 wireless access points and 2 VLANS among the main router and another wireless access point using an etherne tconnection among them with VLANS.

IOT devices can communicate among them using the vlan being connected to any of the two wireless access point.

1 Like

The RT3200 has the reset button. If you hold it down it goes back to the last full flash and you can start over. I had to twice while setting it up because I put the IP address on the wrong vlan as I turned on full tagging.

You can also have it plugged into a cisco switch and turn tagging on/off as you configure it in case you have a model that doesn't allow you to just reset it like the RT3200 does.

Or you can always set one port to full tagging and one port as an untagged maintenance port, so you can always hook it directly to a laptop. Just make sure to affix a "maintenance port" sticker next to it on the back so pen testers can quickly locate it.

Iv this router but mine is now stuck in recovery and can't seem to get it into production
Iv even tried Tried cat /sys/fs/pstore/* and no file or directory found via SSH. how this happened was I used the web gui to update the firmware and checked the box to keep the settings. After it rebooted it it was working but the WiFi was not so I held down the reset button and then it went to into recovery and no matter what firmware I try it just goes back to recovery