Belkin RT3200 bricked

Hey Guys,

I have Belkin RT3200 it was working fine some days ago but then whenever i unplug the router and plug back in power the router didn’t start but after couple of tries it turned on and works fine but now no matter how many times i plug and unplug it doesn’t turn on.

Please eny expert help.

Sadly, I suspect you have what's turning out to be a not entirely uncommon problem.

Yes i do also believe it is OKD but the problem is the procedure mentioned to recover the router is very hard and im a basic user i do not know anything about serial connector.

One thing more i noticed when my router was last turned on it was on 23.05.0 firmware I tried to to flash the latest sysupgarde file and it flashed and get the router restart but that again Router didn’t restart then i unplug the power and plug back in but the router was on the same firmware as before it didn’t update the firmware.

Now im thinking to put my router in freezer than i will turn it back on and if its turned on can I flash the UBI and then do the sysupgrade will it fix my problem?

Unfortunately, the issue appears to be progressive. In other words, it will continue to get worse until properly resolved. At present, the serial connector option is in fact the easiest option available. There are hopes that when the true cause is found and fixed, there will be an easier solution available shortly thereafter.

Neither did I until I read the forums, followed the steps, and wrote the guide!

Are you the person who installed OpenWrt on your router the first time? If so, I am sure you are plenty capable to follow the recovery steps in the wiki. It is very easy.

If you are really not capable of doing so you have only a few options:

  • Retire the router and get something else
  • Ask for help from the person who did set up OpenWrt on that router, if it was not you
  • Pay someone hardware oriented to follow the steps in the wiki. I am sure they will find it trivial.
    • Could be a hardware repair person
    • Or someone who works at an electronics store and wants some easy side cash
    • Or someone who has an arduino as a hobby
    • I am sure you can find someone, no matter how big or small your town

Bro the freezer thing worked I put the router in freezer for around 15 mins then i plug it in it Turned on :joy: then I do the sysupgrade from 23.05.0 to 23.05.03 it upgraded and rebooted successfully then I perform the reboot from luci again it’s not turning on now :pensive:

Please make sure to carefully understand what @grauerfuchs helpfully mentioned. He's correct, it will only get worse.

Ahh You motivated me enough im ordering now usb to TTL adapter and will try to fix it myself and if not fixed i may learned something :blush: thnx Bro


That's the spirit! The guide is well made and quite complete. Please do read it carefully in the entirety before starting back at the top for performing the task. Follow the instructions, and it turns out that it's really only a few steps and one spot where timing is important. Overall, it's not that much more difficult than installing the firmware the first time around.


Yea and I ordered the TTL converter it will arrive on Saturday till then I will Use my old Teltonika rutx11 Router.

The only thing I may get confuse with connecting the rx and tx but let see when the connector arrives maybe i will found it easy to connect :slight_smile:

Hey Bro today I got the TTL converter and now i tried the steps mentioned in okd recvery fix.

I run the mtk uartboot this application just blink and then closes then i turned on the router I got this in putty

Please Guide what thing im doing wrong here

Something is definitely not right there. It may be that you have the transmit (TX) and receive (RX) wires backward. Remember, the TX on the router must connect to the RX of the converter and the RX on the router must connect to the TX of the converter.

Additionally, are you certain that the converter you purchased supports 3.3v? "TTL" by official definition is 5V. "CMOS" logic is 3.3V. There is a lot of confusion out there, with converters being labeled "TTL" but with a switch or jumper to set 5V or 3.3V. This router requires 3.3V logic, and a 5V-only converter may damage it further.

If you're certain that you have the wires connected properly and the converter is working in 3.3V logic levels, are you sure you have selected the correct COM port? The Device Manager may help you there. At the very least, you'll be able to see which COM-compliant ports your computer has. Your converter is probably listed as something similar to "USB to Serial converter".

If you're sure you have the correct COM port selected, make PuTTY is set to communicate using 8 data bits, no parity, 1 stop bit at 115200 speed (115200/8N1). The command line information for mtk_uartboot already contains this information in one of the provided parameters.

If everything appears correct but it's still not working, try directly connecting the adapter's TX and RX pins together and open the port in PuTTY. What you type should appear on the screen. This is called a loopback echo test, and it makes sure your adapter is working properly. To connect the pins together, you can use a small piece of wire inserted into the housing of the two pins. Make sure the piece of wire is no less than 1cm long to ensure it connects to both sides properly. A standard paper staple can also be used in a pinch, since most are electrically conductive.

Bro im doing something wrong here

Ran the v1.1.1 UBI installer (e.g. running recent snapshot builds. You'd know if you did it!)

I really didn’t get what the Ran means?

Run the mtk_uartboot program with your downloaded files, followed by an immediate screen or putty command.

How to Run .

Let me tell You what I did

I downloaded all the files mention in the post and placed it one folder then i installed putty and start the connection on COM3 which i found on device manager.
Then i double click the uartboot exe file one window appears like for milisecond then it closes automatically then i turned on the router and these dots appers in putty.

I must have did something wrong because im completely noob to these things

Follow the instructions in the post on the wiki. You'll need to use a command window to run mtk_uartboot. It's a command-line application and it does not have a graphical user interface. The reason it closed right away is because it was trying to give you the list of command line options, but Windows doesn't let them remain visible once the application has stopped running unless you start the program from a proper command window.

In the case of "Ran" the v1.1.1 UBI installer, it effectively means "uploaded the v1.1.1 UBI installer as a firmware upgrade, waited for it to complete the reboot, and then installed the real OpenWRT firmware from the recovery environment provided by the v1.1.1 UBI installer".

Bro i got this error in command promt

And below is my com port number

Ok. Thank you, that does confirm the correct port and it also shows the cause of the error. I think you stumbled upon a typographical error in the wiki post. In the first part of the command line after mtk_uartboot and prior to COM3, I believe it should be -s instead of the posted s-

@jkdf2 : Please check the command line listed for the Windows version of mtk_uartboot on the e8450 topic. If I'm not mistaken, it should read: mtk_uartboot -a -s COM(X) -p bl2-for-mtk_uartboot.bin -f *uboot.fip && putty.exe -serial COM(X) -sercfg 115200,8,n,1,N instead.

1 Like

Now i got this error

All right. The new error is telling you that the .fip file is not in the current folder. You need the bl2-for-mtk_uartboot.bin and the selected *uboot.fip file to be placed in the same folder from which you are running mtk_uartboot.

1 Like

No bro all the files are in same folder

Maybe im using the wrong .fib i have 23.05.03 installed recently and im not using the most recent .fib.
Should I use most receant .fip?

Like below one

  • Ran the v1.1.1 UBI installer (e.g. running recent snapshot builds. You'd know if you did it!)

In that case, we may need to modify the command line since it does not seem to be able to find the file by wildcard. This might be a limitation in Windows, I'm not sure. I don't have a current Windows-based computer to test against.

Try the below command line instead:
mtk_uartboot -a -s COM3 -p bl2-for-mtk_uartboot.bin -f openwrt-23.05.3-mediatek-mt7622-linksys_e8450-ubi-bl31-uboot.fip && putty.exe -serial COM3 -sercfg 115200,8,n,1,N

1 Like