AX3200 (AX6S): 5Ghz AP activated but devices can't see it

Hello OpenWrt Forum! I need help with very strange 5G wireless bug on my Xiaomi AX6S

Luci says that 5Ghz AP is activated and channel is set, but none of the multiple devices can see it. Also I can see neighbor's 5G networks just fine - just mine is missing. Wireless Scan also works fine - router can see other's 5G access points.

Fixes I tried:

  • Downgrading OpenWrt to lower versions: 23.05.05 and 24.10;
  • Different country codes / modes (N,AC,AX);
  • Using non-DFS channels (36-48);
  • Completely removing WiFi AP's in Luci and creating them from scratch;
  • Fix from AX6S device support topic.
    And none of this worked

Also I don't see any error messages related to 5Ghz networking in logread, at least I didn't notice them.

My WiFi card clearly has support for 5Ghz networks. I use Intel AX210


(I disabled 2.5Ghz on purpose and I have no issues with 2.5 at all)

Device logs are down below:

/etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd40:cb25:4966::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'REDACTED'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
/etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'wl0'
        option band '2g'
        option channel '1'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option phy 'wl1'
        option band '5g'
        option channel 'auto'
        option htmode 'HE80'
        option country 'KZ'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
ubus call system board
{
        "kernel": "6.6.86",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi Redmi Router AX6S",
        "board_name": "xiaomi,redmi-router-ax6s",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.1",
                "revision": "r28597-0425664679",
                "target": "mediatek/mt7622",
                "description": "OpenWrt 24.10.1 r28597-0425664679",
                "builddate": "1744562312"
        }
}

Also my router has older variant of bootloader if that helps.

Also here is logread from the startup:

logread
kern.info kernel:  Booting Linux on physical CPU 0x0000000000 [0x410fd034]
kern.notice kernel:  Linux version 6.6.86 (builder@buildhost) (aarch64-openwrt-linux-musl-gcc (OpenWrt GCC 13.3.0 r28597-0425664679) 13.3.0, GNU ld (GNU Binutils) 2.42) #0 SMP  16:38:32 
kern.info kernel:  Machine model: Xiaomi Redmi Router AX6S
kern.info kernel:  earlycon: uart8250 at MMIO32 0x0000000011002000 (options '')
kern.info kernel:  printk: bootconsole [uart8250] enabled
kern.info kernel:  OF: reserved mem: 0x0000000042ff0000..0x0000000042ffffff (64 KiB) map non-reusable ramoops@42ff0000
kern.info kernel:  OF: reserved mem: 0x0000000043000000..0x000000004302ffff (192 KiB) nomap non-reusable secmon@43000000
kern.info kernel:  Zone ranges:
kern.info kernel:    DMA      [mem 0x0000000040000000-0x000000004fffffff]
kern.info kernel:    DMA32    empty
kern.info kernel:    Normal   empty
kern.info kernel:  Movable zone start for each node
kern.info kernel:  Early memory node ranges
kern.info kernel:    node   0: [mem 0x0000000040000000-0x0000000042ffffff]
kern.info kernel:    node   0: [mem 0x0000000043000000-0x000000004302ffff]
kern.info kernel:    node   0: [mem 0x0000000043030000-0x000000004fffffff]
kern.info kernel:  Initmem setup node 0 [mem 0x0000000040000000-0x000000004fffffff]
kern.info kernel:  psci: probing for conduit method from DT.
kern.info kernel:  psci: PSCIv0.2 detected in firmware.
kern.info kernel:  psci: Using standard PSCI v0.2 function IDs
kern.info kernel:  psci: Trusted OS migration not required
kern.info kernel:  percpu: Embedded 18 pages/cpu s35560 r8192 d29976 u73728
kern.debug kernel:  pcpu-alloc: s35560 r8192 d29976 u73728 alloc=18*4096
kern.debug kernel:  pcpu-alloc: [0] 0 [0] 1
kern.info kernel:  Detected VIPT I-cache on CPU0
kern.info kernel:  CPU features: kernel page table isolation disabled by kernel configuration
kern.info kernel:  CPU features: detected: ARM erratum 843419
kern.info kernel:  alternatives: applying boot alternatives
kern.notice kernel:  Kernel command line: earlycon=uart8250,mmio32,0x11002000 swiotlb=512 ubi.block=0,fit root=/dev/fit0
kern.info kernel:  Dentry cache hash table entries: 32768 (order: 6, 262144 bytes, linear)
kern.info kernel:  Inode-cache hash table entries: 16384 (order: 5, 131072 bytes, linear)
kern.info kernel:  Built 1 zonelists, mobility grouping on.  Total pages: 64512
kern.info kernel:  mem auto-init: stack:off, heap alloc:off, heap free:off
kern.info kernel:  software IO TLB: area num 2.
kern.info kernel:  software IO TLB: mapped [mem 0x000000004f900000-0x000000004fa00000] (1MB)
kern.info kernel:  Memory: 242900K/262144K available (9152K kernel code, 950K rwdata, 1620K rodata, 448K init, 310K bss, 19244K reserved, 0K cma-reserved)
kern.info kernel:  SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
kern.info kernel:  rcu: Hierarchical RCU implementation.
kern.info kernel:        Tracing variant of Tasks RCU enabled.
kern.info kernel:  rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
kern.info kernel:  NR_IRQS: 64, nr_irqs: 64, preallocated irqs: 0
kern.info kernel:  Root IRQ handler: 0xffffffc080010000
kern.info kernel:  GIC: Using split EOI/Deactivate mode
kern.info kernel:  rcu: srcu_init: Setting srcu_struct sizes based on contention.
kern.info kernel:  arch_timer: cp15 timer(s) running at 12.50MHz (phys).
kern.info kernel:  clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x2e2049cda, max_idle_ns: 440795202628 ns
kern.info kernel:  sched_clock: 56 bits at 13MHz, resolution 80ns, wraps every 4398046511080ns
kern.info kernel: [    0.008265] Calibrating delay loop (skipped), value calculated using timer frequency.. 25.00 BogoMIPS (lpj=125000)
kern.info kernel: [    0.018662] pid_max: default: 32768 minimum: 301
kern.info kernel: [    0.026039] Mount-cache hash table entries: 512 (order: 0, 4096 bytes, linear)
kern.info kernel: [    0.033296] Mountpoint-cache hash table entries: 512 (order: 0, 4096 bytes, linear)
kern.info kernel: [    0.043630] RCU Tasks Trace: Setting shift to 1 and lim to 1 rcu_task_cb_adjust=1 rcu_task_cpu_ids=2.
kern.info kernel: [    0.053018] rcu: Hierarchical SRCU implementation.
kern.info kernel: [    0.057828] rcu:  Max phase no-delay instances is 1000.
kern.info kernel: [    0.063464] smp: Bringing up secondary CPUs ...
kern.info kernel: [    0.068417] Detected VIPT I-cache on CPU1
kern.info kernel: [    0.068493] CPU1: Booted secondary processor 0x0000000001 [0x410fd034]
kern.info kernel: [    0.068557] smp: Brought up 1 node, 2 CPUs
kern.info kernel: [    0.083241] SMP: Total of 2 processors activated.
kern.info kernel: [    0.087957] CPU features: detected: 32-bit EL0 Support
kern.info kernel: [    0.093114] CPU features: detected: CRC32 instructions
kern.info kernel: [    0.098294] CPU features: emulated: Privileged Access Never (PAN) using TTBR0_EL1 switching
kern.info kernel: [    0.106679] CPU: All CPU(s) started at EL2
kern.info kernel: [    0.110784] alternatives: applying system-wide alternatives
kern.info kernel: [    0.120808] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
kern.info kernel: [    0.130698] futex hash table entries: 512 (order: 3, 32768 bytes, linear)
kern.info kernel: [    0.138755] pinctrl core: initialized pinctrl subsystem
kern.info kernel: [    0.145209] NET: Registered PF_NETLINK/PF_ROUTE protocol family
kern.info kernel: [    0.151443] DMA: preallocated 128 KiB GFP_KERNEL pool for atomic allocations
kern.info kernel: [    0.158548] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA pool for atomic allocations
kern.info kernel: [    0.166336] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA32 pool for atomic allocations
kern.info kernel: [    0.174687] thermal_sys: Registered thermal governor 'fair_share'
kern.info kernel: [    0.174691] thermal_sys: Registered thermal governor 'bang_bang'
kern.info kernel: [    0.180803] thermal_sys: Registered thermal governor 'step_wise'
kern.info kernel: [    0.186832] thermal_sys: Registered thermal governor 'user_space'
kern.info kernel: [    0.192912] ASID allocator initialised with 65536 entries
kern.info kernel: [    0.205093] pstore: Using crash dump compression: deflate
kern.info kernel: [    0.210515] pstore: Registered ramoops as persistent store backend
kern.info kernel: [    0.216714] ramoops: using 0x10000@0x42ff0000, ecc: 0
kern.info kernel: [    0.230195] Modules: 29616 pages in range for non-PLT usage
kern.info kernel: [    0.230208] Modules: 521136 pages in range for PLT usage
kern.info kernel: [    0.236872] cryptd: max_cpu_qlen set to 1000
kern.notice kernel: [    0.247495] SCSI subsystem initialized
kern.debug kernel: [    0.251342] libata version 3.00 loaded.
kern.info kernel: [    0.256512] clocksource: Switched to clocksource arch_sys_counter
kern.info kernel: [    0.264761] NET: Registered PF_INET protocol family
kern.info kernel: [    0.269770] IP idents hash table entries: 4096 (order: 3, 32768 bytes, linear)
kern.info kernel: [    0.278277] tcp_listen_portaddr_hash hash table entries: 256 (order: 0, 4096 bytes, linear)
kern.info kernel: [    0.286677] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
kern.info kernel: [    0.294452] TCP established hash table entries: 2048 (order: 2, 16384 bytes, linear)
kern.info kernel: [    0.302242] TCP bind hash table entries: 2048 (order: 4, 65536 bytes, linear)
kern.info kernel: [    0.309461] TCP: Hash tables configured (established 2048 bind 2048)
kern.info kernel: [    0.316134] MPTCP token hash table entries: 256 (order: 0, 6144 bytes, linear)
kern.info kernel: [    0.323486] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
kern.info kernel: [    0.330054] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
kern.info kernel: [    0.337294] NET: Registered PF_UNIX/PF_LOCAL protocol family
kern.info kernel: [    0.343002] PCI: CLS 0 bytes, default 64
kern.info kernel: [    0.348083] workingset: timestamp_bits=46 max_order=16 bucket_order=0
kern.info kernel: [    0.359121] squashfs: version 4.0 (2009/01/31) Phillip Lougher
kern.info kernel: [    0.364977] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
kern.info kernel: [    0.406582] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
kern.err kernel: [    0.414734] mt7622-pinctrl 10211000.pinctrl: invalid group "pwm_ch7_2" for function "pwm"
kern.err kernel: [    0.432870] mt-pmic-pwrap 10001000.pwrap: unexpected interrupt int=0x1
kern.info kernel: [    0.452662] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
kern.info kernel: [    0.462325] printk: console [ttyS0] disabled
kern.info kernel: [    0.487108] 11002000.serial: ttyS0 at MMIO 0x11002000 (irq = 118, base_baud = 1562500) is a ST16650V2
kern.info kernel: [    0.496426] printk: console [ttyS0] enabled
kern.info kernel: [    0.504801] printk: bootconsole [uart8250] disabled
kern.info kernel: [    0.515697] mtk_rng 1020f000.rng: registered RNG driver
kern.notice kernel: [    0.515841] random: crng init done
kern.info kernel: [    0.527214] loop: module loaded
kern.info kernel: [    0.530956] mtk-ecc 1100e000.ecc: probed
kern.info kernel: [    0.536113] spi-nand spi0.0: ESMT SPI NAND was found.
kern.info kernel: [    0.541181] spi-nand spi0.0: 128 MiB, block size: 128 KiB, page size: 2048, OOB size: 64
kern.info kernel: [    0.549296] mtk-snand 1100d000.spi: ECC strength: 4 bits per 512 bytes
kern.info kernel: [    0.557152] [BBT] BMT.v2 is found at 0x3ff
kern.notice kernel: [    0.561440] 10 fixed-partitions partitions found on MTD device spi0.0
kern.err kernel: [    0.567994] OF: Bad cell count for /spi@1100d000/flash@0/partitions
kern.err kernel: [    0.574273] OF: Bad cell count for /spi@1100d000/flash@0/partitions
kern.notice kernel: [    0.580772] Creating 10 MTD partitions on "spi0.0":
kern.notice kernel: [    0.585645] 0x000000000000-0x000000080000 : "Preloader"
kern.notice kernel: [    0.591791] 0x000000080000-0x0000000c0000 : "ATF"
kern.notice kernel: [    0.597626] 0x0000000c0000-0x000000140000 : "u-boot"
kern.notice kernel: [    0.603423] 0x000000140000-0x000000180000 : "u-boot-env"
kern.notice kernel: [    0.609302] 0x000000180000-0x0000001c0000 : "bdata"
kern.notice kernel: [    0.614713] 0x0000001c0000-0x000000240000 : "factory"
kern.err kernel: [    0.620655] OF: Bad cell count for /spi@1100d000/flash@0/partitions
kern.notice kernel: [    0.627130] 0x000000240000-0x000000280000 : "crash"
kern.notice kernel: [    0.632586] 0x000000280000-0x0000002c0000 : "crash_log"
kern.notice kernel: [    0.638372] 0x0000002c0000-0x000000340000 : "ubi-loader"
kern.notice kernel: [    0.644509] 0x000000340000-0x0000075c0000 : "ubi"
kern.notice kernel: [    0.769645] ubi0: default fastmap pool size: 45
kern.notice kernel: [    0.774173] ubi0: default fastmap WL pool size: 22
kern.notice kernel: [    0.778966] ubi0: attaching mtd9
kern.notice kernel: [    1.033407] ubi0: scanning is finished
kern.notice kernel: [    1.041232] ubi0: attached mtd9 (name "ubi", size 114 MiB)
kern.notice kernel: [    1.046732] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
kern.notice kernel: [    1.053599] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
kern.notice kernel: [    1.060382] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
kern.notice kernel: [    1.067339] ubi0: good PEBs: 916, bad PEBs: 0, corrupted PEBs: 0
kern.notice kernel: [    1.073337] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
kern.notice kernel: [    1.080553] ubi0: max/mean erase counter: 2/1, WL threshold: 4096, image sequence number: 1738624177
kern.notice kernel: [    1.089680] ubi0: available PEBs: 0, total reserved PEBs: 916, PEBs reserved for bad PEB handling: 19
kern.notice kernel: [    1.098904] ubi0: background thread "ubi_bgt0d" started, PID 287
kern.info kernel: [    1.099394] block ubiblock0_0: created from ubi0:0(fit)
kern.info kernel: [    1.240266] mtk_soc_eth 1b100000.ethernet eth0: mediatek frame engine at 0xffffffc0814c0000, irq 123
kern.info kernel: [    1.250045] i2c_dev: i2c /dev entries driver
kern.info kernel: [    1.255667] mtk-wdt 10212000.watchdog: Watchdog enabled (timeout=31 sec, nowayout=0)
kern.info kernel: [    1.265391] NET: Registered PF_INET6 protocol family
kern.info kernel: [    1.271027] Segment Routing with IPv6
kern.info kernel: [    1.274706] In-situ OAM (IOAM) with IPv6
kern.info kernel: [    1.278683] NET: Registered PF_PACKET protocol family
kern.info kernel: [    1.283742] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
kern.info kernel: [    1.296894] 8021q: 802.1Q VLAN Support v1.8
kern.info kernel: [    1.326623] mtk-pcie 1a143000.pcie: host bridge /pcie@1a143000 ranges:
kern.debug kernel: [    1.333181] mtk-pcie 1a143000.pcie: Parsing ranges property...
kern.info kernel: [    1.339038] mtk-pcie 1a143000.pcie:      MEM 0x0020000000..0x0027ffffff -> 0x0020000000
kern.info kernel: [    1.603215] mtk-pcie 1a143000.pcie: PCI host bridge to bus 0000:00
kern.info kernel: [    1.609440] pci_bus 0000:00: root bus resource [bus 00-ff]
kern.info kernel: [    1.614925] pci_bus 0000:00: root bus resource [mem 0x20000000-0x27ffffff]
kern.debug kernel: [    1.621802] pci_bus 0000:00: scanning bus
kern.info kernel: [    1.625990] pci 0000:00:00.0: [14c3:3258] type 01 class 0x060400
kern.info kernel: [    1.632182] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x1ffffffff 64bit pref]
kern.debug kernel: [    1.642305] pci_bus 0000:00: fixups for bus
kern.debug kernel: [    1.646501] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 0
kern.info kernel: [    1.653212] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
kern.debug kernel: [    1.661291] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 1
kern.debug kernel: [    1.668388] pci_bus 0000:01: scanning bus
kern.info kernel: [    1.672547] pci 0000:01:00.0: [14c3:7915] type 00 class 0x000280
kern.info kernel: [    1.678734] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
kern.info kernel: [    1.686059] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
kern.info kernel: [    1.693388] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
kern.info kernel: [    1.701361] pci 0000:01:00.0: supports D1 D2
kern.info kernel: [    1.705626] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
kern.debug kernel: [    1.712270] pci 0000:01:00.0: PME# disabled
kern.info kernel: [    1.716799] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
kern.debug kernel: [    1.756850] pci_bus 0000:01: fixups for bus
kern.debug kernel: [    1.761035] pci_bus 0000:01: bus scan returning with max=01
kern.info kernel: [    1.766664] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
kern.debug kernel: [    1.773300] pci_bus 0000:00: bus scan returning with max=01
kern.info kernel: [    1.778915] pci 0000:00:00.0: BAR 0: no space for [mem size 0x200000000 64bit pref]
kern.info kernel: [    1.786585] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x200000000 64bit pref]
kern.info kernel: [    1.794584] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x201fffff]
kern.info kernel: [    1.801375] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit pref]
kern.info kernel: [    1.809199] pci 0000:01:00.0: BAR 2: assigned [mem 0x20100000-0x20103fff 64bit pref]
kern.info kernel: [    1.817026] pci 0000:01:00.0: BAR 4: assigned [mem 0x20104000-0x20104fff 64bit pref]
kern.info kernel: [    1.824845] pci 0000:00:00.0: PCI bridge to [bus 01]
kern.info kernel: [    1.829810] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x201fffff]
kern.debug kernel: [    1.836724] pcieport 0000:00:00.0: assign IRQ: got 127
kern.info kernel: [    1.841863] pcieport 0000:00:00.0: enabling device (0000 -> 0002)
kern.debug kernel: [    1.847971] pcieport 0000:00:00.0: enabling bus mastering
kern.debug kernel: [    1.853419] mtk-pcie 1a143000.pcie: msi#0 address_hi 0x0 address_lo 0x44ecd0c0
kern.info kernel: [    1.860810] pcieport 0000:00:00.0: PME: Signaling with IRQ 127
kern.debug kernel: [    1.866719] pcieport 0000:00:00.0: save config 0x00: 0x325814c3
kern.debug kernel: [    1.872634] pcieport 0000:00:00.0: save config 0x04: 0x00100006
kern.debug kernel: [    1.878558] pcieport 0000:00:00.0: save config 0x08: 0x06040000
kern.debug kernel: [    1.884471] pcieport 0000:00:00.0: save config 0x0c: 0x00010000
kern.debug kernel: [    1.890389] pcieport 0000:00:00.0: save config 0x10: 0x0000000c
kern.debug kernel: [    1.896302] pcieport 0000:00:00.0: save config 0x14: 0x00000000
kern.debug kernel: [    1.902219] pcieport 0000:00:00.0: save config 0x18: 0x40010100
kern.debug kernel: [    1.908136] pcieport 0000:00:00.0: save config 0x1c: 0x04200000
kern.debug kernel: [    1.914049] pcieport 0000:00:00.0: save config 0x20: 0x20102000
kern.debug kernel: [    1.919966] pcieport 0000:00:00.0: save config 0x24: 0x00000000
kern.debug kernel: [    1.925879] pcieport 0000:00:00.0: save config 0x28: 0x00000000
kern.debug kernel: [    1.931796] pcieport 0000:00:00.0: save config 0x2c: 0x00000000
kern.debug kernel: [    1.937716] pcieport 0000:00:00.0: save config 0x30: 0x00000000
kern.debug kernel: [    1.943630] pcieport 0000:00:00.0: save config 0x34: 0x00000050
kern.debug kernel: [    1.949547] pcieport 0000:00:00.0: save config 0x38: 0x00000000
kern.debug kernel: [    1.955460] pcieport 0000:00:00.0: save config 0x3c: 0x0002017f
kern.info kernel: [    1.962035] mtk_hsdma 1b007000.dma-controller: MediaTek HSDMA driver registered
kern.info kernel: [    1.970071] FIT: Detected U-Boot 2024.10-OpenWrt-r28427-6df0e3d02a
kern.info kernel: [    1.976253] FIT: Selected configuration: "config-1" (OpenWrt xiaomi_redmi-router-ax6s)
kern.info kernel: [    1.984190] FIT:           kernel sub-image 0x00001000..0x0056676e "kernel-1" (ARM64 OpenWrt Linux-6.6.86)
kern.info kernel: [    1.993946] FIT:          flat_dt sub-image 0x00567000..0x0056e314 "fdt-1" (ARM64 OpenWrt xiaomi_redmi-router-ax6s device tree blob)
kern.info kernel: [    2.005956] FIT:       filesystem sub-image 0x0056f000..0x00a06fff "rootfs-1" (ARM64 OpenWrt xiaomi_redmi-router-ax6s rootfs)
kern.info kernel: [    2.017745] block ubiblock0_0: mapped 1 uImage.FIT filesystem sub-image as /dev/fit0
kern.info kernel: [    2.097307] mt7530-mdio mdio-bus:1f: configuring for fixed/2500base-x link mode
kern.info kernel: [    2.106371] mt7530-mdio mdio-bus:1f: Link is Up - 2.5Gbps/Full - flow control rx/tx
kern.info kernel: [    2.117580] mt7530-mdio mdio-bus:1f wan (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7531 PHY] (irq=129)
kern.info kernel: [    2.139834] mt7530-mdio mdio-bus:1f lan1 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7531 PHY] (irq=130)
kern.info kernel: [    2.161860] mt7530-mdio mdio-bus:1f lan2 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7531 PHY] (irq=131)
kern.info kernel: [    2.183860] mt7530-mdio mdio-bus:1f lan3 (uninitialized): PHY [mt7530-0:04] driver [MediaTek MT7531 PHY] (irq=132)
kern.info kernel: [    2.195108] mtk_soc_eth 1b100000.ethernet eth0: entered promiscuous mode
kern.info kernel: [    2.201858] DSA: tree 0 setup
kern.info kernel: [    2.205262] clk: Disabling unused clocks
kern.info kernel: [    2.212243] VFS: Mounted root (squashfs filesystem) readonly on device 259:0.
kern.info kernel: [    2.219609] Freeing unused kernel memory: 448K
kern.info kernel: [    2.224097] Run /sbin/init as init process
kern.debug kernel: [    2.228213]   with arguments:
kern.debug kernel: [    2.231172]     /sbin/init
kern.debug kernel: [    2.233869]   with environment:
kern.debug kernel: [    2.237023]     HOME=/
kern.debug kernel: [    2.239375]     TERM=linux
user.info kernel: [    2.423391] init: Console is alive
user.info kernel: [    2.426928] init: - watchdog -
user.info kernel: [    2.766749] kmodloader: loading kernel modules from /etc/modules-boot.d/*
kern.warn kernel: [    2.791018] gpio_button_hotplug: loading out-of-tree module taints kernel.
user.info kernel: [    2.801040] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
user.info kernel: [    2.813333] init: - preinit -
kern.info kernel: [    3.180837] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
kern.info kernel: [    3.189521] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
kern.info kernel: [    3.204973] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
kern.info kernel: [    5.141688] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx
kern.notice kernel: [    7.472265] UBIFS (ubi0:1): Mounting in unauthenticated mode
kern.notice kernel: [    7.478079] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 768
kern.notice kernel: [    7.495417] UBIFS (ubi0:1): recovery needed
kern.notice kernel: [    7.554619] UBIFS (ubi0:1): recovery completed
kern.notice kernel: [    7.559157] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
kern.notice kernel: [    7.567003] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
kern.notice kernel: [    7.576925] UBIFS (ubi0:1): FS size: 101199872 bytes (96 MiB, 797 LEBs), max 808 LEBs, journal size 5079040 bytes (4 MiB, 40 LEBs)
kern.notice kernel: [    7.588670] UBIFS (ubi0:1): reserved for root: 4779919 bytes (4667 KiB)
kern.notice kernel: [    7.595281] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID 9E671935-6517-44E4-B70B-A0E50080B469, small LPT model
user.info kernel: [    7.608981] mount_root: switching to ubifs overlay
kern.warn kernel: [    7.616751] overlayfs: null uuid detected in lower fs '/', falling back to xino=off,index=off,nfs_export=off.
user.debug kernel: [    7.630671] urandom-seed: Seeding with /etc/urandom.seed
kern.info kernel: [    7.686426] mt7530-mdio mdio-bus:1f lan1: Link is Down
user.info kernel: [    7.695649] procd: - early -
user.info kernel: [    7.698653] procd: - watchdog -
user.info kernel: [    8.269051] procd: - watchdog -
user.info kernel: [    8.273661] procd: - ubus -
user.info kernel: [    8.428695] procd: - init -
user.info kernel: [    8.743168] kmodloader: loading kernel modules from /etc/modules.d/*
kern.info kernel: [    8.775605] Loading modules backported from Linux version v6.12.6-0-ge9d65b48ce1a
kern.info kernel: [    8.783154] Backport generated by backports.git v6.1.110-1-35-g410656ef04d2
kern.info kernel: [    8.867513] mt7622-wmac 18000000.wmac: registering led 'mt76-phy0'
kern.debug kernel: [    8.947011] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
kern.debug kernel: [    8.967780] mt7915e 0000:01:00.0: assign IRQ: got 127
user.info kernel: [    8.968628] urngd: v1.0.2 started.
kern.info kernel: [    8.972884] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
kern.debug kernel: [    8.982330] mt7915e 0000:01:00.0: enabling bus mastering
kern.info kernel: [    9.056619] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
kern.info kernel: [    9.056619]
kern.debug kernel: [    9.129236] mtk-pcie 1a143000.pcie: msi#0 address_hi 0x0 address_lo 0x44ecd0c0
kern.info kernel: [    9.177096] mt7622-wmac 18000000.wmac: N9 Firmware Version: _reserved_, Build Time: 20220630094834
kern.info kernel: [    9.197758] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20240429200716a
kern.info kernel: [    9.197758]
kern.info kernel: [    9.348209] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20240429200752
kern.info kernel: [    9.395894] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20240429200812
kern.info kernel: [    9.512354] mt7915e 0000:01:00.0: registering led 'mt76-phy1'
kern.info kernel: [    9.580820] PPP generic driver version 2.4.2
kern.info kernel: [    9.586017] NET: Registered PF_PPPOX protocol family
user.info kernel: [    9.594518] kmodloader: done loading kernel modules from /etc/modules.d/*
user.notice : Added device handler type: bonding
user.notice : Added device handler type: 8021ad
user.notice : Added device handler type: 8021q
user.notice : Added device handler type: macvlan
user.notice : Added device handler type: veth
user.notice : Added device handler type: bridge
user.notice : Added device handler type: Network device
user.notice : Added device handler type: tunnel
daemon.notice procd: /etc/rc.d/S25packet_steering: pid 415's current affinity list: 0-1
daemon.notice procd: /etc/rc.d/S25packet_steering: pid 415's new affinity list: 0
daemon.notice procd: /etc/rc.d/S25packet_steering: pid 416's current affinity list: 0-1
daemon.notice procd: /etc/rc.d/S25packet_steering: pid 416's new affinity list: 0
daemon.notice wpa_supplicant[1663]: Successfully initialized wpa_supplicant
user.notice ucitrack: Setting up /etc/config/luci-splash reload dependency on /etc/config/firewall
user.notice ucitrack: Setting up /etc/config/qos reload dependency on /etc/config/firewall
user.notice ucitrack: Setting up /etc/config/miniupnpd reload dependency on /etc/config/firewall
user.notice ucitrack: Setting up /etc/config/odhcpd reload dependency on /etc/config/dhcp
user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/network
kern.info kernel: [   12.585762] mtk_soc_eth 1b100000.ethernet eth0: Link is Down
user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/wireless
kern.info kernel: [   12.614311] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
kern.info kernel: [   12.624069] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
kern.info kernel: [   12.640850] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
kern.info kernel: [   12.652681] br-lan: port 1(lan1) entered blocking state
kern.info kernel: [   12.658027] br-lan: port 1(lan1) entered disabled state
kern.info kernel: [   12.663302] mt7530-mdio mdio-bus:1f lan1: entered allmulticast mode
kern.info kernel: [   12.669636] mtk_soc_eth 1b100000.ethernet eth0: entered allmulticast mode
kern.info kernel: [   12.679713] mt7530-mdio mdio-bus:1f lan1: entered promiscuous mode
daemon.notice netifd: Interface 'lan' is enabled
daemon.notice netifd: Interface 'lan' is setting up now
daemon.notice netifd: Interface 'lan' is now up
kern.info kernel: [   12.700474] mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
kern.info kernel: [   12.712127] br-lan: port 2(lan2) entered blocking state
kern.info kernel: [   12.717445] br-lan: port 2(lan2) entered disabled state
kern.info kernel: [   12.722728] mt7530-mdio mdio-bus:1f lan2: entered allmulticast mode
kern.info kernel: [   12.731521] mt7530-mdio mdio-bus:1f lan2: entered promiscuous mode
kern.info kernel: [   12.747700] mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
kern.info kernel: [   12.760364] br-lan: port 3(lan3) entered blocking state
kern.info kernel: [   12.765608] br-lan: port 3(lan3) entered disabled state
kern.info kernel: [   12.770933] mt7530-mdio mdio-bus:1f lan3: entered allmulticast mode
kern.info kernel: [   12.782195] mt7530-mdio mdio-bus:1f lan3: entered promiscuous mode
daemon.notice netifd: Interface 'loopback' is enabled
daemon.notice netifd: Interface 'loopback' is setting up now
daemon.notice netifd: Interface 'loopback' is now up
daemon.notice netifd: Interface 'wan' is enabled
daemon.notice netifd: Interface 'wan6' is enabled
kern.info kernel: [   12.801655] mt7530-mdio mdio-bus:1f wan: configuring for phy/gmii link mode
daemon.notice netifd: Network device 'eth0' link is up
daemon.notice netifd: Network device 'lo' link is up
user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
daemon.notice netifd: Interface 'loopback' has link connectivity
user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
daemon.notice netifd: radio1 (2134): WARNING: Variable 'data' does not exist or is not an array/object
user.notice ucitrack: Setting up /etc/config/luci_statistics reload dependency on /etc/config/system
user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/system
daemon.notice procd: /etc/rc.d/S96led: setting up led WAN
daemon.notice hostapd: Set new config for phy wl1:
daemon.notice wpa_supplicant[1663]: Set new config for phy wl1
daemon.notice wpa_supplicant[1663]: Set new config for phy wl1
daemon.notice hostapd: Set new config for phy wl1: /var/run/hostapd-wl1.conf
daemon.notice hostapd: Restart interface for phy wl1
daemon.info procd: - init complete -
daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=KZ ieee80211d=1 ieee80211h=1 hw_mode=a beacon_int=100 stationary_ap=1 tx_queue_data2_burst=2.0 #num_global_macaddr=1 #macaddr_base= ieee80211n=1 ht_coex=0 ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935] ieee80211ac=1 vht_oper_chwidth=1 vht_oper_centr_freq_seg0_idx=-6 vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-4][BF-ANTENNA-4][MAX-MPDU-7991][MAX-A-MPDU-LEN-EXP7] ieee80211ax=1 he_oper_chwidth=1 he_oper_centr_freq_seg0_idx=-6 he_su_beamformer=1 he_su_beamformee=1 he_mu_beamformer=1 he_bss_color=128 he_spr_sr_control=3 he_default_pe_duration=4 he_rts_threshold=1023 he_mu_edca_qos_info_param_count=0 he_mu_edca_qos_info_q_ack=0 he_mu_edca_qos_info_queue_request=0 he_mu_edca_qos_info_txop_
daemon.notice hostapd: wl1-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
daemon.notice hostapd: wl1-ap0: interface state COUNTRY_UPDATE->ACS
daemon.notice hostapd: wl1-ap0: ACS-STARTED
daemon.notice netifd: Wireless device 'radio1' is now up
kern.info kernel: [   17.049875] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx
kern.info kernel: [   17.049926] br-lan: port 1(lan1) entered blocking state
kern.info kernel: [   17.063067] br-lan: port 1(lan1) entered forwarding state
daemon.notice netifd: Network device 'lan1' link is up
daemon.notice netifd: bridge 'br-lan' link is up
daemon.notice netifd: Interface 'lan' has link connectivity
daemon.warn odhcpd[1803]: No default route present, overriding ra_lifetime to 0!
daemon.err uhttpd[1921]: [info] luci: accepted login on /admin/system/reboot for root from 192.168.1.193
daemon.notice hostapd: wl1-ap0: ACS-COMPLETED freq=5500 channel=100
daemon.notice hostapd: wl1-ap0: interface state ACS->HT_SCAN
daemon.notice hostapd: wl1-ap0: interface state HT_SCAN->DFS
daemon.notice hostapd: wl1-ap0: DFS-CAC-START freq=5500 chan=100 sec_chan=1, width=1, seg0=106, seg1=0, cac_time=60s
daemon.warn odhcpd[1803]: No default route present, overriding ra_lifetime to 0!
daemon.warn odhcpd[1803]: No default route present, overriding ra_lifetime to 0!

Set another region to check the work.
The KZ region has many restrictions, as Google claims, up to the ban on connecting to unpassworded networks. Intel honors all the rules and this is not a very good card, which should be considered as truly correct.
To the point that Intel reads the region codes of neighboring Wi-Fi networks and geodata of devices and blocks “incorrect” connections at the driver level.

Set another region to check the work

I tried RU, US and PA regions. Same result. With WPA2\WPA3 password as well.

Have you tried connecting another client, not Intel?
You also have the channel set to "auto", although it shows that 36 is selected, try setting it manually, for example 42.

Yes I tried. Android devices also can't see my 5ghz network but can see neighbors'.

Does rolling back to stock firmware solve the problem?

Try some EU region.
Have the same router as dumb AP.
On DFS channel 100 (like you had according to the log) some clients do not see the AP for a while. For example, on android phone, if I turn of wlan and turn it back on, the phone sees all APs except AX6S :slight_smile:
After 1-2 minutes phone finds the AP and connects fine.
Happens only with DFS channels, probably some client thing. It's like it does not scan DFS channels for a while.

In my country, any supported 5 GHz device connects to this router model, whether it's stock, 22, 23, 24, or whatever else was available for this router.
But jumping from 24 to 23 and from 24 to 23 could damage the firmware area responsible for Wi-Fi settings, and then it's really bad. You need to restore from a backup, if you have one.

  • Please refrain from suggesting illegal tests (i.e., switching radio regions)
  • Is this device running OpenWrt, or OEM firmware?
  • What version of OpenWrt did you originally run?
  • Are you keeping settings or resetting to defaults?

This is a former USSR country, not only is it illegal to do anything with Wi-Fi, it is even illegal to be born and live there, so this is a completely harmless experiment))).

2 Likes

Upgrading from 23.05.5 to 24.10 using this guide on device wiki page was the last thing I did before 5Ghz network stopped working. I didn't do OpenWrt's settings reset before updating because the settings are lost anyway.

I got OEM 1.0.83 firmware on purchase, global RB01 variant.


Also I flashed OEM 1.0.71 image yesterday via TFTP (and facinstall method as well) and 5G network is still not there for some reason. Smart Connection feature that combines 2.5Ghz and 5Ghz under one SSID is turned off.

Now I'm wondering is this hardware issue or some kind of firmware bug?

Here are some errors I got running OEM 1.0.71 firmware:

[  112.103335] whnat_probe(): probe fail since whnat is full!
[  112.103344] whnat_dev1: probe of 1020a000.wed2 failed with error -1

[  118.540774] CTS/ACK Timeout Range should between [0xFFFF:0]!!
[  118.546536] [set_datcfg_ack_cts_timeout](12998): DAT config band(0) cck_timeout Fail!
[  118.554366] CTS/ACK Timeout Range should between [0xFFFF:0]!!
[  118.560122] [set_datcfg_ack_cts_timeout](13009): DAT config band(0) ofdm_timeout Fail!
[  118.568040] CTS/ACK Timeout Range should between [0xFFFF:0]!!
[  118.573793] [set_datcfg_ack_cts_timeout](13020): DAT config band(0) ofdma_timeout Fail!
[  118.581797] CTS/ACK Timeout Range should between [0xFFFF:0]!!
[  118.587544] [set_datcfg_ack_cts_timeout](12998): DAT config band(1) cck_timeout Fail!
[  118.595373] CTS/ACK Timeout Range should between [0xFFFF:0]!!
[  118.601122] [set_datcfg_ack_cts_timeout](13009): DAT config band(1) ofdm_timeout Fail!
[  118.609065] CTS/ACK Timeout Range should between [0xFFFF:0]!!
[  118.614814] [set_datcfg_ack_cts_timeout](13020): DAT config band(1) ofdma_timeout Fail!

[  100.923038] mt_rbus 0000:00:00.0: Direct firmware load for mt7622_patch_e2_hdr.bin failed with error -2
^^^ I guess this error is related to 2.5Ghz 

[  100.624317] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2860/RT2860_5G.dat

Output of cat /proc/mtd running OEM 1.0.71

dev:    size   erasesize  name
mtd0: 00020000 00020000 "PL_Header"
mtd1: 00060000 00020000 "Preloader"
mtd2: 00040000 00020000 "ATF"
mtd3: 00080000 00020000 "uboot"
mtd4: 00040000 00020000 "Nvram"
mtd5: 00040000 00020000 "Bdata"
mtd6: 00080000 00020000 "Factory"
mtd7: 00040000 00020000 "crash"
mtd8: 00040000 00020000 "crash_syslog"
mtd9: 01e00000 00020000 "firmware"
mtd10: 002a0000 00020000 "kernel"
mtd11: 01b60000 00020000 "rootfs"
mtd12: 01e00000 00020000 "firmware1"
mtd13: 03200000 00020000 "overlay"
mtd14: 00500000 00020000 "obr"