Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

Yes, just updated from RC1. So far it works.

Also a note: Got two international versions Mi Router AX3200, both with telnet unlocked

Model: RB01
Production date: 08/2021

Bought from different stores in Bulgaria. Also there was one in the Xiaomi Store with the same production date. One of the suppliers stated that those are from the last batch, I don't know if that is true.

Rc3 started building...

Hello,

I find OpenWRT an awesome project and the Devs did a great job with adding support for this device!

My RB03 device finally arrived and i have tried several snapshots, including rc3:

openwrt-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-factory.bin
openwrt-22.03.0-rc3-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-factory.bin
openwrt-22.03-snapshot-r19381-b42511c007-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-factory.bin - currently using this one (OpenWrt 22.03-SNAPSHOT r19381-b42511c007 / LuCI openwrt-22.03 branch git-22.140.66268-ef99568)

With each one though i get the same issue - the 5G wifi driver doesn't seem to start:

[    1.273876] pci 0000:01:00.0: [14c3:7915] type 00 class 0x000280
[    8.520810] mt7915e 0000:01:00.0: assign IRQ: got 142
[    8.530954] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
[    8.537047] mt7915e 0000:01:00.0: enabling bus mastering
[    8.618284] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20201105222230a
[    8.823875] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20201105222304
[    8.890360] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20201105222323
[    9.003482] mt7915e 0000:01:00.0: eeprom load fail, use default bin
[    9.009827] mt7915e 0000:01:00.0: Direct firmware load for mediatek/mt7915_eeprom.bin failed with error -2
[    9.019476] mt7915e 0000:01:00.0: Falling back to sysfs fallback for: mediatek/mt7915_eeprom.bin
[    9.034514] mt7915e: probe of 0000:01:00.0 failed with error -12

And i don't get to see a wlan1 interface. On the stock firmware both wifi radios worked. I haven't seen anyone mention such an issue and any hints for solving this are appreciated!

Thanks!

try rc1. it has been very stable for me.

https://downloads.openwrt.org/releases/22.03.0-rc1/targets/mediatek/mt7622/openwrt-22.03.0-rc1-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-factory.bin

1 Like

Set a wireless region for the 5G radio

Hello,

I have installed rc1, but no luck - still seeing same driver issue in dmesg, hence only radio0 (MediaTek MT7622 802.11bgn) is showing in Luci.

Then i downloaded https://github.com/openwrt/mt76/blob/master/firmware/mt7915_eeprom.bin and reloaded the kernel module:

cp /tmp/mt7915_eeprom.bin /lib/firmware/mediatek/
rmmod /lib/modules/5.10.111/mt7915e.ko
insmod mt7915e
dmesg | tail
[   15.904365] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[   15.911899] br-lan: port 1(lan1) entered blocking state
[   15.917133] br-lan: port 1(lan1) entered forwarding state
[  168.750758] mt7915e 0000:01:00.0: assign IRQ: got 140
[  168.755934] mt7915e 0000:01:00.0: enabling bus mastering
[  168.897953] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20201105222230a
[  168.897953] 
[  168.915727] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20201105222304
[  168.939571] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20201105222323
[  169.053709] mt7915e 0000:01:00.0: eeprom load fail, use default bin

Now i have also radio1 (MediaTek MT7915E 802.11nacax) in Luci!

3 Likes

Is the 27db (500mW) limit a hardware one or is there a reason why it can't do the whole 30db (1W) but my Archer can?

Judging from the FCC measurements of common consumer devices, you'd be hard pressed to find any devices that would even get close to transmitting 1 watt over the air.

2 Likes

The Archers C7s supposedly can really output that. Anyone has any FCC datasheets for the AX3200?

I believe they're more euro-centric for their global products, so the best you have in that regard is a declaration of conformity, with the actual test reports only mentioned by report number.

For the US market, they haven't submitted many of the product line to the FCC (I think I saw the 4A in there...). I assume that's fine since they're probably not direct selling them to the US market.

They can be shipped worldwide if you buy on AliExpress. I hope it's legal to have them shipped here. :face_with_hand_over_mouth:

At the present moment (April 2022) there is no known way to enable telnet on the Xiaomi AX3200 (model RB01, international version). So if you have this device, you can check if it came from factory with telnet enabled. If so you can install OpenWrt, otherwise it is not possible to install OpenWrt on the Xiaomi AX3200 (model RB01).

I couldn't find anything related to this in the thread, so I apologize if this is a redundant question. But just to make sure: wouldn't I be able to bypass this restriction by soldering pins to the serial pins and use that to login as root? Or is there no active serial console on those pins?

@hrkfdn

2 Likes

Im using vnStat to monitor bandwidth and I think monitoring doesn't work correctly on this device, is that because NAT Offloading is enabled ? I selected wan interface and it detects about 30% of real bandwidth. Anyone else using vnstat ?

@hrkfdn

as @cliobrando quoted, you are able to install OpenWrt if you have serial access.

And you don't even need to open the case, if you have long enough pins ...:

2 Likes

Got a November 2021 RB03 (running 1.0.19) and successfully installed OpenWRT yesterday. Be warned though that the web UI is Chinese with seemingly no way to switch to English.

I used DeepL and a lot of guessing to flash the beta firmware to get telnet access after which it was smooth sailing (well except for the part were my existing network already uses 192.168.1.1 as gateway :slight_smile: )

I have a feeling that this thread is neglected

Rc4 is ready.
Anyone has installed it?

I use Rc1.

Installed. No problem at all

1 Like

Because the AX3600 got discounted heavily and now costs almost the same as AX3200.