Attempting custom build for TP-LINK WA801N v6

I bought a TP-LINK WA801N(EU) (expecting v5) with the intention of using as a wifi bridge with 2 SSID/VLANs on the broadcast side.

Figured if the factory software won't do it, I can always install openWRT.
Unfortunately the factory only allows multiple VLAN or bridge mode and it's an unsupported v6.

I've already made the mistake of bricking and recovering as per Bricked WA801N v6
Looked into Openwrt 18.06(Snapshot) custom builds for TP-LINK WR740N(D), WA801N(D) ....
I'm aware of Warning about 4/32 devices.
Have read through Building a smaller kernel for a specific device.

I do have serial access, factory image output is:

[04080C0B][04080C0C][8A890000][26263B3A][00262639]
DU Setting Cal Done


U-Boot 1.1.3 (Jan 16 2020 - 17:03:08)

Board: Ralink APSoC DRAM:  32 MB
relocate_code Pointer at: 81fc0000
fl¡ +¹U™…š,WÉVJ:1, Ù¥ª)J‘ l0 6
Wann -cos¹é•‘ Œ¡ÁDpa patebotodeHš================OêOOOOORRi UšÑVrson 43.0(-K©ª----------K©ª--K©*----------KRS768_M (or<o)DRM cmpnn 5Mt DD,with6R s: 6 itTler:32 Btesla.œÁœ•¹:SI Fah
AD$ѕ)'"… 6 00  m100
========O===O==========O==
icahe st51&	ºÍ:	b¥•é3 ot':š’Rdcch:ss56	º…Í4 lies:3&b¢…:&ºR ###T•)AU%2ÉÅ= 80MZ €J#
esimtemeo z= byts
RSETj62PA!!!!cntuota.W˝
šåѕ
Rdsaleswtcppo#.R  3 Ssmo sNѕcod ia ±Í¡.A100)
oooC:GT’b
‘É=0L‚‚R$œÑ¹iagab10 ..  Unc«-ÉÍ¥*
Z•É•± $µ• É	þK
o nirdFš¡€$TE…(k™Éɹ ŒœÑ± œ ¥á(a adre 01)..
## ivngb¥¹Uá •Íé• €¹M,32(
AhE…(.Wkerel..
AHPøLU tate...TSSASC
Linux version 2.6.36 (jenkins@mobile-System) (gcc version 4.6.3 (Buildroot 2012.11.1) ) #1 Thu Jan 16 17:05:12 CST 2020

 The CPU feqenuce set to 575 MHz

 MIPS CPU sleep mode enabled.
CPU revision is: 00019655 (MIPS 24Kc)
Software DMA cache coherency
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: console=ttyS1,115200 root=/dev/mtdblock2 rootfstype=squashfs init=/sbin/init
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 64kB, VIPT, , 4-waylinesize 32 bytes.
Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
Writing ErrCtl register=0004ef79
Readback ErrCtl register=0004ef79
Memory: 29236k/32768k available (2176k kernel code, 3532k reserved, 579k data, 156k init, 0k highmem)
NR_IRQS:128
console [ttyS1] enabled
Calibrating delay loop... 386.04 BogoMIPS (lpj=772096)
pid_max: default: 4096 minimum: 301
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource Ralink Systick timer
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Ralink gpio driver initialized
i2cdrv_major = 218
Serial: 8250/16550 driver, 2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0x10000d00 (irq = 21) is a 16550A
serial8250: ttyS1 at MMIO 0x10000c00 (irq = 20) is a 16550A
brd: module loaded
flash manufacture id: 1c, device id 70 16
Warning: un-recognized chip ID, please update SPI driver!
EN25Q32B(1c 30161c30) (4096 Kbytes)
mtd .name = raspi, .size = 0x00400000 (4M) .erasesize = 0x00010000 (64K) .numeraseregions = 0
Creating 5 MTD partitions on "raspi":
0x000000000000-0x000000010000 : "boot"
0x000000010000-0x000000100000 : "kernel"
0x000000100000-0x0000003e0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
0x0000003e0000-0x0000003f0000 : "config"
0x0000003f0000-0x000000400000 : "radio"
Register flash device:flash0
PPP generic driver version 2.4.2
PPP MPPE Compression module registered
NET: Registered protocol family 24
Mirror/redirect action on
u32 classifier
    Actions configured
Netfilter messages via NETLINK v0.30.
nf_conntrack version 0.5.0 (456 buckets, 1824 max)
ip_tables: (C) 2000-2006 Netfilter Core Team, Type=Linux
TCP cubic registered
NET: Registered protocol family 10
ip6_tables: (C) 2000-2006 Netfilter Core Team
IPv6 over IPv4 tunneling driver
NET: Registered protocol family 17
Ebtables v2.0 registered
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 156k freed
starting pid 29, tty '': '/etc/init.d/rcS'
mount: mounting devpts on /dev/pts failed: No such device
rdm_major = 253
spiflash_ioctl_read, Read from 0x003ff100 length 0x6, ret 0, retlen 0x6
Read MAC from flash(  3ff100) 28-ffffff87-ffffffba-2d-ffffffc9-ffffffe0
GMAC1_MAC_ADRH -- : 0x00002887
GMAC1_MAC_ADRL -- : 0xba2dc9e0
Ralink APSoC Ethernet Driver Initilization. v3.1  256 rx/tx descriptors allocated, mtu = 1500!
NAPI enable, Tx Ring = 256, Rx Ring = 256
spiflash_ioctl_read, Read from 0x003ff100 length 0x6, ret 0, retlen 0x6
Read MAC from flash(  3ff100) 28-ffffff87-ffffffba-2d-ffffffc9-ffffffe0
GMAC1_MAC_ADRH -- : 0x00002887
GMAC1_MAC_ADRL -- : 0xba2dc9e0
PROC INIT OK!
add domain:tplinkap.net
add domain:tplinklogin.net
tp_domain init ok
Set: phy[0].reg[0] = 3900
Set: phy[1].reg[0] = 3900
Set: phy[2].reg[0] = 3900
Set: phy[3].reg[0] = 3900
Set: phy[4].reg[0] = 3900
Set: phy[0].reg[0] = 3300
Set: phy[1].reg[0] = 3300
Set: phy[2].reg[0] = 3300
Set: phy[3].reg[0] = 3300
Set: phy[4].reg[0] = 3300
resetMiiPortV over.
Set: phy[0].reg[4] = 01e1
Set: phy[0].reg[0] = 3300
Set: phy[1].reg[4] = 01e1
Set: phy[1].reg[0] = 3300
Set: phy[2].reg[4] = 01e1
Set: phy[2].reg[0] = 3300
Set: phy[3].reg[4] = 01e1
Set: phy[3].reg[0] = 3300
Set: phy[4].reg[4] = 01e1
Set: phy[4].reg[0] = 3300
turn off flow control over.
starting pid 74, tty '/dev/ttyS1': '/bin/sh'
~ # [ util_execSystem ] 141:  ipt_init cmd is "/var/tmp/dconf/rc.router"

[ dm_readFile ] 2061:  can not open xml file /var/tmp/pc/reduced_data_model.xml!, about to open file /etc/reduced_data_model.xml
spiflash_ioctl_read, Read from 0x003e0000 length 0x10000, ret 0, retlen 0x10000
spiflash_ioctl_read, Read from 0x003e0000 length 0xbdd0, ret 0, retlen 0xbdd0
spiflash_ioctl_read, Read from 0x003ff400 length 0x10, ret 0, retlen 0x10
[ util_execSystem ] 141:  cos_init cmd is "cp -pR /etc/web/EU/* /var/tmp/pc/web/"

===>Enter Multi-spiflash_ioctl_read, Read from 0x003ff100 length 0x6, ret 0, retlen 0x6
SSID mode
[ oal_sys_readMaspiflash_ioctl_read, Read from 0x003ff200 length 0x4, ret 0, retlen 0x4
cFlash ] 1934:  spiflash_ioctl_read, Read from 0x003ff300 length 0x4, ret 0, retlen 0x4
 3ff100 set flasspiflash_ioctl_read, Read from 0x003ff400 length 0x10, ret 0, retlen 0x10
h mac : 28:87:BAspiflash_ioctl_read, Read from 0x003ff500 length 0x29, ret 0, retlen 0x29
:2D:C9:E0.
spiflash_ioctl_read, Read from 0x003ff600 length 0x21, ret 0, retlen 0x21
spiflash_ioctl_read, Read from 0x003ff700 length 0x10, ret 0, retlen 0x10
spiflash_ioctl_read, Read from 0x003ff700 length 0x10, ret 0, retlen 0x10
spiflash_ioctl_read, Read from 0x00010000 length 0x1d0, ret 0, retlen 0x1d0
spiflash_ioctl_read, Read from 0x003ff100 length 0x6, ret 0, retlen 0x6
[ oal_sys_readMacFlash ] 1934:   3ff100 set flash mac : 28:87:BA:2D:C9:E0.
sendto: No such file or directory
pid 73 send 2001 error
[ util_execSystem ] 141:  oal_startDynDns cmd is "dyndns /var/tmp/dconf/dyndns.conf"

Get SNTP new config
[ util_execSystem ] 141:  oal_startNoipDns cmd is "noipdns /var/tmp/dconf/noipdns.conf"

[ util_execSystem ] 141:  oal_startCmxDns cmd is "cmxdns /var/tmp/dconf/cmxdns.conf"

ioctl: No such device
[ util_execSystem ] 141:  oal_br_addBridge cmd is "brctl addbr br0;brctl setfd br0 0;brctl stp br0 off"

[ util_execSystem ] 141:  oal_ipt_addLanRules cmd is "iptables -t filter -A INPUT -i br+ -j ACCEPT
"

[ rsl_initLanIpIntfObj ] 1025:  Smart DHCP, use 192.168.0.254/255.255.255.0 as default Static IP at initial stage!

[ util_execSystem ] 141:  oal_intf_setIntf cmd isRaeth v3.1 ( "ifconfig br0 1NAPI
92.168.0.254 net,SkbRecyclemask 255.255.255)
.0 up"

[ util
phy_tx_ring = 0x00c97000, tx_ring = 0xa0c97000
_execSystem ] 14
phy_rx_ring0 = 0x00c98000, rx_ring0 = 0xa0c98000
1:  oal_util_set[fe_sw_init:5357]rt305x_esw_init.
ProcLanAddr cmd is "echo "br0 4261456064," > /proc/net/conntract_LocalAddr"

[ util_execSystem ] 141:  oal_intf_enableIntf cmd is "ifconfig eth0 up"

disable switch phyport...
GMAC1_MAC_ADRH -- : 0x00002887
GMAC1_MAC_ADRL -- : 0xba2dc9e0
RT305x_ESW: Link Status Changed
[ util_execSystem ] 141:  rsl_initLanEthIntfObj cmd is "ifconfig eth0 up"

[ util_execSystem ] 141:  oal_br_addIntfIntoBridge cmd is "brctldevice eth0 entered promiscuous mode
 addif br0 eth0"br0: port 1(eth0) entering forwarding state


br0: port 1(eth0) entering forwarding state
[ util_execSystem ] 141:  oal_eth_setIGMPSnoopParam cmd is "for i in /sys/devices/virtual/net/*/bridge/multicast_snooping;do echo 1 > $i ; done"

[ util_execSystem ] 141:  rsl_initApIgmpSnoop cmd is "for i in /sys/devices/virtual/net/*/bridgespiflash_ioctl_read, Read from 0x003ff700 length 0x10, ret 0, retlen 0x10
/igmp_query_version; do echo 3 > $i; done"

[ util_execSystem ] 141:  oal_wlan_ra_setCountryRegion cmd is "cp /etc/SingleSKU_CE.dat /var/Wireless/RT2860AP/SingleSKU.dat"

[ util_execSystem ] 141:  oal_wlan_ra_setCountryRegion cmd is "iwpriv ra0 set CountryRegion=1"

ra0       no private ioctls.

[ util_execSystem ] 141:  oal_wlan_ra_updateSkuByIsoName cmd is "if [ -e /etc/SingleSKU_DE.dat ]; then cp /etc/SingleSKU_DE.dat /var/Wireless/RT2860AP/SingleSKU.dat; fi"

[ util_execSystem ] 141:  oal_wlan_ra_loadDriver cmd is "insmod /lib/modules/kmdir/kernel/drivers/net/wireless/mt_wifi_ap/mt_wifi.ko"



=== pAd = c082d000, size = 1509912 ===

<-- RTMPAllocTxRxRingMemory, Status=0, ErrorValue=0x
<-- RTMPAllocAdapterBlock, Status=0
RtmpChipOpsHook(492): Not support for HIF_MT yet!
mt7628_init()-->
mt7628_init(FW(8a00), HW(8a01), CHIPID(7628))
e2.bin mt7628_init(1156)::(2), pChipCap->fw_len(64560)
mt_bcn_buf_init(218): Not support for HIF_MT yet!
<--mt7628_init()
[ util_execSystem ] 141:  oal_wlan_ra_initWlan cmd is "ifconfig ra0 up"

TX_BCN DESC a0ea9000 size = 320
RX[0] DESC a0eab000 size = 2048
RX[1] DESC a0eb0000 size = 2048
RT_CfgSetApcliMacAddress : invalid mac setting 
cfg_mode=9
cfg_mode=9
wmode_band_equal(): Band Equal!
AndesSendCmdMsg: Could not send in band command due to diable fRTMP_ADAPTER_MCU_SEND_IN_BAND_CMD
APSDCapable[0]=0
APSDCapable[1]=0
APSDCapable[2]=0
APSDCapable[3]=0
APSDCapable[4]=0
APSDCapable[5]=0
APSDCapable[6]=0
APSDCapable[7]=0
APSDCapable[8]=0
APSDCapable[9]=0
APSDCapable[10]=0
APSDCapable[11]=0
APSDCapable[12]=0
APSDCapable[13]=0
APSDCapable[14]=0
APSDCapable[15]=0
default ApCliAPSDCapable[0]=0
Key1Str is Invalid key length(7) or Type(0)
Key1Str is Invalid key length(0) or Type(0)
Key1Str is Invalid key length(0) or Type(0)
Key1Str is Invalid key length(0) or Type(0)
Key2Str is Invalid key length(0) or Type(0)
Key2Str is Invalid key length(0) or Type(0)
Key2Str is Invalid key length(0) or Type(0)
Key2Str is Invalid key length(0) or Type(0)
Key3Str is Invalid key length(0) or Type(0)
Key3Str is Invalid key length(0) or Type(0)
Key3Str is Invalid key length(0) or Type(0)
Key3Str is Invalid key length(0) or Type(0)
Key4Str is Invalid key length(0) or Type(2142663635)
Key4Str is Invalid key length(0) or Type(0)
Key4Str is Invalid key length(0) or Type(0)
Key4Str is Invalid key length(0) or Type(0)
WscKeyASCII=8
WscKeyASCII=8
WscKeyASCII=8
WscKeyASCII=8
[RTMPReadParametersHook:297]wifi read profile faild.
load fw image from fw_header_image
AndesMTLoadFwMethod1(2263)::pChipCap->fw_len(64560)
FW Version:1
FW Build Date:20161213152835
CmdAddressLenReq:(ret = 0)
CmdFwStartReq: override = 1, address = 1048576
CmdStartDLRsp: WiFI FW Download Success
MtAsicDMASchedulerInit(): DMA Scheduler Mode=0(LMAC)
efuse_probe: efuse = 10000012
RtmpChipOpsEepromHook::e2p_type=0, inf_Type=4
RtmpEepromGetDefault::e2p_dafault=2
RtmpChipOpsEepromHook: E2P type(2), E2pAccessMode = 2, E2P default = 2
NVM is FLASH mode
1. Phy Mode = 14
exec!
spiflash_ioctl_read, Read from 0x003f0000 length 0x400, ret 0, retlen 0x400
eeFlashId = 0x7628!
Country Region from e2p = ffff
tssi_1_target_pwr_g_band = 36
2. Phy Mode = 14
3. Phy Mode = 14
NICInitPwrPinCfg(11): Not support for HIF_MT yet!
NICInitializeAsic(651): Not support rtmp_mac_sys_reset () for HIF_MT yet!
mt_mac_init()-->
MtAsicInitMac()-->
mt7628_init_mac_cr()-->
MtAsicSetMacMaxLen(1277): Set the Max RxPktLen=450!
<--mt_mac_init()
	WTBL Segment 1 info:
		MemBaseAddr/FID:0x28000/0
		EntrySize/Cnt:32/128
	WTBL Segment 2 info:
		MemBaseAddr/FID:0x40000/0
		EntrySize/Cnt:64/128
	WTBL Segment 3 info:
		MemBaseAddr/FID:0x42000/64
		EntrySize/Cnt:64/128
	WTBL Segment 4 info:
		MemBaseAddr/FID:0x44000/128
		EntrySize/Cnt:32/128
AntCfgInit(2952): Not support for HIF_MT yet!
MCS Set = ff ff 00 00 01
MtAsicSetChBusyStat(861): Not support for HIF_MT yet!
FW LOG: !!!! Pass, dont need recal (total fail[0])

FW LOG: !!!! Pass, dont need recal (total fail[0])

FW LOG: !!!! Pass, dont need recal (total fail[0])

FW LOG: RxDCOC Set DC Valid(8)(2)

CmdSlotTimeSet:(ret = 0)
[PMF]ap_pmf_init:: apidx=0, MFPC=0, MFPR=0, SHA256=0
[PMF]RTMPMakeRsnIeCap: RSNIE Capability MFPC=0, MFPR=0
[PMF]ap_pmf_init:: apidx=1, MFPC=0, MFPR=0, SHA256=0
[PMF]RTMPMakeRsnIeCap: RSNIE Capability MFPC=0, MFPR=0
[PMF]ap_pmf_init:: apidx=2, MFPC=0, MFPR=0, SHA256=0
[PMF]RTMPMakeRsnIeCap: RSNIE Capability MFPC=0, MFPR=0
[PMF]ap_pmf_init:: apidx=3, MFPC=0, MFPR=0, SHA256=0
[PMF]RTMPMakeRsnIeCap: RSNIE Capability MFPC=0, MFPR=0
MtAsicSetRalinkBurstMode(3156): Not support for HIF_MT yet!
MtAsicSetPiggyBack(796): Not support for HIF_MT yet!
reload DPD from flash , 0x9F = [c400] doReload bit7[0]
CmdLoadDPDDataFromFlash: Channel = 10, DoReload = 0
MtAsicSetTxPreamble(3135): Not support for HIF_MT yet!
MtAsicAddSharedKeyEntry(1344): Not support for HIF_MT yet!
MtAsicAddSharedKeyEntry(1344): Not support for HIF_MT yet!
MtAsicAddSharedKeyEntry(1344): Not support for HIF_MT yet!
MtAsicAddSharedKeyEntry(1344): Not support for HIF_MT yet!
MtAsicSetPreTbtt(): bss_idx=0, PreTBTT timeout = 0xf0
ap_ftkd> Initialize FT KDP Module...
Main bssid = 28:87:ba:2d:c9:e0
<==== rt28xx_init, Status=0
@@@ ed_monitor_exit : ===>
@@@ ed_monitor_exit : <===
mt7628_set_ed_cca: TURN OFF EDCCA  mac 0x10618 = 0xd7083f0f, EDCCA_Status=0
WiFi Startup Cost (ra0): 4.148s
[ util_execSystem ] 141:  oal_wlan_ra_initWlan cmd is "echo 1 > /proc/tplink/led_wlan_24G"

[ util_execSystem ] 141:  oal_wlan_ra_setStaNum cmd is "iwpriv ra0 set MaxStaNum=32"

[ util_execSystem ] 141:  oal_wlan_ra_apVlanBridgeModulefini cmd is "rmmod br_MultiSsidVlan_InputForward.ko"

rmmod: can't unload 'br_MultiSsidVlan_Inpudevice ra0 entered promiscuous mode
tForward': unknobr0: port 2(ra0) entering forwarding state
wn symbol in modbr0: port 2(ra0) entering forwarding state
ule, or unknown parameter
[ util_execSystem ] 141:  oal_wlan_ra_apVlanBridgeModdevice apcli0 entered promiscuous mode
ulefini cmd is "rmmod br_MultiSsidVlan_PassUpToRouter.ko"

rmmod: can't unload 'br_MultiSsidVlan_PassUpToRouter': unknown symbol in module, ordevice ra1 entered promiscuous mode
 unknown parameter
[ util_execSystem ] 141:  oal_br_addIntfIntoBridge cmd is "bdevice ra2 entered promiscuous mode
rctl addif br0 ra0"

[ util_execSystem ] 141:  oal_br_addIntfIntoBridge cmd isdevice ra3 entered promiscuous mode
 "brctl addif br0 apcli0"

[ util_execSystem ] 141:  oal_br_addIntfIntoBridge spiflash_ioctl_read, Read from 0x003f0000 length 0x2, ret 0, retlen 0x2
cmd is "brctl addif br0 ra0"

brctl: bridge br0: Device or resource busy
[ util_execSystem ] 141:  oal_br_addIntfIntoBridge cmd is "brctl addif br0 ra1"

[ util_execSystem ] 141:  oal_br_addIntfIntoBridge cmd is "brctl addif br0 ra2"

[ util_execSystem ] 141:  oal_br_addIntfIntoBridge cmd is "brctl addif br0 ra3"

[ util_execSystem ] 141:  oal_wlan_ra_initEnd cmd is "wlNetlinkTool &"

[ util_execSystem ] 141:  oal_wlan_ra_initEnd cmd is "killall -q wscd"

WLAN-Start wlNetlinkTool
[ util_execSystem ] 141:  oal_wlan_ra_initEnd cmd is "wscd -i ra0 -m 1 -w /var/tmp/wsc_upnp/ &"

Waiting for Wireless Events from interfaces...
swWlanChkAhbErr: netlink to do
[ util_execSystem ] 141:  rsl_initLanWlanObj cmd is "echo 4 > /proc/tplink/wl_mode"

spiflash_ioctl_read, Read from 0x003ff700 length 0x10, ret 0, retlen 0x10
[ oal_wlan_ra_loadDriver ] 2103:  no 5G chip.


[ rsl_initLanWlanObj ] 9424:  perror:1
wscd: SSDP UDP PORT = 1900
sendto: No such file or directory
pid 73 send 2030 error
sendto: No such file or directory
pid 73 send 2004 error
[ util_execSystem ] 141:  oal_startDhcps cmd is "dhcpd /var/tmp/dconf/udhcpd.conf"

[ util_execSystem ] 141:  oal_startSnmp cmd is "snmpd -f /var/tmp/dconf/snmpd.conf"

iptables: Bad rule (does a matching rule exist in that chain?).
[ rsl_initAppObj ] 1035:  ===>Smart DHCP, use 192.168.0.254/255.255.255.0 as default Static IP at initial stage!

[ rsl_initAppObj ] 1052:  lanCfgObj.IPRouters 192.168.0.254, lanCfgObj.X_TP_RemoteDns 192.168.0.254,0.0.0.0, lanCfgObj.DNSServers 192.168.0.254,0.0.0.0, lanCfgObj.minAddress 192.168.0.100, lanCfgObj.maxAddress 192.168.0.199.

[ rsl_initAppObj ] 1065:  ==> start dhcp client

iptables: Bad rule (does a matching rule exist in that chain?).
iptables: Bad rule (does a matching rule exist in that chain?).
[ util_execSystem ] 141:  oal_rip_updateConfig cmd is "rm -f /var/tmp/dconf/zebra.conf"

[ util_execSystem ] 141:  oal_rip_updateConfig cmd is "rm -f /var/tmp/dconf/ripd.conf"

[ util_execSystem ] 141:  removeAllRIPIpTableRule cmd is "iptables -L INPUT -v --line-numbers > /var/iptable"

[ getPidFromPidFile ] 112:  Cann't open file: /var/run/zebra.pid.
[ util_execSystem ] 141:  controlRipProcess cmd is "zebra -d -f /var/tmp/dconf/zebra.conf"

[ getPidFromPidFile ] 112:  Cann't open file: /var/run/ripd.pid.
[ util_execSystem ] 141:  oal_ipt_fwDdos cmd is "iptables -D FORWARD -j FIREWALL_DDOS
"

iptables: No chain/target/match by that name.
[ util_execSystem ] 141:  oal_ipt_forbidLanPing cmd is "iptables -t filter -D INPUT -i br+ -p icmp --icmp-type echo-request -j DROP
iptables -t filter -D FORWARD -i br+ -p icmp --icmp-type echo-request -j DROP
"

iptables: Bad rule (does a matching rule exist in that chain?).
iptables: Bad rule (does a matching rule exist in that chain?).
[ util_execSystem ] 141:  oal_ddos_delPingRule cmd is "iptables -t filter -D INPUT ! -i br+ -p icmp --icmp-type echo-request -j ACCEPT
"

iptables: Bad rule (does a matching rule exist in that chain?).
[ util_execSystem ] 141:  oal_ipt_setDDoSRules cmd is "iptables -F FIREWALL_DDOS"

[ util_execSystem ] 141:  ddos_clearAll cmd is "rm -f /var/tmp/dosHost"

sh: diagTool: not found
[ util_execSystem ] 141:  oal_initFirewallObj cmd is "ebtables -N FIREWALL"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/netfilter/nf_conntrack_ftp.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_ftp.ko"

[ util_execSystem ] 141:  oal_openAlg cmd is "iptables -D FORWARD_VPN_PASSTHROUGH  -p udp --dport 500 -j DROP"

iptables: Bad rule (does a matching rule exist in that chain?).
[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_proto_gre.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_pptp.ko"

[ util_execSystem ] 141:  oal_openAlg cmd is "iptables -D FORWARD_VPN_PASSTHROUGH  -p tcp --dport 1723 -j DROP"

iptables: Bad rule (does a matching rule exist in that chain?).
[ util_execSystem ] 141:  oal_openAlg cmd is "iptables -D FORWARD_VPN_PASSTHROUGH  -p udp --dport 1701 -j DROP"

iptables: Bad rule (does a matching rule exist in that chain?).
[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/netfilter/nf_conntrack_tftp.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_tftp.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/netfilter/nf_conntrack_h323.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_h323.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/netfilter/nf_conntrack_sip.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_sip.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/netfilter/nf_conntrack_rtsp.ko"

[ util_execSystem ] 141:  setupModules cmd is "insmod /lib/modules/kmdir/kernel/net/ipv4/netfilter/nf_nat_rtsp.ko"

nf_nat_rtsp v0.6.21 loading
[ util_execSystem ] 141:  rsl_initPingWatchDogObj cmd is "pwdog &"

enable switch phyport...
Set: phy[0].reg[0] = 3900
Set: phy[1].reg[0] = 3900
Set: phy[2].reg[0] = 3900
Set: phy[3].reg[0] = 3900
Set: phy[4].reg[0] = 3900
Set: phy[0].reg[0] = 3300
Set: phy[1].reg[0] = 3300
Set: phy[2].reg[0] = 3300
Set: phy[3].reg[0] = 3300
Set: phy[4].reg[0] = 3300
resetMiiPortV over.
Set: phy[0].reg[4] = 01e1
Set: phy[0].reg[0] = 3300
Set: phy[1].reg[4] = 01e1
Set: phy[1].reg[0] = 3300
Set: phy[2].reg[4] = 01e1
Set: phy[2].reg[0] = 3300
Set: phy[3].reg[4] = 01e1
Set: phy[3].reg[0] = 3300
Set: phy[4].reg[4] = 01e1
[cmd_dutInit():1083] init shm
[tddp_taskEntry():151] tddp task start
Set: phy[4].reg[0] = 3300
turn off flow control over.
Started WatchDog Timer.
Ralink APSoC Hardware Watchdog Timer
[ read_dhcpc_config ] 113: error, unable to open config file: /var/tmp/dconf/udhcpc.conf
start ntp_request
[ oal_sys_getOldTZInfo ] 592:  Open TZ file error!
[ util_execSystem ] 141:  oal_sys_unsetTZ cmd is "echo "" > /etc/TZ"

[ ntp_start ] 504:  ntp connect failed, return.

[ util_execSystem ] 141:  oal_sys_unsetTZ cmd is "echo "" > /etc/TZ"

Hence am left with my final option to compile an image myself for the device.

All I really need in the build are:

  • working wifi (bridge and multiple SSID)
  • vlan
  • 18.06 or newer
  • luci - would be nice but not vital

I probably can manage to download the source and compile, and am able to upload using TFTP (or serial if that's easier).

Where I'm struggling is ensuring correct config for image and how to allow for the 64kB bootloader.
I wouldn't know where to get started.
Am happy to do trial and error, if I knew where to start

With 4/32, you are below minimum system requirements, which means you need to reconsider really hard if it's worth the effort.