Ath79 target status


#1

Hi all
I see that there is a lot of work going on the dts based ath79 target. I see also that several devices have been added to the target family but there is no images available in the snapshot images list.
I have an Archer C7 and WDR3600, I can give it a try self-compiling the image, but I am not sure of what is expected to be functional on this routers
Bye


Ar71xx vs ath79
#2

TL-WDR3600/ TL-WDR4300 and Archer C7v2 (so far only v2) should be almost fully supported by ath79 (I can attest that for the first two), however that's not yet true for all other devices included in ath79 (e.g. Netgear WNDR3800 (that should be fixed soon) and TP-Link TL-WR1043NDv1 (which seems to be more problematic)).

Edit: TP-Link TL-WR1043NDv1 has now been fixed in master.


#3

The ath79 target is working very good on all my current ported targets.
WDR3600/4300, WR1043v2-v4

As i know, there is only one issue on all ath79 devices...
If you change the ip of a interface (luci, uci or config files) and do only a /etc/init.d/reload the network interface does not work anymore, but if you do a /etc/init.d/restart all went fine.

Luci does always only a reload!


#4

Ok thanks. Is there a specific reason why the target is not included in the build bot?


#5

Because it's explicitly marked as source-only for now, after all it's very new and still has known issues (not for all devices); that's likely to change soon, but no one wants to brick devices knowingly.


#6

Ok, it makes sense, thanks, I didn't know that some targets can be marked as source only. Last question for now: on the WDR3600 I have (even a little bit old, but I can update it) the modified uboot that allow a simple recovery if a non-functional image is loaded. Do you know if exist something similar for the Archer C7 v2? Or a booloader recovery mode that works for sure? I am asking it because I saw a still pending PR that fix the ethernet port of the Archer C7, meaning that if I load a recent image for it I would loose the ethernet port and I need to hope to have a wifi up and running to recover


#7

That probably depends on the last OEM firmware version you installed, at least for the TP-Link TL-WR1043NDv1 and TL-WDR3600/ TL-WDR4300 tftp push-button functionality was only retrofitted with OEM firmware versions released since ~2013, but not present in the initial v1.0 hardware.


#8

Talking about TL-WDR3600, I tried to change the IP address from luci after flashing the official 18.06 release, read: not ath79 target one, and still fail to connect after the IP change. However, IP change is successful if I update/etc/config/network directly and /etc/init.d/network restart.

I have some doubt on whether the problem is specific to ath79 target or not.


#9

This posting is "wiki", i.e. everybody can edit it and add a new device status.

Status: working / not working / WIP / not started / ...

Device ath79 Status
Buffalo BHR-4GRV working
Buffalo BHR-4GRV2 working
Buffalo WHR-G301N working
Buffalo WZR-HP-AG300H working
Buffalo WZR-HP-G300NH/G301NH WIP (jffs2 issue, no GPIO chip driver)
Buffalo WZR-HP-G302H Rev.A1A0 working
Buffalo WZR-HP-G450H working
ELECOM WRC-300GHBK2-I working
ELECOM WRC-1750GHBK2-I/C WIP
GL.iNet GL-AR750S "Slate" under consideration
spi-nor only: WIP
I-O DATA ETG3-R working
I-O DATA WN-AG300DGR working
I-O DATA WN-AC1167DGR working
I-O DATA WN-AC1600DGR WIP
I-O DATA WN-AC1600DGR2 working
Linksys E2100L WIP in the ath79 porting thread
NEC WG800HP PR
Netgear WNDR3700 v1 working, "sysupgrade -F" works both ways
Netgear WNDR3700 v2 working, "sysupgrade -F" works both ways
Netgear WNDR3800 working, "sysupgrade -F" works both ways
PowerCloud Systems CAP324 WIP (migration not ready but new installs work fine)
PowerCloud Systems CR5000 WIP (ath79 5Ghz wifi not working; no migration)
TP-Link Archer C7 v2 working
TP-Link TL-WDR3600 working
TP-Link TL-WDR4300 working
TP-Link TL-WR741ND v1 working
TP-Link TL-WR841N/ND v8 WIP, working but PR still needs merge
TP-Link TL-WR941ND v2/ v3 working
TP-Link TL-WR1043ND v1 working
TP-Link TL-WR1043ND v2 working
TP-Link TL-WR1043ND v3 working
TP-Link TL-WR1043ND v4 working
TP-Link TL-WR2543ND v1 working

Porting guide ar71xx to ath79?
#10

This happens also if you don't use luci and use reload instead of restart for network.
Please try if reload works on ar71xc.


#11

Just tried network reload on ar71xx build, and I am able to connect back to the router web UI and ssh.

However, just noticed that I've turned off the 'Force link' option on the lan interface, will retry with that turned back on as default later...


#12

It is not ath79 specific. Affects all targets (at least on 18.06.0rc2), I have ar7xxx, sunxi and kirkwood targets, all with the same issue


#13

I have added TP-Link TL-WR741ND v1. It is fine but network restart is not working and during upgrade the configuration was reset to default.


#14

USB seems to be a bit broken on WRT3600 at least.... (speed-wise)


#15

Please add Netgear R6100 (nearly same as WNDR4300 but have little difference) to WIP list.


#16

Hello
I have a couple of TP-LINK TL-WRD841ND V8 that currently are not supported by ath79 due to lack of DTS (if it is only dts).
They should not be so different compared with V7, I can try to work on it, if anyone can give me guidance of what to check from old mach C files
Bye

--edit--
Well actually not so simple, it is the only one quite special since use AR9341
--edit2--
According to the inspection it is very similar to tl842n-v2 that is supported, except for the lack of USB
Last thing I miss is the partition layout: how can I check it in the old ar71xx target?


#17

Well, it seems to be quite straightforward, got partition layout from dmesg output of ar71xx image.
I am building an image for a test, only one check left the clock frequency for 842n-v2 is set to:

clock-frequency = <25000000>;

How can I check if it is the same for 841n-v8? it shoule be, since normally they always use the same crystal for the same SoC type
Also, the ram size is handover by Uboot, right?


#18

TL-WR841ND V8 has 4 MB of flash and WR842ND - 8 MB. That is the major difference.


#19

Of course it has been taken in account in flash layout
I have built the image, anyhow I found only: openwrt-ath79-tiny-tplink_tl-wr841-v8-initramfs-kernel.bin
I would have expected a factory and sysupgrade (it is a tiny target)


#20

Hello,
Tried TL-WR703N and had also problems changing the LAN interface via luci
( /etc/init.d/network restart worked ).
It also works on ar7xxx.
Is there any solution?

Robert