Asus TUF Gaming AX6000 support

@deeddy
please use image for sysupgrade using console and paste here log from sysupgrade output with option -v ( verbose ).

1 Like

root@OpenWrt:/tmp# sysupgrade -v openwrt-mediatek-filogic-asus_tuf-ax6000-squash
fs-sysupgrade.bin
verifying sysupgrade tar file integrity
Cannot save config while running from ramdisk.
Mon Nov 6 19:01:49 UTC 2023 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed


Then the connection disconnect, the router reboots, and I'm back to initramfs after the reboot.

normaly. but not in my case. i'm always back to initramfs.
i tried any version possible, and nothing is working.

So have we that same problem like with the squash image from https://drive.google.com/drive/folders/1grGOrKlW9lb7VlTQSFaCNcOkhnIT89zi ( include @remittor changes, build by me )?
@deeddy: please look at the priv.

btw. WED is unstable on both routers ( ax4200 and ax6000 ). I'll collect logs from ax6000 soon.

This is where I'm stuck after every reboot. :slight_smile:

Try install stock trx-image TUF-AX6000 via LuCI (use -F option)

ok just for information snapshot has not luci if you flash

if you are not access maybe is not

please

opkg update && opkg install luci 

in putty ssh port 22

1 Like

opkg update && opkg install luci luci-ssl

1 Like

You Can follownthis guide

Then you're Luci interface appair

So, this is the outcome. We spent a few hours with @patrykk trying to fix my new router. The problem was with the free space trx image. It was making some not so well UBI partitions, so the router ran out of space and it was not possible to update it to any new firmware, so I ended up stuck in initramfs.

What I did is I set up the serial console (no need to open the box) and with @patrykk 's help managed to repartition filesystem and properly sysupdate to squashfs bin. Now I'm on the latest official snapshot from the OpenWRT Firmware Selector website. :slight_smile:

@patrykk will most likely update you here with the latest changes he is about to implement soon. Thank you so much! I really appreciate all your help! :slight_smile:

4 Likes

how did u setup network?

Yes good news :ok_hand:

Did these instructions not work?

unzip ......
dd if=/tmp/fw.trx bs=64 skip=1 of=/tmp/fw.fit
ubirmvol /dev/ubi0 -N rootfs
ubirmvol /dev/ubi0 -N rootfs_data
ubirmvol /dev/ubi0 -N jffs2
ubirmvol /dev/ubi0 -N linux
ubimkvol /dev/ubi0 -N linux -s 0x45fe000
volnum=$( ubinfo -d 0 -N linux | awk 'NR==1 {print $3}' )
ubiupdatevol /dev/ubi0_$volnum /tmp/fw.fit

Please don't use trx image on the ax6000. You will stuck with trx image and you will need to change partitions manually.

1 Like

So what was the matter? How did you fix the volumes?

Download packages luci and luci-ssl, upload them manually to the router and install them using opkg.

LAN should be working by default.

We tried something similar by deleting the partitions and replicating the correct ones, but since it didn't work, eventually I had to use the serial cable. It was really easy to access the pins without opening the router plastic case:

  1. I used a USB-to-TTL adapter, a small cable and 3 separate golden pins that were part of a pin header (I had to remove the plastic). Had to used a duct tape to make them not fall out from the cable.
  2. Then stuck pins into the pin holes onto the PCB, each one under different angle (so they don't touch each other). Took me literally 2 minutes to do that without opening the box.
  3. Then I followed @patrykk's instructions and installed initramfs and sysupgrade within 2 more minutes. It was really that easy. Reboots took longer than the upgrade. :slight_smile:

Pay attention that TX goes to RX, and the other way around. Do NOT use VCC (voltage) pins by any means, otherwise you might fry the board!

The problem with that free space initramfs trx was that it left no empty space for sysupgrade.bin to get uploaded.

I wonder, will it work to use @patrykk's initramfs (the original one, with not much space left) and encode it with @remittor's trx encoder (that .exe file). Any thoughts on that?
I would have tried that myself, but I was not possible to revert back to the original ROM (most likely a different file system layout).

Anyway, as long as you have a PC, a serial port (a usb-to-ttl adapter) and the router's bootloader is working, you can restore your router no matter what.

Oh, and do NOT touch Nand, Factory and Factory2 partitions by any means! I think factory partitions contain wifi calibration individual to each router (to each single piece).

Looks like TUF-AX6000 router has the same data twice (double partitions with the same size and similar names: Factory vs Factory2, linux vs linux2), and I would assume it is a dual-firmware device, like 2 different ROMs could be saved at the same time. If yes, there should be some NAND variable that switches what ROM is in use. Probably the same with TUF-AX4200.

Any opinion? @patrykk @remittor @Dopam-IT_1987

I still don’t understand what the installer was complaining about and how you managed to overcome it.

This device does not have the problem you described.