Asus TUF Gaming AX6000 support

It is not at all necessary to search for dts-file.
Just look at the header of the trx image. Both routers have the product name: "TUF-AX6000"

1 Like

And there we go, ASUS TUF-AX6000 finally showed up in OpenWrt Firmware Selector under Snapshots. :slightly_smiling_face:

Thank you @patrykk and @remittor for all the hard work! :innocent:

2 Likes

@patrykk I finally got ASUS TUF-AX6000 router today. Managed to successfully install openwrt-mediatek-filogic-asus_tuf-ax6000-initramfs.trx
Restarted the router, and after installing luci from ssh, tried to upgrade the firmware to openwrt-mediatek-filogic-asus_tuf-ax6000-squashfs-sysupgrade.bin
The update finished, the restart went fine, but I was back at the initramfs (instead of the sysupgrade image).

Whatever I was doing, it didn't move past the initial trx initramfs. Not sure what am I supposed to do at this point. FYI, I was not going thru serial, but thru original Asus upgrade, using the trx file provided by you (and @remittor).

I also tried updating to openwrt-mediatek-filogic-asus_tuf-ax6000-initramfs-kernel.bin, but the update (from trx-initramfs) reported that the firmware is incorrect.

Any advice what to do at this point?

In addition to the mentioned problem, I had to change the LAN IP, after the reboot the old IP came back. OPKG UPDATE is not possible because it shows me an error: Failed to send request: Operation not permitted

Have you installed OpenWRT using image which include @remittor changes or used serial console and official image?

You have this error when network is not configured. Please configure you network and change it in the /etc/config/ ....

Please describe always which build, which version and method have you used to update/flash

@patrykk I have NOT used serial. I used Asus web interface to upload the trx file (that should be firmware with @remittor 's changes).

Now, I'm stuck in trx initramfs. I guess I should be able to revert back to Asus stock firmware, but trying to move to OpenWRT sysupgrade.

Not all of my changes are present in the trx-image @patrykk created.

It's too bad that @patrykk didn't add LuCI and mtd/ubi utilities to his trx-image!

Could you supply information which change should be add to the my repo ?

Another problem: Now I'm NOT able to flash back to Asus stock thru Luci (and using sysupgrade from shell). :frowning: I guess at this point it's only serial that can help.

Also, Asus Rescue (TFTP) doesn't work (unless I'm missing something). I set up IP's correctly, and kept holding reset while turning on the router, but nothing happens. Rescue can not connect.

I've checked it now. You made all my changes. Besides adding LuCI.

I managed to add Luci using, since my network was already preconfigured on Asus stock firmware:
opkg update; opkg install luci luci-ssl

@remittor I'm not possible to update/upgrade to any other image (using Luci/sysupgrade), both sysupgrade or trx, or the original stock firmware (trx). Any suggestion what to do without a serial port?

My router AX4200 has exactly the same problem. And I don't know what caused this.

rescu mode working only if you connect router over LAN port.... not WAN port

Revert to stock:

wget -O /tmp/fw.zip https://dlcdnets.asus.com/pub/ASUS/wireless/TUF-AX6000/FW_TUF_AX6000_300438832432.zip
unzip ......
dd if=/tmp/fw.trx bs=64 skip=1 of=/tmp/fw.fit
ubirmvol /dev/ubi0 -N rootfs
ubirmvol /dev/ubi0 -N rootfs_data
ubirmvol /dev/ubi0 -N jffs2
ubirmvol /dev/ubi0 -N linux
ubimkvol /dev/ubi0 -N linux -s 0x45fe000
volnum=$( ubinfo -d 0 -N linux | awk 'NR==1 {print $3}' )
ubiupdatevol /dev/ubi0_$volnum /tmp/fw.fit

(I don't know how to unpack the zip archive)

2 Likes

what's problem i don't understands for to return to firwmare stock ?

@whitedd Iā€™m connected to LAN port 1.

Any specific IP we need to set up? The tutorial on the website mentions 192.168.1.10, but looks like a generic tutorial, rather than one for this router specifically.

https://www.asus.com/support/FAQ/1000814/

I remember somebody mentioned 192.168.1.70 in TUF-AX4200 thread.

for my ax4200 similar to ax6000 i has not changed ip just connect to lan 1 for flash to luci the first time and then after rescue mode direclty reflash with sysupgrade

i has do'nt try to revert to asus stock

@Dopam-IT_1987 Did you use trx sysupgrade?

Iā€™m unable to move to anything else after uploading (freespace) initramfs trx file from Asus stock.

yes i has use the file then my own build wait i take a picture for you