Asus TUF Gaming AX6000 support

I have an SSD connected and I get around 20 MB/s in R/W using samba or ksmbd.
Any suggestion on how to improve transfer speeds?
What kind of performance are you getting by sharing a usb disk?

1 Like

Hi, I use NFSd ( nfs-kernel-server ). Transfers around 120-130MB/s Up and down.

1 Like

Is this in Windows?

Hi there. Perhaps this is not an example of the most technically advanced issue, but I am hoping to help someone who had the same problem as I did. Currently upgrading my network for 2.5Gbps throughput. Planned topology ONT--> Router --> Dumb Wireless AP --> Hosts. The ASUS AX6000 is a great candidate for the wireless DUMBAP with two 2.5Gbps capable ports and great Wi-Fi coverage. The problem was that the default OpenWRT configuration had the WAN port assigned to WAN, when I needed two 2.5Gbps LAN ports for my topology to work (the Asus device then acts more like a glorified wireless switch). What I did was to delete the WAN interfaces (since the main router provides the WAN interface anyway) and reassigned the WAN(eth1) port to the br-lan devices. To add it, I used the Luci GUI --> Network --> Interfaces --> Devices --> configure br-lan and then just added the WAN(eth1) port to the bridge interface. Pictures for added clarity.


As far as I understand, the TUF AX6000 device page ( claims that the device only supported in snapshot. But there is firmware available for it in stable release 23.05.3 ( Could you please clarify - is it safe to use this stable 23.05.3 firmware?

Hello. The device page doesn't get updated as frequently as things change. Stable release (23.05.3) is indeed ready.

1 Like

After a reboot my cover led is now back red/orange. Any idea what it means? what color is your cover led?

Great that you have mentioned that. Since the default WAN port is 2.5GbE, I did a change, and now using both 2.5GbE ports as LAN ports. Reassigned the WAN port to be used as LAN, and now the desktop is connected to the NAS using 2.5Gbps LAN. The fiber connection is 1Gbps anyway, so it was moved to a gigabit port.

It was an easy task to do in luci. The only thing not to forget is using the correct MAC address for the new WAN port, in case your fiber is in bridge mode (using ONT), as WAN port MAC address is usually used for authentication by ISPs.

1 Like

I think the colors change with a new reboot (or with a new upgrade). No specific meaning in what color is currently active. Somebody, please correct me if I was wrong.

I have a brand new never used TUF Gaming AX6000 and says:

Main changes between OpenWrt 23.05.2 and OpenWrt 23.05.3
Device support
Support for the following devices was added:
mediatek: ASUS TUF AX6000

So my question is how do I flash openwrt with 25.03.3?

As mentioned below?

There is a dowloand link:

Is this the correct one for 23.05.3?

Are there any checksums. Are mine ok, if this download would be ok for 23.05.3?

$ sha256sum 
$ sha256sum openwrt-23_tuf-ax6000-initramfs.trx
4a24d4de6b9ddb22245ae8aa6df213cff055d372f27955208112429d2244bb32  openwrt-23_tuf-ax6000-initramfs.trx

Do I have to register with Asus first before I flash? With the Asus RT-AX53U it was a nightmare to flash, could not do it without registering at Asus und doing the latest Asus fw update.

Is an example for the pc or a must? I use normally to connect from the pc.

I have to thank you!
After activating packet steering, I went from 900 Mbps download to 1800 Mbps!
I was slightly dissatisfied with the performance, now I can't say that anymore!




That's right, things are more complicated there. I don't want to do a TRX image for AX53U yet.

This was an example. You can use

1 Like

This router is really amazing, I have no inventice to promote it but, the WiFi and SQM performance is nothing I have seen before from a standalone router:

Firmware: 23.05.3
Macbook Pro M1 2021,
5 Ghz settings. Channel 149 80mhz
AQT TX Limits: 1000
SQM: Cake, Piece of Cake, Overhead 18 and RTT 50. 650 Up 250 Down
Distance to router 50ft with a wall between
Internet: 1 Gig Fios Fiber


Maybe my question was not exact enough. I meant that an internet connection to Asus is not necessary. I was in a circle like with AX53U.

I set the PC to DHCP, Asus has the iP-Adresse at 192.168.50.x, got .1

I post some screenshots

Since I could not leave this circle, I connected an etherned cable to the wan port and now it was pretty easy. I allowed an Asus FW update.

Now we are going to flash openwrt-23_tuf-ax6000-initramfs.trx

Note the text at the bottom with "manual firmware update" and the link beside.

Now I had no idea how to reboot, but it worked to switch off the router.

I switched the PC to

$ ssh root@

OpenWrt 23.05.2, r23630-842932a63d, 231213

Looks fine. Note: I am using Linux, with Windows you have to use an option with scp, which I don't remember.

$ scp asus-ax6000/openwrt-23.05.3-mediatek-filogic-asus_tuf-ax6000-squashfs-sysupgrade.bin root@

Don't forget to compare the checksums! Had it a few times, that they were not the same!

root@OpenWrt:~# sha256sum /tmp/openwrt-23.05.3-mediatek-filogic-asus_tuf-ax6000-
60130651305de8ad4e241d998242c475a7b9e68503b90667b8b396126b0a55e2  /tmp/openwrt-23.05.3-mediatek-filogic-asus_tuf-ax6000-squashfs-sysupgrade.bin
root@OpenWrt:~# sysupgrade -n /tmp/openwrt-23.05.3-mediatek-filogic-asus_tuf-ax6
verifying sysupgrade tar file integrity
Sun Apr  7 18:38:14 UTC 2024 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed
root@OpenWrt:~# Connection to closed by remote host.
Connection to closed.

Looks fine now:

root@OpenWrt:~# ubus call system board
	"kernel": "5.15.150",
	"hostname": "OpenWrt",
	"system": "ARMv8 Processor rev 4",
	"model": "ASUS TUF-AX6000",
	"board_name": "asus,tuf-ax6000",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "mediatek/filogic",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"

What does the red light on top of the case mean?

This is all unnecessary!
You can simply install the sysupgrade image via the web interface.
Even in this case the checksum will be checked!

1 Like

I am generally speaking, I am new with the AX6000. It depends on the router model and with a new model you never know. The checksum can depend on the operating system and on the browser. Was really crazy for me, when I noticed this.

Learned this in this discussion:Broken Upload with Chromium? - #2 by slh with a D-Link DAP-X1860 A1.

Does this work with firmware buitlt by firmware-selector too?

Latest SNAPSHOT (r25876-923d7c5531) broke my internet connection. Luckily, I had a 2 week old snapshot file saved, that I manually uploaded and fixed it.

But again, there's a question of how compatible are current opkg packages with a few weeks old snapshots...

Maybe it's time to move on to the stable build 23.05.3 for this reason? Your thoughts?

Just installed stable build 23.05.3, and looks like like package 'fitblk' was removed from it, while looks like it should not. It is a block device driver that might mess with any subsequent sysupgrade on some devices.

Somebody please confirm is it needed for this device (ASUS TUF).