Asus TUF Gaming AX6000 support

Where you able to fix using the official snapchat images? I would probably install both official images but thats just me.

When trying to flash either of the bin files I mentioned on the previous pos, I'm getting the following warning:

Image check failed:

Tue Dec 12 13:48:51 UTC 2023 upgrade: Device asus,tuf-ax6000 not supported by this image Tue Dec 12 13:48:51 UTC 2023 upgrade: Supported devices: mediatek,mt7986a-rfb-snand invalid sysupgrade file Image check failed. 

Select 'Force upgrade' to flash the image even if the image format check fails. Use only if you are sure that the firmware is correct and meant for your device!

So, I'm waiting for confirmation these are the right images for the TUF-AX6000 before flashing and possibly making things worse.


You must use: openwrt-mediatek-filogic-asus_tuf-ax6000-squashfs-sysupgrade.bin (snapshot)


I did just noticed you were choosing the mt7986 vs the ax6000 file once @remittor posted the correct link.

Thanks for the direct link, for some reason I didn't notice the ax6000 image there and was looking at the soc instead.
I managed to flash the snapshot and am now running r24624-957a0921e2 with LuCI installed through the command-line.

Some things I noticed are different from remittor's image:

  • The main LED is red now even though the router seems to be working
  • The eth1 WAN port is labelled as 1 GbE on LuCI instead of 2.5 GbE
  • The lan5 port is labelled as -1 MbE (H) instead of 2.5 GbE

This might be due to the fact that the snapshot has very few packages installed and I'm missing something?
In any case, it seems to be working now. Hopefully it'll stay that way.
Thanks for the help



Would you recommend flashing from the trx files from your google drive or from the official 2 snapshots from the links you provided recently? Or it doesnt matter?


Sorry main led? You mean the led at the top of the router? This rgb puke led? :roll_eyes:

There was a bug in my build. I'll fix it now...


After remittor TRX image please install the official sysupgrade snapshot image for this router.

1 Like

Thank you! It can get confusing/scary for a newbie to see all these different links and trying to chose the correct links!!!

I've been running the December 12th snapshot for a bit now, and it seems to be working very well, with no major issues.

Yes, the big Asus Aura RGB LED on top of the cover, labeled as blue:cover on OpenWrt. The one that shows up blue, then slowly blinks yellow and finally turns blue during boot.
It seems like the color of said LED is stored somewhere on the hardware: during normal OpenWrt operation, it defaults to blue (the default color on the official firmware), it was set to green for be because I tried out the Aura controls on the Asus firmware for a bit before flashing OpenWrt, and now since I had issues and then flashed the latest OpenWrt snapshot, it's always red when OpenWrt is running (leading me to wrongly believe something was wrong after the upgrade).
At least I am able to turn it off, so that's fine enough for me.

Great, thanks for fixing this issue. I'll try it out when I can.


Since in the stock ROM I can change it to any color I want, it seems to be an addressable RGB LED. So in theory it could be set to any color you want when you want. Of course assuming we know how to control this LED.

If I set it to 'static' and then press 'Default' it shows a orange/yellow color. Reading the docs says something about an 'event' mode, but for some reason I only see; 'static', 'breathing', 'wave' and 'rainbow'. Which is pretty useless IMO. Hopefully in OpenWRT we can eventually make more use out of that. In the past week I just disabled this whole Aura RGB led.

1 Like

@patrykk How do we enable WED? I would like to test it.

1 Like

I updated also wiki page for router. Please find there much more new informations.


Do you know gpio numbers for rest of the RBG cover leds?

1 Like

Just curious if I read above correctly. So this router can do cake at 1 Gbps with around 40% max load?

On the Asus merlin firmware it also has cake. On there it would max out around 450 Mbps with cake. How is the data it can manage somehow being doubled and cpu load being halved with OpenWRT?

1 Like

I believe Merlin is only for Broadcom based devices. I did some googling and I can only find discussions about Asus GT-AX6000 in relation to Merlin. GT-AX6000 and TUF-AX6000 (the model discussed here) are 2 very different routers from Asus despite being of the same WiFi class AX6000. This one has Mediatek platform and can't be directly compared to one with Broadcom.


The point here is that people tested cake with SFO and should be tested without it, as sqm is not working correctly with sfo.

I saw a post from @slh from june informing that SFO should be working fine with sqm, but not sure about it.

You can easily test real performance configuring sqm with/without sfo, performing few tests and capturing tc -s qdisc data.

If you don't see data in the tins with sfo means, cake is not working correctly with sfo, which was like that from the beginning

Yeah Merlin seems to only be for Broadcom. I'm still perplexed how a 2Ghz CPU can struggle to do cake at 450 Mbps but another 2Ghz CPU (that is much cheaper btw) can somehow do DOUBLE that data rate and still not break a sweat.

1 Like

Thank you very much! Will WED work with SQM? @patrykk
I'm about to test it now.

More info about how to enable WED here:

1 Like