First of all the dumbAPs need to use the router as DNS.
But that is not enough as the dumbAPs are not involved in any communication with the hosts, so they don't build their arp table with the necessary data.
Some similar topics:
package network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdbc:465a:a93b::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth0 eth1'
option proto 'dhcp'
config switch
option name 'switch0'
option reset '1'
config interface 'lan6'
option proto 'dhcpv6'
option ifname '@lan'
option reqaddress 'try'
option reqprefix 'auto'
uci: Entry not foun…
To do a nslookup, it should know the address first. But since it is a dumbAP, it doesn't participate in the dhcp packet exchange in any other way but forwarding the frames. Therefore it doesn't know addresses unless there is some way of communication.
Check the packages arpwatch, addrwatch, and arp-scan. Maybe they can help in automatically adding new stations in the list correctly.
2 Likes