Wireless Associated Stations - Hostname not shown

I'm using the following setup:

  • Router o2 Box 6431 (Wi-Fi/VDSL-Modem/DHCP-/DNS-Server)
  • 2 TP-Link TL-WR841N v8 (Only Wi-Fi AP)

Both running 19.07.1. The 2 TP-Links are connected via cable with the main unit. When a device is connected via Wi-Fi to the main unit the hostname and IP-address are displayed in the Host section:

android-df55e4111e898ea3.lan (192.168.1.157, fe80::522e:5cff:fed3:a9c3)

When the same device is connected to either of the APs only the IPv6 address is displayed as hostname.

fe80::522e:5cff:fed3:a9c3

When a device has only an IPv4 address then this one is shown.

192.168.1.157

Why isn't the proper hostname shown on the APs? What am I missing?

I disabled (not installed) all packages that I don't need. Would I need dnsmasq for this?

This is expected behaviour: hostnames are stored on the DNS, which is only present on the main router.

Are you using the main router to resolve addresses in the APs?

Yes. The APs have no dnsmasq or any other resolver installed, everything is done on the main router.

Which is fine, but how do I enable a reverse DNS lookup?

What is the output of:
uci export network; uci export dhcp; ls -l /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

I'm having a similar setup (Main Router OpenWrt >> AP OpenWrt). I had to untick "Filter private" under Network >> DHCP and DNS >> Advanced Settings and put the DNS server and Gateway IP of my main Router into the LAN Interface to show the real hostnames on my AP. For some reason it doesn't work for my guest LAN/Wifi Interface/Network, so all the guest clients which are connected to my AP are showing as "?" in Luci. I guess it's related to my ebtable setup (to fully isolate guest clients)...

Afaik you have to untick "Filter private" in the Advanced Settings under the Network >> DHCP and DNS (Do not forward reverse lookups for local networks).

Please let us know if it works for you...

2 Likes
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbc:465a:a93b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0 eth1'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'

config interface 'lan6'
	option proto 'dhcpv6'
	option ifname '@lan'
	option reqaddress 'try'
	option reqprefix 'auto'

uci: Entry not found
lrwxrwxrwx    1 root     root            16 Jan 29 17:05 /etc/resolv.conf -> /tmp/resolv.conf
lrwxrwxrwx    1 root     root            21 Feb  5 16:50 /tmp/resolv.conf -> /tmp/resolv.conf.auto
-rw-r--r--    1 root     root            96 Feb  5 16:51 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
# Interface lan
nameserver 192.168.1.1
search lan
# Interface lan6
nameserver fd37:5e50:6b20::1

==> /tmp/resolv.conf <==
# Interface lan
nameserver 192.168.1.1
search lan
# Interface lan6
nameserver fd37:5e50:6b20::1

==> /tmp/resolv.conf.auto <==
# Interface lan
nameserver 192.168.1.1
search lan
# Interface lan6
nameserver fd37:5e50:6b20::1

Since I don't have dnsmasq running I don't have these settings.

Oops, than I've no idea how you could get it done.