Assigning an IP to a TP-Link repeater

I have an old TP-Link repeater that I am trying to setup, but following the instructions from the manual, I can't access its web interface.

So, there are at least 2 methods to start configuring the device.
Method 1 - via repeater app Tether
Method 2 - via

Using method 1, we have to connect to the repeater WiFi (which I do and get an IP -, and then the app should find the device. However, my app simply can't find it, no matter what I do.

Using method 2, also after connecting to the repeater WiFi, we should be able to access to and we shoul be able to access the repeater web interface to set it up to connect to my home WiFi. However, I can't access this site. It simply redirects me to a page saying: Ups, it seems you may have run into an issue and suggests me to use the app. It also have other scenarios but are not the case here, eg. if by any chance my home WiFi name is the same as the TP Link repeater.

This said, I was trying to connect the repeater with an RJ45 cable to my router so that it could get an IP address and maybe that way I could access its web interface. However, it seems that for some reason, or the router is not neing able to assign an IP to the repeater or the repeater itself is not even requesting one.

So, I was trying to assign an IP to this device manually, and it's here where I need help because my networking skills/knowledge are very limited!
How can I manually assign an IP to this repeater?

I just noticed that if I connect the repeater to my router via RJ45 cable and if I connect other devices to this repeater WiFi, I actually have internet connection. But no repeater interface! :expressionless:

Is this device running openwrt?

TP Link WA850RE is the device. I don't think it uses OpenWrt. The point here is that I am asking help with my router, which is using OpenWrt, to assign manually an IP to this repeater.

Since the device you are trying to configure is not running openwrt, you should ask on the tp-link support forums. This board is focused on openwrt and therefore doesn’t specialize in support for other firmware.

I understand, but I'm just asking help to assign an IP to this repeater, manually! If this is still out of context to this forum, I'll close the thread (or ask to).

But the method to do this is going to be specific to the firmware that is on it. unless you are asking how to assign an address via the openwrt dhcp server??

Yes, it was exactly that. To use the router dhcp server to assign an IP manually to this device, so that I could then access the repeater web interface!

So the repeater must be set to obtain an ip via dhcp. Then from there, openwrt offers static leases in the dhcp server.

But is it possible to set the repeater to obtain the IP via DHCP? How can I do that if I have no access to any configuration interface?

For that, you must seek out the documentation from tp-link or ask for help from their support channels. That is not openwrt and is therefore not going to be something that you’ll likely get help for here. I would answer if I knew, but that is very specific to the device you are using and tp-link’s firmware - I’d have to be an expert on that device to tell you.


The WA850RE (v5) I have allowed me to use both your methods 1 and 2. I suppose you've already reset it to it's defaults and tried from there ?

If that doesn't work, please let me know and I'll document the steps I need to do here to get to the interface.

1 Like

this have nothing to do with openwrt

My device says Ver: 1.2 in the back.
I have already performed reset countless times.

Any help would be appreciated.

We all already know, but if there is someone willing to help me, I'm not going to ignore it!

I have a WA850RE too, ver 6, and just tested and was able to access from the app as well, so maybe a problem specific to your older version? The only other thing I can think of would be to (if you haven't already) delete the app, restart your phone and reinstall/setup form scratch to see if it connects.

1 Like

I just tried it. And I hit reset on the repeater again. This time, when connecting to the repeater WiFi, I get an error on my phone saying it couldn't get an IP address.
So, somehow, or the repeater is not even requesting new IP or somehow, an IP cannot be assigned to this device.

When I connect to the repeater WiFi, from my phone, who's acting as the DHCP server? The repeater or my phone?

It should be OpenWrt acting as DHCP server, although I just noticed in the tp-link settings under network the DHCP server is set to auto, so you could set yours to off to make sure OpenWrt is the DHCP server, also check that the Tp-link is in range extender mode, not access point.

But how can I set anything in the repeater if I don't have access to any of its settings?

Have you referred to the user guide or setup instructions on tp-link’s website??

If you're referring to this guide:

yes, those are the 2 methods I already described above and tried! Web interface and Tether app.

You can't connect by ethernet either? Also, ignore, my suggestion about changing tp-link DHCP server from auto to off, apparently auto=on and I just tried with off and didn't get an ip (been a while since ive used this tp-link).