Assigning an IP to a TP-Link repeater

Ok, ignored. Even if I wanted to do it, I wouldn't know how to do it because I have no access to any settings!

So, what you suggest is that I connect it via ethernet (RJ45 cable) and then, go to my router OpenWrt (Luci) at Network -> DHCP and DNS -> Static Leases and then add there a static IP to the mac address of the repeater?

I'd suggest resetting the Tp-link again, connect to it by rj45 and follow the quick setup to connect to your network manually, once you're sure you're connected, then assign a static ip for it in OpenWrt ( you should probably reboot the openWrt router before assigning a static ip to clear any old connections), then see if the app finds it, if not, I'm not sure what else to try.

Let me just clarify:

1 - Reset TP-Link
2 - Connect it via RJ45 cable to my OpenWrt router
3 - Follow the quick setup to connect to the TP-Link WiFi, right? <-- I need clarify here because if I'm using RJ45 and then if I'm supposed to connect to the Wifi of the repeater, then, this makes me confused!
4 - Set the static IP as I described above
5 - Try to find the repeater in the app or via web interface!

I'll come back tomorrow. Need to go to bed.
Thanks everyone, for today!

The Tp Link quick setup is what connects the Tp link to your OpenWrt, everything else, yes.

edit - sorry, misread #2, connect to the tp link by rj45 to your computer, not openwrt router

Here's what works for me (TL-WA850RE (EU) v6):

  • put unit in socket without network cable plugged
  • keep reset pressed for 10+ seconds (blue light flashes, then only shows power)
  • check network for existence of TP-Link_Extender AP (not secured)
  • connect to TP-Link_Extender AP
  • check for gateway IP ( for me)
  • use the browser to connect to http://[gateway IP]

Hope that helps

I tried that procedure but when I press the reset button, after like 5 secons, all leds blink a couple of times, then, the power led stays steady. After a few more secons, the WiFi starts blinking. Then, I try to connect to the repeater WiFi but I get Failed to obtain IP address.

I also tried to set a static IP to the TP-Link repeater Wifi - - an then tried to access it via web browser with but I get a "Web page not available - net::ERR_CONNECTION_REFUSED"

Ok, what about #3?? Can you please clarify?

Don’t you think it might be faster to get answers from tp-link or their support forums?

I'm already there and there is 1 reply since yesterday. So, no, it's not faster for sure. :stuck_out_tongue:

Reset the TpLink and connect it directly to your comp with the rj45, there's no reason why it shouldn't connect to if at defaults, the quick setup should be the first thing you see (unless it's different on version 1), it scans for networks, just find yours and connect, once connected you'll see it in OpenWrt and can set a static ip.

Hmm, perhaps you alteady tried, but the final suggestion I’d have is to skip the wireless connection, and connect directly over wire from pc to wa850re. This should result in a connection with a gateway. Then through this gateway you should be able to access the webUI (http://[gateway IP].

If this also doesn’t work, I’d consider your device broken, and look for a replacement…

Somehow right now, via RJ45, I can see an IP but I still can't access to any web interface.

$ sudo ifconfig -a
enp3s0f2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::661e:58f3:c055:1df8  prefixlen 64  scopeid 0x20<link>
        ether 00:90:f5:d2:7d:56  txqueuelen 1000  (Ethernet)
        RX packets 72  bytes 8367 (8.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 880  bytes 85074 (83.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I see no gateway.

Also tried the default IP:

The returns this:

One more image:

I'm out of ideas at this point, it looks like your version might work with an older version of OpenWrt if you wanted to give that a try.

Final comment from me as I mimicked the wireless setup from the OP.

  • Set up WPA2 PSK SSID for WA850RE to connect to on OpenWRT 22.03.0 rc6 router
  • Set the WA850RE up as extender
  • Confirmed WA850RE connects to router
  • Checked DHCP for WA850RE MAC (separate non-OpenWRT router) :
    172.xx.xx.xx xx:xx:xx:xx:xx:xx 2022/09/29 21:18:35 VLAN17xx TL-WA850RE
  • Connected from wireless client (iphone) to the IP listed (172.xx.xx.xx)
  • Got presented webUI

If this can not be reproduced with your unit, I'd bet it is damaged. I checked mine, and the unit does not seem to support tftpd. Hence serial connection inspection would likely be indicated in case you'd want to try to resuscitate the device...

You mean to install an older version of OpenWrt in my router? It's out of question because I can't go out of internet and it doesn't worth the struggle. But thanks for the link and suggestion.
However, that link seems to me to be for the case we wanted to install OpenWrt in this repeater, which is not the case!

For the first step, you mean to manually create a WiFi network in Luci for the repeater, ahead of connecting the repeater to the mains plug?

As for the second step, you mean to set up the above manually created WiFi as extender, meaning as a client and not an AP?

I'm not sure I understand the steps 3 and 4 because that is something I could never do, at least up to now - connect the repeater to the router and get an IP I can use to access the repeater web interface!

Yes, but this is only to mimic your situation, in which you're using the WA850RE as extender. So this suppose this is already set up. If it isn't (or you want to start over) you can of course set it up again.

Indeed, the extender acts as a client. AP mode would be with wired backhaul (which I myself used exclusively with these devices...)

For me, I can also not access through the router, but it does work through wifi.

However, I would recommend to connect with a cable from a PC first as mentioned in my previous post (in case you hadn't already tried).

There are at least 7 versions of the WA-850RE. The first step would be to identify your version from the nameplate label. Go to the TP-Link site, after searching for model WA-850RE and going to the model's support page, make sure to choose your version in the pull-down box. Then read the quickstart guide and the manual for your version.

Resetting a TP-Link (or almost anything other than Mikrotik) stock firmware usually consists of:

  • Plug the unit in and allow time for it to boot fully.
  • Press and hold the reset button for at least 5 seconds then release.
  • All the lights should blink out and then the unit reboots with defaults.

Ok, allow me to try to follow steps where I connect the repeater via RJ45 to my laptop.
From this point I connect the repeater to the mains plug, let it boot, reset by press the reset button for 5 secs or more.

Then, when I go to my laptop and I try to connect to enp3s0f2 device, Debian can't establish the connection. However, if I go to the settings of this connection, and set manual IP to (for instance), netmask to and gateway to, Debian can already establish a connection. However, what I think I did is to set an IP to the laptop network card, not to the repeater!

So, if I try to access that manual IP I simply get the nginx welcome page!

The instructions are pretty much the same no matter the version. I've been at those instructions. It didn't work via nor via Tether app.

While running unconfigured, it should broadcast an open AP on wifi and offer a network including a DHCP server on the Ethernet port. Connect to either of those with a laptop then use a web browser on the default IP from the instructions.