ARV752DPW Easybox 802 - sysupgrade to LEDE


I was surprised to find the Easybox 802 among the devices ideally suited for LEDE, because I have been struggling to put OpenWRT on it more than 4 years ago.

Now I wonder whether my existing OpenWRT installation simplifies things - or will rather complicate them.
My flash layout differs from the one in the OpenWRT Wiki. The LEDE Wiki does not (yet?) have much info on it..

On my box:
root@OpenWrt_802:~# cat /proc/mtd
dev: size erasesize name
mtd0: 00030000 00010000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 007b0000 00010000 "firmware"
mtd3: 0015b90d 00010000 "kernel"
mtd4: 006546f3 00010000 "rootfs"
mtd5: 00340000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "board_config"

In the Wiki:
dev: size erasesize name
mtd0: 00010000 00002000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 007d0000 00010000 "firmware"
mtd3: 001759b3 00010000 "kernel"
mtd4: 0065a64d 00010000 "rootfs"
mtd5: 00350000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "board_config"

Maybe the Wiki is outdated? Or U-Boot has changed since I installed my hand-crafted version.
My concern is: If I now flash the current LEDE image, will it overwrite a part of my old U-Boot installation?
Or will it be written to the wrong location and fail to find the kernel start address?

Should I flash a new U-Boot image first?

OK, so the OpenWRT Wiki still has the old layout from Attitude Adjustment, and the u-boot compiled by myself had the correct layout.
Thus, I decided to just try a sysupgrade - and ended up in a boot loop.
U-Boot gave an lzma decompression error and started over.
So I had t replace my uboot. The only other (recommended) image I found was .
I gave it a shot - and shot myself in the foot.
This is one of the very old images without any loadx, loadb, etc. and with a broken switch - so no network either.

I corrected the kernel_addr, so that it now will at least load the kernel.
The kernel then panics with:
[ 0.884660] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[ 0.890631] Please append a correct "root=" boot option; here are the available partitions:
[ 0.898743] 1f00 64 mtdblock0 (driver?)
[ 0.903560] 1f01 64 mtdblock1 (driver?)
[ 0.908460] 1f02 8000 mtdblock2 (driver?)
[ 0.913359] 1f03 64 mtdblock3 (driver?)

I tried
bootargs=root=/dev/mtdblock2 ro rootfstype=squashfs,jffs2 ip= init=/etc/preinit console=ttyS1,115200 ethaddr=23:b0:48:66:52:e5
to no avail.

I tried to load the kernel manually with
bootm ${kernel_addr} - root=/dev/mtdblock2 ro rootfstype=squashfs,jffs2 ip= init=/etc/preinit console=ttyS1,115200 ethaddr=23:b0:48:66:52:e5
but this did not work either.

What am I doing wrong?
I guess the boundaries of mtdblock2 are just incorrectly defined in this u-boot?
So mtdblock2 starts at 0x00020000 when it should start at 0x00040000 and there is no way to start the kernel from this u-boot?

Does anyone have a known good u-boot for the arv752dpw aka Easybox 802? Maybe even with decent functionality?