Arcadyan ARV752DPW right image and U-Boot


as on the device page asked by tmomas already 4 month ago, I want to test if the documented wifi issues are still valid with the new versions. So I connected my arv752dpw (with stock firmware) to a serial adapter and backed it up like it is described on that page.

This worked well, but now I am a bit confused which image I should use. In the older Versions (chaos calmer and below) there was an image ending to "-squashfs.image". In the newer versions (17 and 18) there is only a "-initramfs-kernel.bin" and a "-squashfs-sysupgrade.bin". i.e.:

Does this mean I have first to install a chaos calmer or older version and then upgrade from that? Or can I just use the "sysupgrade.bin" like the ".image"?

I'm also unsure with the on the device page linked U-Boot because someone already tried to boot a LEDE with this loader which didn't worked in this post last year:

I have seen that in the v18 directory there are new U-Boot files available, which are bigger in size:

Should I use them instead? Can I also use them to test older versions if necessary?

Thank You very much for our help!


Disclaimer: no warranties (although lantiq is hard to brick), check this quick overview against the wiki for sanity, as I don't own that particular device.

File names certainly have changed, but the procedures themselves are still largely the same. Which ones to use depends massively on which procedure you're going to pick.

Similarly you can tftpboot from u-boot, you need to boot into this initramfs image to flash the actual firmware (after you have u-boot installed). Once booted into the initramfs image, you can simply sysupgrade

You need the old u-boot version if you want to use images from master, 18.06 or 17.01.
This is because the partition layout for arv752dpw is with a 64k bootloader partition and never has changed for the new bigger uboot version...


			partition@0 {
				label = "uboot";
				reg = <0x00000 0x10000>;

			partition@10000 {
				label = "uboot_env";
				reg = <0x10000 0x10000>;

There are two options:

  • Use old bootloader with 64k size
  • Change partition layout to give the bootloader more space

If you don´t do one of the mentioned two options, then you will overwrite the "big" bootloader on a sysupgrade!!!

For me there is no network working from within the old and the new uboot version, so no tftp boot...
But you can upload everything with serial. (ymodem, xmodem)

There was a bug filed for uboot on the arv752dpw here:
The broken uboot is being carried on uncorrected in all eternity, because changing it would lead to a new start address for the kernel partition.
I really believe backwards compatibility should be finally given up in this case, so that more modern (and properly working) uboot versions could be used.
There is really no reason for this "special treatment" of the arv752dpw, other than that it was simply overlooked when all other systems (like the arv752dpw22) got new uboot and new partition layout.

Thank you for providing the Information about the bootloader.

I flashed the old 64k bootloader and then started testing with v12.09 to get familiar with the flashing, because people worked already with this version when starting to write the dev Page.
-> WiFi offered only 72MBit Max and is extremely slow and crashing soon.
Then I flashed v14.07. -> WiFi offered now 144MBit is faster round about 20MBit but still slower then stock firmware which is over 40MBit in this mode.
Then I flashed v15.05. WiFi never comes up with this version, but I haven't seen the PCI errors described in some of the ticket - maybe this was only in the rc versions of v15. So I hoped that I haven't overwritten the last 64k which may contain some firmware for the WiFi and flashed again v14.07. -> WiFi worked as before.
Now I wanted to see if the new Version so I sysupgraded to v18.06. For the first minutes it seams that WiFi works better even with speeds nearly to 40MBits, but then it was crashing again. Speed is since then also round about 20 MBit or slower. You get error on the console like this:

ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
ieee80211 phy0: rt2x00lib_rxdone_read_signal: Warning - Frame received with unrecognized signal
ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 2
Please file bug report to

Question is now what to do next here. the rt2860T is now over 10 Years old, but the driver still seams not to work. serialmonkey seams not to work on his driver any more. The net is full with tweak tips for x86 Linux including to try different kernels - and newer means not better all the time...

Here the datasheet:

Here someone describes a mt7610u driver directly from meadiatec should work:

For the rt2860 mediatec (the new owner) seams to offer only Windows and Mac drivers - even if there is a penguin:

Here someone worked on a v2 for openwrt somehow:

Sometimes there is also described a rt2860sta driver which was form Ralink itself which should work better?

Should I open a extra thread here in the forum for that? Are there any better options? Or is the only Option to wait for a new version which may support the device magically?

Because of the partition thing: I also think that not really many people use openWRT on that box for now because it isn't realy supported and working. I searched a lot before I started, and found only less than a hand full written in their blog and also the responses to that were very rare and old. For the arv752dpw22 you can find more actual information. So I think it would be a good time to change it, but a full Image (no sysupgrade) would be nice, to flash it directly from the bootloader. But be aware to not overwrite the last 64k! The Option to restore the last 64k from the backup every time like descried on the arv752dpw22 dev page is also not a very good solution.


i am also still intressted in what happens with that topic here. I also have a few 602/802/803 and 904 devices here. Also newer devices and with all devices it seems that the old dogs are nearly as unusable as the new one's and also the new mediathek devices still use sometimes the rt2860 chipset.

So I tried to conclude all a bit in this topic and would love if someone wants to contine this topic to get some usable and working devices out of this old routers:

I would also love to get any news about these devices.