Archer C7 v4 support

Good day everyone. I just received this Archer C7 V4 EU router and I want to flash it but I want to ensure that it's ready for this operation,.

Trying to do some research and it would seem that this isn't ready yet or doesn't have a gui. as per this link anyway.

https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c7_v4

Is this working already or should I wait some more?

You can install the gui with opkg update && opkg install luci

Does the rest of the O.S work with this Router? The idea of a snapshot being installed sounds like it might not be ready for release.

Hi everyone :slight_smile:
I've had this device since November and it worked perfectly fine as my home router with the r5126-8348106 snapshot; last week I flashed the r6672-b28e995fc7 one and it works fine too, no problem of any kind so far.
So, @ApertureSecurity, I think you can be safe even if they're snapshots.

I managed to brick my device while updating, so I followed the "TFTP de-brick Alternative" found at https://wiki.openwrt.org/toh/tp-link/tl-wdr7500#tftp_recovery_de-bricking; the address to assign to the PC is 192.168.0.66 and the firmware to be served via TFTP (I used tftp-hpa) has to be named ArcherC7v4_tp_recovery.bin.
Just thought that can be useful to share the correct setup as I had to try a few before succeeding :wink:

2 Likes

First hand unbricking information for Archer C7 v4 (see Flash instruction using TFTP recovery):
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=9887afb1afcf387f6892315413e610a6816df463

1 Like

There seems to be a regression with respect to the sysupgrade process introduced recently into the trunk, the 4/19 and 4/20 builds can do factory firmware replacements, buy a OpenWRT (trunk) -> OpenWRT (trunk) sysupgrade bricks the unit.
See this thread: Archer C7 V4 brick on sysupgrade from Luci

1 Like

Hey just following up here . Archer C7 V4 works perfectly fine! ( This includes Vlans and AC wireless ) You just have to install Luci in the end and that is cake.

I just bricked my Archer C7 V4 EU with today update. Flashed upgrade erasing configuration via Luci. Router didn't reboot. Power recycle after few minutes results in one short green blip for 1s then all dark.
I suggest to avoid today sysupgrade until problem resolved. Will try to unbrick it I hope I will succeed.
https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c7_v4

Yesterdays (4/23) build was OK. So looks like the regression crept back in. I have not tested the 4/24 build yet.

1 Like

Based on separate thread problem may be not related with sysupgrade image itself but caused recent Luci https issue that corrupted sysupgrade file on flash (I previously flashed build from last Friday, I assume it was build 2018-04-19 or 2018-04-20). I managed to unbrick it, described in in this thread -> Archer C7 V4 brick on sysupgrade from Luci

I just flashed today nightly for tp-link Archer C7 V4 EU. VLANs work, except are broken.
Today image has identical switch issue as described here -> Problem with VLAN tagging on DIR-860L (MT7530)
Real life example based on my use case:
My ISP provider gives FTTH via ONT. I authenticate with PPPoE session on VLAN 35 on ONT.
In order to properly connect my PPPoE session to VLAN 35 I have to create 33 dummy VLANs tagged to CPU otherwise IT DOESNT WORK!
So only working solution to have VLAN 35 working is workaround like this:

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config interface 'wan'
        option proto 'pppoe'
        option username 'XXX@neostrada.pl'
        option password 'XXX'
        option ipv6 'auto'
        option ifname 'eth0.35'
        option mtu '1492'

config interface 'wan6'
        option proto 'pppoe'
        option password 'XXX'
        option ipv6 'auto'
        option ifname 'eth0.35'
        option username 'XXX@neostrada.pl/ipv6'
        option mtu '1492'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '4'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '5'
        option vid '5'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option vid '6'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '8'
        option vid '8'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option vid '9'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option vid '10'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '11'
        option vid '11'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '12'
        option vid '12'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '13'
        option vid '13'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '14'
        option vid '14'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '15'
        option vid '15'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '16'
        option vid '16'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '17'
        option vid '17'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '18'
        option vid '18'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '19'
        option vid '19'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '20'
        option vid '20'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '21'
        option vid '21'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '22'
        option vid '22'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '23'
        option vid '23'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '24'
        option vid '24'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '25'
        option vid '25'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '26'
        option vid '26'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '27'
        option vid '27'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '28'
        option vid '28'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '29'
        option vid '29'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '30'
        option vid '30'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '31'
        option vid '31'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '32'
        option vid '32'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '33'
        option vid '33'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '34'
        option vid '34'
        option ports '0t'

config switch_vlan
        option device 'switch0'
        option vlan '35'
        option vid '35'
        option ports '0t 1t'

Yesterday I flashed the snapshot from here:
https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=Archer+c7+ac1750&dataflt[Versions*~]=v4

Everything seems to work fine. I also build nginx module with SSL support to manage reverse proxy with SSL. If anyone is interested, here can you download de nginx .ipk with SSL enabled: http://www.filedropper.com/nginx1122-1mips24kc

The 2.4G radio on the v4 is not functioning the same as v2. When running in monitor mode it is dropping all traffic above MCS 7. I have tested v4 side-by-side with a v2 both monitoring the same WiFi network. The captured packets show that all traffic above MCS 7 (~150 Mbs) is dropped on the v4.

The 20/40 bandwidth and SGI work correctly in both modes. That tells me that some 802.11n functionality is working correctly but multiple spatial streams probably are not.

Comparing the output of iw phy1 info on both devices shows that v2 has LDPC as one of its capabilities but v4 does not. I don't know if that is causing a problem or not. I know we must have LDPC capabilities.

I don't know where to start looking at this issue. Any help would be greatly appreciated.

1 Like

@magnumb, I don't have any advice to give you on how to proceed, but I have got to say that this is a fabulous bit of troubleshooting.

Hi guys. I just got a C7 V4 and I'm wondering if going to DDWRT (which i've been using for years) o going to OWRT/LEDE.

Is the snapshot currently good enough for home usage? I do not use fancy features, just TX power, Short Preamble, DDNS and port forwardings, with a 50mbit internet connection.

Thanks.

Should be fine in snapshots, both master (keep in mind that these don't have the webinterface preinstalled) and the openwrt-18.06 branch (which should have luci preinstalled).

Great! But it's odd I can't get 18.06 main in the downloads site, is it published elsewhere? I only see 18.06 packages.

Snapshots (with all the usual caveats) are available at http://downloads.openwrt.org/releases/18.06-SNAPSHOT/

These are snapshot builds and are not "release" firmware

1 Like

@jeff @slh thanks a lot guys, you've been very helpful. Let's see in a couple of days when my router arrives how all this goes!

When trying to do opkg install luci, i have an error about a missing dependency libiwinfo-lua. Is mips_24kc not supporting this ? Btw opkg list | grep iwinfo does list libiwinfo - 2018-05-18-e59f9253-1