Archer C7 V4 brick on sysupgrade from Luci

I grabbed the latest snapshot build for the Archer C7 V4 on 4/19/18. I used the factory image to flash from the TP-Link factory firmware. That worked fine. However, I then installed Luci and tried to use the sysupgrade image to flash from the OpenWRT Luci firmware upgrade page. The image was accepted and looked to flash. Once the C7 V4 rebooted it was bricked.

I still have my C7 V4 snapshot from a couple of months ago so I flashed back to TP-Link factory and then went through the same steps with the older OpenWRT images and it worked fine (first flash with factory from TP-Link then sysupgrade from Luci).

So, it looks like the most recent image has some issues on firmware upgrade from Luci. I have a friend who also has a C7 V4 and he is seeing the same problem.

Anyone else seeing this problem?

1 Like

Yep, I'm also seeing this using the 4/20 builds on a C7v4. A sysupgrade to the same build fails, so something is messed-up with the sysupgrade process in the current trunk.

For target mvebu, sysupgrade has been broken for ~3 days, resolved as of today, I assume the same issue.

Likely caused by (new HTTP data parser corrupted data). Should be fixed with liblucihttp >= 2018-04-20

I just bricked my tp-link Archer C7 V4 EU with today sysupgrade while flashing via Luci firmware upgrade (with erasing config selected).
If I manage to unbrick I will let you know if Luci bricking flash issue was rectified.
Accordingly to this info I am supposed to hold WPS button while boot on to light WPS light and enabling tftp recovery. In case of tp-link Archer C7 V4 EU power blinks for 2s and WPS never lights up. Could you help with unbricking, any suggestion how to start recovery on rourter?
This wiki is for other models but is supposed to work.

1 Like

The C7v4 uses a slightly different mechanism to initiate the TFTP request:

On the back, next to the power button, there is small pinhole labeled 'Reset'. Using an unbent paper-clip, you press the inset button while simultaneously turning the power On with the Power button. Continue to hold in the reset button until the WPS light on the front panel lights up, then you can let go of the reset button. The TFTP starts when the WPS light lights up. Then wait for the flash and reboot to occur.

1 Like

Thanks for suggestion, on TP-Link C7 V4 EU tftp recovery started by holding reset while booting.
I managed to unbrick it based on general suggestion in guide:
I changed my PC IPv4 address to and gateway to
I used tftpd32 win32 "portable" (x64 version of tpftdp didn't work for me - To start tftp recovery on router side I powered router while pressing RESET using shaped pin.

I downloaded factory image for tp-link C7 V4 EU (openwrt-ar71xx-generic-archer-c7-v4-squashfs-factory.bin), renamed it to ArcherC7v4_tp_recovery.bin . Log from tftpd

Connection received from on port 1948 [24/04 19:17:31.970]
Read request for file <ArcherC7v4_tp_recovery.bin>. Mode octet [24/04 19:17:31.970]
OACK: <timeout=5,> [24/04 19:17:31.970]
Using local port 53288 [24/04 19:17:31.970]
<ArcherC7v4_tp_recovery.bin>: sent 7373 blks, 3774720 bytes in 2 s. 0 blk resent [24/04 19:17:33.424] 

I was able to log in using puTTY as root with no password.

login as: root

BusyBox v1.28.3 () built-in shell (ash)

 _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
         |__| W I R E L E S S   F R E E D O M
OpenWrt SNAPSHOT, r6755-d089a5d
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.

I updated general recovery information for this device based on my experience to device page